You are Here:
Linux Lite 6.0 Final Released - See Release Announcements



Install Updates Error

Author (Read 588 times)

0 Members and 1 Guest are viewing this topic.

Install Updates Error
« on: May 30, 2022, 04:54:32 AM »
 

BibleGeezer

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: AMD A9-9425 RADEON R5

  • MEMORY: 8Gb
===========================
Install Updates Error log
===========================
Install Updates could not successfully download and install available updates.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 3781 (apt-get)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
 

Re: Install Updates Error
« Reply #1 on: May 30, 2022, 05:42:45 AM »
 

stevef

  • Global Moderator
  • Forum Regular
  • *****
  • 245
    Posts
  • Reputation: 33
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Updating requires exclusive use of some resources and this message indicates the update process cannot get the resources at this time.

Maybe a scheduled task is running in the background in which case simply waiting and trying again should work or there may be a package manager (like Synaptic)  open in which case the update can run after the package manager has been closed.

 
 

Re: Install Updates Error
« Reply #2 on: May 31, 2022, 04:12:28 AM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 181
    Posts
  • Reputation: 9
  • Linux Lite Member

  • Linux Lite: 6.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 3781 (apt-get)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
Hi! :)
The message explains exactely what went wrong:
Either you were using GDebi to install something BEFORE triggering the Update sequence, OR,
You were using Synaptic Package Manager, OR,
You were using apt-get itself, for whatever installation of something.
Since the update process IS EXCLUSIVE (as explained in the post before).
Now, each time you trigger the "Update Software" process, remember to check if any instance of the processes listed above is ACTIVE, and if so, CANCEL the Update and finish the job at hand. After that, you can use the Update sequence.
Although I am using Linux on a daily basis for more than 10 years, it sometimes happens to me :( (with Synaptic PM) so "I've been there", as we say...
I recognized the error message.

I hope you'll get to the end of the Update with this! :)
IF this solves the issue, please, remember to mark the thread as SOLVED :)
All the best! ;)
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: Install Updates Error
« Reply #3 on: June 01, 2022, 09:27:59 PM »
 

Rodney H.

  • New to Forums
  • *
  • 1
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM) i7-7700

  • MEMORY: 32Gb

  • VIDEO CARD: NVIDIA GeForce GTX 1660

  • Kernel: 5.x
While I don't consider myself as being new to Linux, I am by no means an expert. I am too receiving an error message while trying to do updates. I will post below.
============ Log ===========

Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages were automatically installed and are no longer required:
  gir1.2-gdesktopenums-3.0 gir1.2-gnomedesktop-3.0
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  linux-modules-nvidia-470-5.4.0-91-generic
The following NEW packages will be installed:
  linux-headers-5.4.0-113 linux-headers-5.4.0-113-generic
  linux-image-5.4.0-113-generic linux-modules-5.4.0-113-generic
  linux-modules-extra-5.4.0-113-generic
  linux-modules-nvidia-470-5.4.0-113-generic
  linux-objects-nvidia-470-5.4.0-113-generic
  linux-signatures-nvidia-5.4.0-113-generic
The following packages will be upgraded:
  alsa-ucm-conf apt-transport-https balena-etcher-electron bind9-dnsutils
  bind9-host bind9-libs bluetooth bluez-cups bluez-obexd command-not-found
  cpp-9 cryptsetup cryptsetup-bin distro-info-data dnsmasq-base dnsutils dpkg
  dpkg-dev firefox fonts-opensymbol g++-9 gcc-9 gcc-9-base
  gir1.2-javascriptcoregtk-4.0 gir1.2-nm-1.0 gir1.2-webkit2-4.0 grub-common
  grub-pc grub-pc-bin grub2-common gtk-update-icon-cache gvfs gvfs-backends
  gvfs-bin gvfs-common gvfs-daemons gvfs-fuse gvfs-libs iio-sensor-proxy
  initramfs-tools initramfs-tools-bin initramfs-tools-core klibc-utils kmod
  language-pack-en language-pack-en-base libarchive13 libasan5 libbluetooth3
  libcurl3-gnutls libcurl3-gnutls:i386 libdpkg-perl libevdev2 libexiv2-27
  libgcc-9-dev libgtk-3-bin libinput-bin libinput10
  libjavascriptcoregtk-4.0-18 libjuh-java libjurt-java libklibc libkmod2
  liblightdm-gobject-1-0 libmysqlclient21 libmysqlclient21:i386 libnetplan0
  libnm0 libnss3 libnvidia-compute-470 libnvpair1linux libpcre16-3 libpcre3
  libpcre3:i386 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpython3.8
  libpython3.8-dev libpython3.8-minimal libpython3.8-stdlib libqt5core5a
  libqt5dbus5 libqt5gui5 libqt5network5 libqt5widgets5
  libreoffice-avmedia-backend-gstreamer libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome
  libreoffice-gtk3 libreoffice-impress libreoffice-pdfimport
  libreoffice-style-colibre libreoffice-style-elementary
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libridl-java libsasl2-modules:i386 libsepol1 libsepol1-dev libsmbclient
  libspeex1 libspeex1:i386 libspeexdsp1 libstdc++-9-dev libuno-cppu3
  libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3
  libuno-salhelpergcc3-3 libunoloader-java libuutil1linux libvkd3d-shader1
  libvkd3d-shader1:i386 libvkd3d1 libvkd3d1:i386 libwbclient0
  libwebkit2gtk-4.0-37 libxatracker2 libxnvctrl0 libzfs2linux libzpool2linux
  lightdm lintian linux-firmware linux-generic linux-headers-generic
  linux-image-generic linux-libc-dev linux-modules-nvidia-470-generic
  lite-welcome lite-widget lm-sensors lutris mesa-va-drivers
  mesa-va-drivers:i386 mesa-vdpau-drivers mesa-vdpau-drivers:i386
  mesa-vulkan-drivers:i386 netplan.io network-manager networkd-dispatcher
  nvidia-common nvidia-kernel-common-470 openssh-client openssl openvpn passwd
  python-apt python-apt-common python3-apport python3-apt
  python3-commandnotfound python3-distupgrade python3-lxml python3-pil
  python3-problem-report python3-samba python3-update-manager python3.8
  python3.8-dev python3.8-minimal rfkill rsync rsyslog samba samba-common
  samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules sbsigntool
  smbclient tcpdump thunderbird thunderbird-locale-en thunderbird-locale-en-gb
  thunderbird-locale-en-us tzdata ubiquity ubiquity-frontend-gtk
  ubiquity-ubuntu-artwork ubuntu-advantage-tools ubuntu-drivers-common
  ubuntu-release-upgrader-core uno-libs-private update-manager-core ure
  uuid-runtime vim-common vim-tiny vkd3d-compiler wine-stable
  wine-stable-amd64 wine-stable-i386:i386 wine-staging wine-staging-amd64
  wine-staging-i386:i386 winehq-staging xxd xz-utils zfs-initramfs zfs-zed
  zfsutils-linux
Preconfiguring packages ...
209 upgraded, 8 newly installed, 1 to remove and 0 not upgraded.
59 not fully installed or removed.
Need to get 0 B/1,085 MB of archives.
After this operation, 533 MB of additional disk space will be used.
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
 libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
  Package libmount1:i386 is not configured yet.
 libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libglib2.0-0:i386 (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: too many errors, stopping
Errors were encountered while processing:
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
 libglib2.0-0:i386
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Re: Install Updates Error
« Reply #4 on: June 01, 2022, 10:10:27 PM »
 

Ralph Bromley

  • Blue Bunny from outer space
  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 2

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-3230M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 4000

  • Kernel: 5.x
Well that seems to be a wine issue, its asking for i386 packages.
How did you install wine?
 

Re: Install Updates Error
« Reply #5 on: June 01, 2022, 11:36:01 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1786
    Posts
  • Reputation: 278
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x

Run the below commands  in terminal...
Code: [Select]
sudo dpkg --configure -a


sudo apt --fix-broken install
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: Install Updates Error
« Reply #6 on: August 03, 2022, 01:18:41 PM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 181
    Posts
  • Reputation: 9
  • Linux Lite Member

  • Linux Lite: 6.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
[...]dpkg: error processing package libglib2.0-0:i386 (--configure) [...]
Fixing this error, requires some patience.
In theory, the previous post should fix it.
For whatever reason, it refuses to work and the error message reasppears, for whatever reason this might be.

Here's what I did and it worked:

1. Go to Synaptic Package Manager. Select Edit --> Fix Broken Packages.
2. Go to Lite Tweaks and select Package System Repair --> Click Begin button.
3. Go to Synaptic Package Manager. Select Edit --> Fix Broken Packages.
4. From Synaptic, click on Mark All Upgrades then Apply.

This made the " libglib2.0-0:i386" issue go forever.
I remember that the libglib2.0-1:i386 triggers the same error.
Maybe reinstalling WINE, will make the error go, also.
I forgot if this was my case too. All I remember is that WINE used to work fine, then I updated and this error came forth.
Since it never crossed my mind to check WINE before fixing the issue, it's hard to say something else that I fixed it, than went further with the updates. After that, I never had this trouble again.
Good luck and best regards! :)

[later edit...]
Jerry, posted previously a fix to the same problem, for LL 5.8. See this post:

https://www.linuxliteos.com/forums/updates/install-updates-5-8-failed-too-install-dependency-errors/
Essentially, it is the same solution posted above.

Good luck! :)
« Last Edit: August 03, 2022, 01:31:37 PM by Şerban S. »
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: Install Updates Error
« Reply #7 on: August 03, 2022, 01:51:00 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1786
    Posts
  • Reputation: 278
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
Yes the above post on June 1 2022 was in direct reference to https://www.linuxliteos.com/forums/updates/install-updates-5-8-failed-too-install-dependency-errors/msg57892/#msg57892
posted March 24 2022  ;)
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

 

-->
X Close Ad

Linux Lite 6.0 Final Released - See Release Announcements