Linux Lite Forums

General => Security & Bug Fixes => Topic started by: thedoor on June 05, 2020, 11:11:13 AM

Title: Notification tool doesn't work
Post by: thedoor on June 05, 2020, 11:11:13 AM
NOTE: This issue has been resolved by Jerry in a fix shown below and a permanent fix is planned for a future update, if not already included in one.

On my LinuxLite 5.0 second install, the Notification tool is totally useless (also on the first install). No matter what setting I choose, nothing changes. It's always the same look and always in the upper right corner. When I change to a different look, the preview is always the same. The preview doesn't show the new setting. Also, the notification shows for 10 seconds, regardless of the timing set for it. It's useless to even have the tool, since using it doesn't change anything. Obviously something isn't working. It would be nice if it worked.
Title: Re: Notification tool doesn't work
Post by: firenice03 on June 05, 2020, 12:24:55 PM
@thedoor
I haven't yet installed LL5.0 but I believe it functions similarly to LL4.x...
Per the below from the release thread..


It Checks 2x per day and will only notify when there are updates
So there has to be updates since the last check in... Not sure of the settings... but if you could set say 1hr -- it will notify hourly not check for updates hourly..
Say it checks in at noon and midnight and nothing new, there will be "no updates" (not displayed) every hour  (even if there is and update available say at 1pm) it will display a "new update" at midnight (next check in) and every hour there after till updates are ran..




New Updater notifier:
(https://i.imgur.com/QrPHNji.png)


Enabled by default to check for updates twice per day, and only notify when there are updates.To disable, Menu Settings, Session and Startup, Application Autostart tab, untick Package Update Indicator.



If its more so to the duration.... I can't speak to as I haven't tried - perhaps another can...
Title: Re: Notification tool doesn't work
Post by: thedoor on June 05, 2020, 03:11:26 PM
firenice03,

Thank you for your response. However, you seem to be talking about the Package Update Indicator notification which deals with system software updates.

I wasn't talking about that. I was talking about the Notification Tool in general, which displays all kinds of notifications, like emails received, song changes, etc. No matter what I change in this tool's settings, nothing changes. The location is locked to the top right corner, even if I tell it to use bottom right or any other location, and the look (appearance style) is unchangeable, though there's a list of different styles from which we should be able choose.
Title: Re: Notification tool doesn't work
Post by: Jerry on June 05, 2020, 05:13:16 PM
Confirmed. Let me work on a solution and get back to you.
Title: Re: Notification tool doesn't work
Post by: Jerry on June 05, 2020, 05:20:05 PM
Fix:

Code: [Select]
sudo apt-get remove notify-osd notify-osd-icons
Log out and in again.

I'll deploy this in a coming update.
Title: Re: Notification tool doesn't work
Post by: firenice03 on June 05, 2020, 07:44:51 PM
firenice03,

Thank you for your response. However, you seem to be talking about the Package Update Indicator notification which deals with system software updates.

I wasn't talking about that. I was talking about the Notification Tool in general, which displays all kinds of notifications, like emails received, song changes, etc. No matter what I change in this tool's settings, nothing changes. The location is locked to the top right corner, even if I tell it to use bottom right or any other location, and the look (appearance style) is unchangeable, though there's a list of different styles from which we should be able choose.
@thedoor
Oopps - Sorry, you can see where my mind went... Who said pics are worth a thousands words... LOL
Good job on the find and posting!!!

Looks like @Jerry is on it!!!
Title: Re: Notification tool doesn't work
Post by: thedoor on June 05, 2020, 08:00:45 PM
firenice03,

No problem. We all see things from a different point of view. Thanks for at least attempting to be helpful.
Title: Re: Notification tool doesn't work
Post by: thedoor on June 05, 2020, 08:05:13 PM
Thanks, Jerry. That solved the problem! You're the man!

I wanted to respond directly to you but I saw no way of responding to your post. So I figured you may have it set that way so you don't get inundated with responses.

Also, I tried to add [SOLVED] to the Prefix of this post, as described in the Posting Guidelines, but that item is no longer available in the drop-down list. So maybe there's some other way to mark it that way, or maybe you're not ready for it to be marked as solved, since the resolution you mentioned, which worked, will be updated into the code later.
Title: Re: Notification tool doesn't work
Post by: Jerry on June 05, 2020, 09:40:48 PM
There's no 'Solved' under the Bug section. This for me, is in the right section, it's something that was wrong with LL, and it will be fixed :)
Title: Re: Notification tool doesn't work
Post by: Jerry on June 06, 2020, 06:00:48 AM
Update uploaded. You will see a pause when you run Install Updates for the first time AFTER updating, that's just the software removing the offending packages in the background. I was going to show a msg but thought...nah :) It's a once 'r. Fix will be in 5.2