You are Here:
Translations are underway - See Linux Lite Software Development Section



Recent Posts

Pages: [1] 2 3 ... 10
1
Installing Linux Lite / Re: Installation of LL6.2 goes to GRUB
« Last post by stevef on Today at 01:59:34 AM »
Further to Wytwun's link you can check the grub setting fairly quickly from the grub prompt.

Provided you have the grub> prompt (not grub rescue>) it implies grub is running but the necessary files aren't where grub thinks they should be.  This might be fixable but because your installation didn't complete the state is unknown and re-installation might be the better option.

Type
Code: [Select]
set
Look for the line beginning 'root=', it should look something like

Code: [Select]
root=(hd0,gpt1)
This is where grub is trying to boot from, make a note of it.
Begin checking what is actually on the disk by listing the partitions on the system

Code: [Select]
ls
The partition names should look something like
(hd0,msdos1) or (hd0,gpt1).  The numbers may be different on your system.

Now check each partition for a 'root/' directory.
Repeat the 'ls' command followed by a space, then each partition in turn and finally slash '/'.
Regardless of the 'msdos' or 'gpt', you only need the partition number.
The commands will look something like this, but replace the hd and partition numbers to suit your system.

Code: [Select]
ls (hd0,1)/
For any partition with a root/ directory you can investigate what may be on it.

Type
Code: [Select]
cat (hd0,1)/etc/llveragain, you must replace the disk and partition numbers with your system.  The 'llver' file (if found) should have a valid LL release number.  As you've tried to install 6.2, the contents of this file should be 'Linux Lite 6.2'

If you can't find the llver file showing 'Linux Lite 6.2' in any partition you need to re-install.

If the root partition line from the 'set' command is the same as the partition in which you found 'Linux Lite 6.2' then grub is set correctly and you probably need to re-install.

If the root partition line from the 'set' command is not the same as the partition in which you found 'Linux Lite 6.2' then grub can be changed from the grub command line.  However it may still not boot properly due to the failed install.

Let us know what you find and also what problems you had that lead you to the conclusion that system won't re-install.
2
Installing Linux Lite / Re: Installation of LL6.2 goes to GRUB
« Last post by WytWun on Today at 12:58:33 AM »
I ended up with this... "GNU GRUB version 2.4 minimal BASH-like line editing is supported.  For the first word, Tab lists possible command completions.  Anywhere else TAB lists possible device or file completions. "  Then I get a grub> command. 
This post may lead you to some resources that guide you through a grub recovery.
3
Installing Linux Lite / Re: Installation of LL6.2 goes to GRUB
« Last post by f23948 on November 26, 2022, 11:16:25 PM »
you can not upgrade from 5.x series to 6.x series. You need to clean install 6.2
4
Installing Linux Lite / Installation of LL6.2 goes to GRUB
« Last post by javier_mina on November 26, 2022, 06:05:26 PM »
I have been happily using Linux Lite for a number or years.  When I just tried to upgrade ver 5.8 with 6.2 etched on a USB, my installation started well going through location, network connection and so on but then went black.  When I rebooted, I ended up with this... "GNU GRUB version 2.4 minimal BASH-like line editing is supported.  For the first word, Tab lists possible command completions.  Anywhere else TAB lists possible device or file completions. "  Then I get a grub> command. 

It won't reinstall, just goes right back to the message and prompt.

How can I fix this?  Is my Dell laptop bricked?
5
Other / [ SOLVED ] ttyS0 permission denied
« Last post by timbuck2 on November 26, 2022, 09:22:31 AM »
I am trying to use the serial port to access a Lantronix mss100 via null modem cable - LL 5.4.

Using gtkterm, when I run the program I get a "permission denied" message.  How do I gain access to the serial port?






*Edit* Solved - I had to add myself as a member of the "dialout" group.  Now it is working.
6
Other / integrated/external webcam not working
« Last post by kamui on November 26, 2022, 07:44:48 AM »
Hello!

The integrated webcam is not shown at all in skypeforlinux/discord/cheese. The external webcam is shown, but the content is just black.
I have dual boot with Windows 10. The integrated webcam works there and the external one (Genius Eye 312) started to work after I installed its driver.
My laptop is ACER Nitro 5 AN515-58-789C and I found no keyboard shortcut in the user manual.

The system report: https://www68.zippyshare.com/v/Vf6ljuUW/file.html
I figured that the internal webcam is 0408:4035 Quanta Computer, Inc. ACER HD User Facing in lsusb.

cat /dev/video0 shows No such file or directory


sudo dmesg | grep -ni "uvc|facing":
Code: [Select]
988:[    2.822775] usb 3-6: Product: ACER HD User Facing
1115:[    5.023136] usb 3-6: Found UVC 1.50 device ACER HD User Facing (0408:4035)
1143:[    5.065102] usb 3-6: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
1145:[    5.068252] uvcvideo 3-6:1.1: Failed to query (129) UVC probe control : 26 (exp. 48).
1146:[    5.068255] uvcvideo 3-6:1.1: Failed to initialize the device (-5).
1147:[    5.068301] usbcore: registered new interface driver uvcvideo

The lines with "Failed to query" and "Failed to initialize" are with red.


guvcview output:
Code: [Select]
GUVCVIEW: version 2.0.7
V4L2_CORE: ERROR opening V4L interface: No such file or directory
GUVCVIEW (1): Guvcview error
no video device (/dev/video0) found
(guvcview:11537): Gtk-WARNING **: 14:22:13.768: Theme parsing error: <data>:1:17: not a number

(guvcview:11537): Gtk-WARNING **: 14:22:13.768: Theme parsing error: <data>:1:31: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(guvcview:11537): Gtk-WARNING **: 14:22:13.768: Theme parsing error: <data>:1:17: not a number

(guvcview:11537): Gtk-WARNING **: 14:22:13.768: Theme parsing error: <data>:1:32: Using Pango syntax for the font: style property is deprecated; please use CSS syntax


dmesg output for sudo rmmod uvcvideo && sudo modprobe uvcvideo:
Code: [Select]
[  595.311323] usbcore: deregistering interface driver uvcvideo
[  595.359025] usb 3-6: Found UVC 1.50 device ACER HD User Facing (0408:4035)
[  595.390062] usb 3-6: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[  595.393101] uvcvideo 3-6:1.1: Failed to query (129) UVC probe control : 26 (exp. 48).
[  595.393116] uvcvideo 3-6:1.1: Failed to initialize the device (-5).
[  595.393253] usbcore: registered new interface driver uvcvideo


dmesg output for plugging the external webcam:
Code: [Select]
[  732.172423] usb 3-1: new full-speed USB device number 5 using xhci_hcd
[  732.322341] usb 3-1: config 1 interface 0 altsetting 1 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322352] usb 3-1: config 1 interface 0 altsetting 2 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322356] usb 3-1: config 1 interface 0 altsetting 3 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322359] usb 3-1: config 1 interface 0 altsetting 4 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322362] usb 3-1: config 1 interface 0 altsetting 5 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322365] usb 3-1: config 1 interface 0 altsetting 6 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322368] usb 3-1: config 1 interface 0 altsetting 7 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322371] usb 3-1: config 1 interface 0 altsetting 8 endpoint 0x6 has invalid wMaxPacketSize 0
[  732.322381] usb 3-1: New USB device found, idVendor=093a, idProduct=2622, bcdDevice= 1.00
[  732.322387] usb 3-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[  732.346929] gspca_main: v2.14.0 registered
[  732.349691] gspca_main: gspca_pac7302-2.14.0 probing 093a:2622
[  732.350299] input: gspca_pac7302 as /devices/pci0000:00/0000:00:14.0/usb3/3-1/input/input24
[  732.350614] usbcore: registered new interface driver gspca_pac7302
[  732.361560] usbcore: registered new interface driver snd-usb-audio


guvcview output with the external webcam plugged in:
Code: [Select]
GUVCVIEW: version 2.0.7
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: Inappropriate ioctl for device
V4L2_CORE: failed to subscribe events for control 0x0098090c: Invalid argument
V4L2_CORE: failed to subscribe events for control 0x00980910: Invalid argument
ALSA lib pcm_dsnoop.c:601:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1032:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp
ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp
ALSA lib confmisc.c:160:(snd_config_get_card) Invalid field card
ALSA lib pcm_usb_stream.c:482:(_snd_pcm_usb_stream_open) Invalid card 'card'
ALSA lib confmisc.c:160:(snd_config_get_card) Invalid field card
ALSA lib pcm_usb_stream.c:482:(_snd_pcm_usb_stream_open) Invalid card 'card'
ALSA lib pcm_dmix.c:1032:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
V4L2_CORE: V4L2_CAP_TIMEPERFRAME not supported
control[0]:(unknown - 0x6) 0x980001 'User Controls'
V4L2_CORE: Could not grab image (select timeout): Resource temporarily unavailable
V4L2_CORE: V4L2_CAP_TIMEPERFRAME not supported
V4L2_CORE: Could not grab image (select timeout): Resource temporarily unavailable
^CGUVCVIEW Caught signal 2
V4L2_CORE: Could not grab image (select timeout): Resource temporarily unavailable


dmesg output of doing that:
Code: [Select]
[  971.161367] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for DAI Digital Codec DAI
[  971.161380] snd_hda_codec_realtek ehdaudio0D0: ASoC: error at snd_soc_dai_startup on Digital Codec DAI: -22
[  971.161387]  Digital Playback and Capture: soc_pcm_open() failed (-22)
[  971.161391]  HDA Digital: ASoC: dpcm_be_dai_startup() failed at Digital Playback and Capture (-22)
[  971.161395]  HDA Digital: dpcm_fe_dai_startup() failed (-22)
[  971.161481] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for DAI Digital Codec DAI
[  971.161485] snd_hda_codec_realtek ehdaudio0D0: ASoC: error at snd_soc_dai_startup on Digital Codec DAI: -22
[  971.161488]  Digital Playback and Capture: soc_pcm_open() failed (-22)
[  971.161491]  HDA Digital: ASoC: dpcm_be_dai_startup() failed at Digital Playback and Capture (-22)
[  971.161494]  HDA Digital: dpcm_fe_dai_startup() failed (-22)


The external webcam is listed in lsusb as Bus 003 Device 005: ID 093a:2622 Pixart Imaging, Inc. Webcam Genius.

If you need any other information, let me know.
Thanks!
7
Updates / Re: Verbose Update
« Last post by stevef on November 26, 2022, 03:18:44 AM »
I've not used MX or xubuntu so don't know what you are looking for.
Most Linux Lite systems show a progress indicator GUI throughout the update process.  A small number of systems don't get the on screen indication of anything happening between the points of accepting the updates and the updates completed dialog so you may be affected by that.

If you need to see what the update manager is doing in real time

Open a terminal window and move to the log directory with

Code: [Select]
cd /var/log
While the updating process is running use the following command in that window.

Code: [Select]
tail llupdates.log
This will show you the last few lines of the update progress log as it builds.
Repeating the command every few seconds should give you a close to real time indication of what is happening.

8
Updates / Verbose Update
« Last post by Yomiz on November 25, 2022, 05:04:55 PM »
Hi there!

Is there any way to receive feedback from the update manager (a la Xubuntu or MX or something similar) in order to know what it is doing at every moment while updating?

Thank you.
9
Installing Software / Re: Installing Webmin on Linux Lite 6.2
« Last post by trinidad on November 25, 2022, 10:24:37 AM »
Quote
I just got a response from Ilia at Webmin and they will be adding support for Linux Lite to the next release of Webmin (2.010)

It would be so nice if more users would use your method of contacting developers when Linux Lite has configuration problems with their software. This is how Linux Lite gains more access to software additions. Thanks for that effort.
https://****pit-project.org/
Been around for while and there are debs for it. If you try it let me know if there are any graphics issues. Designed originally for Fedora I think. Good luck with your Linux Lite server. Sounds like fun. I quit installing servers from DE ISO's after Debian 9 when LXDE got buggy. The forum is sensoring the link, my goodness how silly. Where's Elan?   
 
TC
10
Desktop Customization / Re: Just reinstalled LinuxLite 6.2
« Last post by stevef on November 25, 2022, 05:23:55 AM »
Try this:-
Click Menu
Click Settings - scroll down
Click Session and Startup

Select 'Application Autostart' tab - scroll down and de-select 'Orca Screen Reader'
Close the Session and Startup window
Restart
Pages: [1] 2 3 ... 10
-->
X Close Ad

Translations are underway - See Linux Lite Software Development Section