You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] LibreOffice 6.4 package in LL 5.4 does not work

Author (Read 1099 times)

0 Members and 1 Guest are viewing this topic.

LibreOffice 6.4 package in LL 5.4 does not work
« on: August 26, 2021, 09:40:31 PM »
 

dentalcher

  • New to Forums
  • *
  • 14
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz

  • MEMORY: 4Gb

  • VIDEO CARD: NVIDIA C79 [GeForce G102M]
Hello. The LibreOffice is not working. Everything else seems ok. I did a Fresh install of LL 5.4. I can't find any error but when I try to open Writer, I get this message box "LibreOffice 6.4 Document Recovery" Due to an error, LibreOffice crashed. All The files you were working on will now be saved...etc... with Calc & Impress, they open when I click to create new doc. But Calc cannot open any spreadsheet file... I followed the manual to uninstall, checked the repositories, reload for update and re-installed LibreOffice 6.4 but still the same...

This laptop, I already had LL 5.4 with all the packages running well but I recently replaced the HDD with SSD to make it faster. The files I was trying to open, I saved in external HDD before I changed the hard drive. I can open all those files without problem in my other computer with Windows even those saved in odf... Please help, I've spent 2 days already trying to find answers in the forum.

I tried fresh reinstalling LL 5.4 a few times too hoping it would solve the problem, but remained the same.
I'm not tech savvy. I just came to appreciate LL when I first installed it in the old hard drive because everything worked well. I submitted LL System Report, if info would help, file:///home/cherrylinux/Desktop/sysreport-Thursday-26-August-2021-18:13:17.html.

I use this for work. Thank you very much for all your help in advance.
Last Edit: August 27, 2021, 02:04:01 PM by dentalcher
 


Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #1 on: August 27, 2021, 12:17:47 AM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I have a few suggestions you can try:
1. To use a different version other than the one provided by the distro, for example, you could try the latest, 7.2.0, or the previous one 7.1.5, by downloading the .deb file from here https://www.libreoffice.org/download/download/ then install it by either selecting it and hitting Enter or by double-clicking on the file, also, you could try the .Appimage too https://www.libreoffice.org/download/appimage/ I recommend downloading fresh which I use and am sure it works. Here's how AppImages work https://docs.appimage.org/introduction/quickstart.html#ref-quickstart  launch LO, do something and check whether the issue persists.
2. To Burn/write Linux Lite .iso file to a USB stick(the same way you did to install it) boot up the Live system, launch LO, do something and check whether the issue persists.

Report back your findings, including any errors you may get in your reply. Screenshots are good too. By the way, to attach files, like the one you tried to, click on Attachments and other options, then select the file in the dialog popup box from your computer, because this file:///home/cherrylinux/Desktop/sysreport-Thursday-26-August-2021-18:13:17.html. never made it to the forum. :)

Hope this helps! :)
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #2 on: August 27, 2021, 12:33:33 AM »
 

dentalcher

  • New to Forums
  • *
  • 14
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz

  • MEMORY: 4Gb

  • VIDEO CARD: NVIDIA C79 [GeForce G102M]
Thanks, again. I will try your suggestions ASAP... and for your corrections in posting, too. Much appreciated! :)
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #3 on: August 27, 2021, 08:16:04 AM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Thanks, again. I will try your suggestions ASAP... and for your corrections in posting, too. Much appreciated! :)

You're welcome. By the way, forgot to mention this, but before installing a new LO version, remember to remove the current one first. Also, one more thing you could try, is renaming the LO folder in your /home/user/.config directory. Just launch thunar,  hit Ctrl + h to show hidden files, click on .config folder, locate the folder libreoffice, select it, hit f2, and rename it to libreoffice.old. Now launch LO, the folder will be recreated, and check if the issue persists. This is just to confirm whether some file might be corrupted in that folder. If the issues doesn't show, you can erase the old folder. If it does, you can delete the new one, and rename back the old folder, just drop the .old.
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #4 on: August 27, 2021, 10:15:43 AM »
 

j8a

  • New to Forums
  • *
  • 36
    Posts
  • Country: ar
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: AMD FX-8320E Buldozer

  • MEMORY: 8Gb

  • VIDEO CARD: NVIDIA C61 [GeForce 7025 / nForce 630a]

  • Kernel: 5.x
Hi @dentalcher ,
I wonder whether you can try to remove libreoffice and do a fresh reinstall.
You could execute the follwoing command on the terminal:
sudo apt remove libreoffice-* --purge
Then, type yes at the prompt asking to proceed with this command and reboot.

After the reboot you can choose to install libreoffice again. I always use the terminal, but you can also try from Install/Remove Software.
In the terminal you could type the following command.
sudo apt install libreoffice-* and ask yes at the prompt.

Regards,
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #5 on: August 27, 2021, 01:51:41 PM »
 

dentalcher

  • New to Forums
  • *
  • 14
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz

  • MEMORY: 4Gb

  • VIDEO CARD: NVIDIA C79 [GeForce G102M]
I have a few suggestions you can try:
1. To use a different version other than the one provided by the distro, for example, you could try the latest, 7.2.0, or the previous one 7.1.5, by downloading the .deb file from here https://www.libreoffice.org/download/download/ then install it by either selecting it and hitting Enter or by double-clicking on the file, also, you could try the .Appimage too https://www.libreoffice.org/download/appimage/ I recommend downloading fresh which I use and am sure it works. Here's how AppImages work https://docs.appimage.org/introduction/quickstart.html#ref-quickstart  launch LO, do something and check whether the issue persists.
2. To Burn/write Linux Lite .iso file to a USB stick(the same way you did to install it) boot up the Live system, launch LO, do something and check whether the issue persists.

Report back your findings, including any errors you may get in your reply. Screenshots are good too. By the way, to attach files, like the one you tried to, click on Attachments and other options, then select the file in the dialog popup box from your computer, because this file:///home/cherrylinux/Desktop/sysreport-Thursday-26-August-2021-18:13:17.html. never made it to the forum. :)

Hope this helps! :)

I did your suggestion #2 first as it was the least "invasive" and least complicated (for me). What I did this time is run Linux Lite Live first for a long time, almost the whole night - this part I didn't give much time before as my 1st install in my old hard drive was successful at first try... At first, it took a while to open Writer, Calc, and Impress, but finally, they opened! then I created test documents, attached in emails, saved in documents folder while running LL live before I finally re-installed LL. I was able to open LO after installing LL! I created many test docs like I did in live. At one point there was some glitch, the presentation I created wouldn't open again, so I shut down and reboot after a minute. I was able to open the file again.... so far, so good. I hope LO stays this way. If I encounter the same problem again, I will try to do all the suggestions posted here.. Thank you very much!
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #6 on: August 27, 2021, 01:56:23 PM »
 

dentalcher

  • New to Forums
  • *
  • 14
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz

  • MEMORY: 4Gb

  • VIDEO CARD: NVIDIA C79 [GeForce G102M]
Hi @dentalcher ,
I wonder whether you can try to remove libreoffice and do a fresh reinstall.
You could execute the follwoing command on the terminal:
sudo apt remove libreoffice-* --purge
Then, type yes at the prompt asking to proceed with this command and reboot.

After the reboot you can choose to install libreoffice again. I always use the terminal, but you can also try from Install/Remove Software.
In the terminal you could type the following command.
sudo apt install libreoffice-* and ask yes at the prompt.

Regards,

Thank you so much for your suggestion @j8a . So far, LO is working fine after doing @Moltke  suggestion #2... But if problem happens again, I will try this suggestion of yours too. Thanks a lot!
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #7 on: August 27, 2021, 02:51:29 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I did your suggestion #2 first as it was the least "invasive" and least complicated (for me). What I did this time is run Linux Lite Live first for a long time, almost the whole night - this part I didn't give much time before as my 1st install in my old hard drive was successful at first try... At first, it took a while to open Writer, Calc, and Impress, but finally, they opened! then I created test documents, attached in emails, saved in documents folder while running LL live before I finally re-installed LL. I was able to open LO after installing LL! I created many test docs like I did in live. At one point there was some glitch, the presentation I created wouldn't open again, so I shut down and reboot after a minute. I was able to open the file again.... so far, so good. I hope LO stays this way. If I encounter the same problem again, I will try to do all the suggestions posted here.. Thank you very much!

Glad is working. This is a good time to back up, use timeshift, and create a snapshot of the system, should anything go wrong, you can just revert to a working state using that snapshot, from there you could investigate what went wrong and hopefully prevent it from happening again. This is a nice thread with lots of tips and tricks on how to use timeshift https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/  give it  a read, learn, and enjoy. :)
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #8 on: August 27, 2021, 03:51:00 PM »
 

dentalcher

  • New to Forums
  • *
  • 14
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz

  • MEMORY: 4Gb

  • VIDEO CARD: NVIDIA C79 [GeForce G102M]
I did your suggestion #2 first as it was the least "invasive" and least complicated (for me). What I did this time is run Linux Lite Live first for a long time, almost the whole night - this part I didn't give much time before as my 1st install in my old hard drive was successful at first try... At first, it took a while to open Writer, Calc, and Impress, but finally, they opened! then I created test documents, attached in emails, saved in documents folder while running LL live before I finally re-installed LL. I was able to open LO after installing LL! I created many test docs like I did in live. At one point there was some glitch, the presentation I created wouldn't open again, so I shut down and reboot after a minute. I was able to open the file again.... so far, so good. I hope LO stays this way. If I encounter the same problem again, I will try to do all the suggestions posted here.. Thank you very much!

Glad is working. This is a good time to back up, use timeshift, and create a snapshot of the system, should anything go wrong, you can just revert to a working state using that snapshot, from there you could investigate what went wrong and hopefully prevent it from happening again. This is a nice thread with lots of tips and tricks on how to use timeshift https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/  give it  a read, learn, and enjoy. :)

Thanks again! Yes, I just activated Timeshift. Is this ok even if I am now having problem installing updates?.. so my LO issue is solved. Now my new issue is I can't update (I made a new post). Thank you @Moltke and @j8a !
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #9 on: August 27, 2021, 05:21:22 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Thanks again! Yes, I just activated Timeshift. Is this ok even if I am now having problem installing updates?.. so my LO issue is solved. Now my new issue is I can't update (I made a new post). Thank you @Moltke and @j8a !

Good. Yes, it is. Just one word of advice, timeshift can create scheduled snapshots, and these might take some disk's space over time, so if you plan on sticking with that, you should keep an eye on it, so the disk doesn't run out of space, remove the older ones and leave only the most recent ones. I personally have that deactivated, and take manual snapshots when needed, like when an important system or mayor kernel update happens.
Last Edit: August 27, 2021, 05:24:19 PM by Moltke
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: LibreOffice 6.4 package in LL 5.4 does not work
« Reply #10 on: August 27, 2021, 05:58:14 PM »
 

dentalcher

  • New to Forums
  • *
  • 14
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz

  • MEMORY: 4Gb

  • VIDEO CARD: NVIDIA C79 [GeForce G102M]
Thanks again! Yes, I just activated Timeshift. Is this ok even if I am now having problem installing updates?.. so my LO issue is solved. Now my new issue is I can't update (I made a new post). Thank you @Moltke and @j8a !

Good. Yes, it is. Just one word of advice, timeshift can create scheduled snapshots, and these might take some disk's space over time, so if you plan on sticking with that, you should keep an eye on it, so the disk doesn't run out of space, remove the older ones and leave only the most recent ones. I personally have that deactivated, and take manual snapshots when needed, like when an important system or mayor kernel update happens.

Thanks. I saw that in the Timeshift link you shared. Thank you very much.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements