You are Here:
Translations are underway - See Linux Lite Software Development Section



Installing Steam - broken dependencies

Author (Read 1959 times)

0 Members and 2 Guests are viewing this topic.

Re: Installing Steam - broken dependencies
« Reply #8 on: June 27, 2022, 04:19:09 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8558
    Posts
  • Reputation: 795
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
No problem :)
 

Re: Installing Steam - broken dependencies
« Reply #7 on: June 27, 2022, 04:17:36 PM »
 

m0NbaVx5jBVSh

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 6.0 64bit
Okay thanks Jerry. At the risk of sounding like an absolute newb it seems to be working for me this morning. Not sure what changed on the linux side. Probably nothing. But happy it's working nonetheless. Now I can commit to Linux Lite and learn more about the OS. Thanks!
 

Re: Installing Steam - broken dependencies
« Reply #6 on: June 27, 2022, 03:50:43 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8558
    Posts
  • Reputation: 795
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
I just tested to see if there was a bug, installs just fine into a test VM:

 

Re: Installing Steam - broken dependencies
« Reply #5 on: June 27, 2022, 11:56:09 AM »
 

m0NbaVx5jBVSh

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 6.0 64bit
Well I'm not exactly sure what's going on here but doing a clean install and then updating via
apt-get update && apt-get upgrade && apt-get dist-upgrade
before finally running the linux lite installer for Steam and I'm still getting the same issue.

Is anyone else able to install Steam out of the box without issue? I'm running a Thinkpad X1 Carbon 3rd Gen so i5-5300u.
 

Re: Installing Steam - broken dependencies
« Reply #4 on: June 25, 2022, 07:46:43 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8558
    Posts
  • Reputation: 795
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Yeah, you're trying to install now with 2 different methods without cleaning up the first method. Seek out Lite Software before installing any common programs, if what you are looking for is not there, then try another source :) This will prevent any breakages.
 

Re: Installing Steam - broken dependencies
« Reply #3 on: June 25, 2022, 03:18:25 PM »
 

m0NbaVx5jBVSh

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 6.0 64bit
I assumed it was broken because it shows nothing under 'remove software' and there's tons of software I wanted to remove on first bootup like LibreOffice and Orca. I'll try to
apt-get purge
steam and try the Lite Software

EDIT: I tried the Lite Software utility and the install is broken with a similar message to apt-get on the command line:


- Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
- Make sure your computer is connected to the internet and try again.



I'll probably just reinstall the entire operating system at this point.
« Last Edit: June 25, 2022, 03:25:02 PM by m0NbaVx5jBVSh »
 

Re: Installing Steam - broken dependencies
« Reply #2 on: June 25, 2022, 02:49:51 AM »
 

stevef

  • Global Moderator
  • I come here a lot
  • *****
  • 332
    Posts
  • Reputation: 58
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Did using Lite Software not work ?
 

Installing Steam - broken dependencies
« Reply #1 on: June 24, 2022, 01:26:26 PM »
 

m0NbaVx5jBVSh

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 6.0 64bit
I've tried installing via downloading the `.deb` and also via adding the `multiverse`? PPA and now neither works.

Adding the `multiverse` PPA has given me a ton of warnings on `apt-get update` now:

W: Skipping acquire of configured file 'multiverse/binary-amd64/Packages' as repository 'http://archive.canonical.com/ubuntu jammy InRelease' doesn't have the component 'multiverse' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'multiverse/binary-i386/Packages' as repository 'http://archive.canonical.com/ubuntu jammy InRelease' doesn't have the component 'multiverse' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'multiverse/i18n/Translation-en_US' as repository 'http://archive.canonical.com/ubuntu jammy InRelease' doesn't have the component 'multiverse' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'multiverse/i18n/Translation-en' as repository 'http://archive.canonical.com/ubuntu jammy InRelease' doesn't have the component 'multiverse' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'multiverse/cnf/Commands-amd64' as repository 'http://archive.canonical.com/ubuntu jammy InRelease' doesn't have the component 'multiverse' (component misspelt in sources.list?)



The `.deb` fails to install and the `Package Install` window doesn't support copy/pasting. But if I run `steam` via the terminal I get:
Package libegl1:i386 needs to be installed
Package libgbm1:i386 needs to be installed
Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1:i386 needs to be installed
Package steam-libs-amd64:amd64 needs to be installed
Package steam-libs-i386:i386 needs to be installed
Package xdg-desktop-portal needs to be installed
Package xdg-desktop-portal-gtk needs to be installed




And finally errors with:
steam.sh[9574]: Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
libdrm.so.2
libdrm.so.2
libdrm.so.2


EDIT1: I followed the guide at https://techpiezo.com/linux/install-steam-in-ubuntu-22-04/ and installed a ton of stuff via
sudo apt install libgl1:i386
and now steam launches but it still complains about missing packages. The missing packages now are:

Package libegl1:i386 needs to be installed
Package libgbm1:i386 needs to be installed
Package steam-libs-amd64:amd64 needs to be installed
Package steam-libs-i386:i386 needs to be installed
Package xdg-desktop-portal needs to be installed
Package xdg-desktop-portal-gtk needs to be installed

« Last Edit: June 27, 2022, 04:19:23 PM by Jerry »
 

 

-->
X Close Ad

Translations are underway - See Linux Lite Software Development Section