You are Here:
Download Linux Lite 5.6 RC1 for testing today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] LL4.8 takes a lot to boot

Author (Read 2341 times)

0 Members and 1 Guest are viewing this topic.

LL4.8 takes a lot to boot
« on: April 13, 2020, 04:04:35 AM »
 

SpAiK

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 1.0.2
Hi, I recently installed LL 4.8 on an old HP Compaq 6710b laptop. It installed perfectly fine and I'm currently writing this post from there, so it works fine and fast once logged in. But every time I boot (no dual boot, LL only) it takes a lot of time to reach to desktop. Similarly when I shut down, it takes some time to do it, more than it should.
So I've taken a look to dmesg and have found that there is some problem than repeats over boot time (and also at shutdown) and slows things down a lot:
Quote
q-6710b-GB889ET-ABE kernel: [   13.280068] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
Apr  1 21:52:52 HP-Compaq-6710b-GB889ET-ABE kernel: [   13.384046] ------------[ cut here ]------------
Apr  1 21:52:52 HP-Compaq-6710b-GB889ET-ABE kernel: [   13.384047] vblank wait timed out on crtc 0
Apr  1 21:52:52 HP-Compaq-6710b-GB889ET-ABE kernel: [   13.384120] WARNING: CPU: 0 PID: 91 at /build/linux-ZcR2Eb/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1081 drm_wait_one_vblank+0x188/0x190 [drm]
What do you think?
Last Edit: April 13, 2020, 04:23:36 AM by SpAiK
 


Re: LL4.8 takes a lot to boot
« Reply #1 on: April 13, 2020, 04:23:18 AM »
 

SpAiK

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 1.0.2
Ok, I just found the solution. Edit grub file (sudo nano  /etc/default/grub) and add "video = SVIDEO-1: d" to GRUB_CMDLINE_LINUX_DEFAULT.What I still don't understand is the root cause of this.
 

Re: LL4.8 takes a lot to boot
« Reply #2 on: April 13, 2020, 09:19:02 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1287
    Posts
  • Country: us
  • Reputation: 197
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.4 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
The cause is Intel (incomplete firmware). This is an old bug started with kernel 4.8, (4.7 seems to have been OK) but I can't find any mention of it being fixed in newer kernels other than the workaround you used (disabling the s-video port). Seems it is still there (reported at RHEL & Debian) at least up through kernel 4.15. There may or may not be a kernel fix coming at some point. 

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 


Tags: 4.8 slow much time boot 
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 RC1 for testing today - See Release Announcements