You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
Sound - Changing default device, mainly for Intel sound users

Author (Read 4096 times)

0 Members and 1 Guest are viewing this topic.

 

aus9

  • Occasional Poster
  • **
  • 54
    Posts
  • Country: au
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 3.0 64bit

  • CPU: 4 core i5-4590 CPU @ 3.30GHz

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Corporation Xeon E3-1200
Hi

I am not a Windows user and most users are likely to stay with the graphical control panel for PulseAudio (PA) called PulseAudio Volume Control whose icon can be found in 64 bit under /usr/share/applications/ or via the menu -> Multimedia -> Volume control

If you need a permanent change and hopefully can understand this ....read on.

#########################
PA is a front end to ALSA and has too many  feature to list here. But offers on-the-fly changing of sound output device etc.

Some people with towers, laptops, netbooks etc want to fix their default sound device away from (say) the default likely to be the hdmi device.
Skype for example tends to use analog sound devices as you tend to plug in a headphone mic/ear set.

Lets show how mine first looked after Hard drive install.....I open PA volume control to see this



But as its graphical it does not tell me what my default sound device is.  Secondly ALSA counts its device by 0,1,2 etc and not the normal way of 1,2,3 etc. Thirdly we need to know the default sound device is therefore the one the system thinks is index=0  which means card number zero.  Here is my way of checking it.

Open a terminal as a local user and run the command
Code: [Select]
alsamixer -c0
and if you have hdmi you are likely to see this image. Ignore whether you have an Haswell but focus on the HDMI please.

.

Now if you can set up PA, the easiest thing to do would be go to the Volume Control gui and then click the TAB for configution and pulldown one of the analog sound settings depeinding on whether you ouptut to a surround sound system or not. But that may still not help some who need an actual default to be analog such as Skpe users. YMMV.

If interested here is one way to change it.

copy and paste the following command into a terminal as a local user.

Code: [Select]
sudo leafpad /etc/modprobe.d/alsa-base.conf
Hint 1  your terminal as a pulldown called edit that an option of paste so you copy from your web browser into a terminal
Hint 2 for wheel mouse users after copying from web browser press down the wheel to paste in terminal.

Next in the terminal you are prompted to enter your password and after pressing enter you will be in a root powered text editor at the correct file.

scroll down and press the mouse at the end of the line of file which on 64 bit is
options snd-usb-audio index=-2  ......and press enter twice

copy paste the next bit ....if your sound modulle is intel.....and then save the file and do a full reboot please.

Quote
# swap index to change default card number
options snd_hda_intel index=1

Most people have intel sound IMHO but if you do not, post the output of a localuser command
Code: [Select]
inxi -Abut note that inxi counts from one and not zero......and post your output and we hopefully can offer better instructions

upon reboot open a terminal and repeat the command
Code: [Select]
alsamixer -c0
What you should see is a change and that change should be to your analog sound device (normally intel) as per my image


Last Edit: June 24, 2016, 04:25:13 AM by aus9
Good Luck
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements