You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
[SOLVED] Boot up takes 1 minute and 9 seconds on a fast SSD

Author (Read 8768 times)

0 Members and 1 Guest are viewing this topic.

[SOLVED] Boot up takes 1 minute and 9 seconds on a fast SSD
« on: August 03, 2014, 11:07:28 AM »
 

LenAsh

  • Guest
Hi - hopefully someone can decipher the bootchart log and tgz attached. I'm at a loss. I get 3 "COMRESET" errors about 10 seconds apart during boot. Shutdown takes about 1 second.

This is a "fast" system...

Windows boots in 8 seconds on another SSD.

Thanks!

https://drive.google.com/file/d/0B_ESvfVtZzEwSTdsWlB3M3FyVU0/edit?usp=sharing
https://drive.google.com/file/d/0B_ESvfVtZzEwV0xfa1hvb1N1WWc/edit?usp=sharing


EDIT: Fixed on any Linux distro. The problem was an "old" Intel 32GB SSD. This worked absolutely fine on W7, but any Linux didn't like it at all at boot. It had the latest firmware too, wgich was dated 2010. I've now removed it and binned it as I have no real need for this tiny drive.

Thanks for all help offered in any case.
Last Edit: August 16, 2014, 03:15:08 AM by LenAsh
 


Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #1 on: August 04, 2014, 01:15:56 AM »
 

LenAsh

  • Guest
Sharing links updated...!
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #2 on: August 06, 2014, 07:01:18 AM »
 

tompa

  • New to Forums
  • *
  • 17
    Posts
  • Country: se
  • Reputation: 2
  • Linux Lite Member

  • MEMORY: 4Gb
Hi,
I'm a bit surprised to see my LL2 start in 28sec on new SSD, it was about the same boot time with old HD (on the same PC) .
My windows 7 boots in 30 sec on this PC/SSD....  :P

/tompa
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #3 on: August 06, 2014, 07:13:32 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8182
    Posts
  • Country: nz
  • Reputation: 762
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
If you don't have bluetooth you can disable it during boot, same with printing services. Menu, Settings, Session and Startup, Autostart tab. Those are the only 2 that are safe to untick, the rest must not be unticked. For a more advanced tool, try Boot Up Manager (B.U.M.):

Code: [Select]
sudo apt-get install bum
Only untick items if you know what you are doing. Disabling items without researching their function may render your machine unbootable.
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #4 on: August 06, 2014, 10:46:01 AM »
 

tompa

  • New to Forums
  • *
  • 17
    Posts
  • Country: se
  • Reputation: 2
  • Linux Lite Member

  • MEMORY: 4Gb
If you don't have bluetooth you can disable it during boot, same with printing services. Menu, Settings, Session and Startup, Autostart tab. Those are the only 2 that are safe to untick, the rest must not be unticked. For a more advanced tool, try Boot Up Manager (B.U.M.):

Code: [Select]
sudo apt-get install bum
Only untick items if you know what you are doing. Disabling items without researching their function may render your machine unbootable.

Thanks for the tip!
Didn't make any difference here though :(

/tompa
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #5 on: August 06, 2014, 01:14:37 PM »
 

LenAsh

  • Guest
Doesn't make any real difference. The problem seems to be something disk wise/ATA problems....
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #6 on: August 06, 2014, 01:48:27 PM »
 

misko_2083

  • Gold Level Poster
  • *******
  • 688
    Posts
  • Reputation: 191
  • Linux Lite Member

  • CPU: Dual core Pentium E5700 3GHz

  • MEMORY: 3Gb

  • VIDEO CARD: GeForce GT 430
You are using kernel 3.16.0-031600rc4-generic
See if this resolves your problem https://www.linuxliteos.com/forums/index.php?topic=474.msg3725%3Btopicseen#msg3725
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #7 on: August 06, 2014, 01:54:55 PM »
 

LenAsh

  • Guest
Done that, the same.

I originally "updated" the kernel to the one linked due to sound problems with the Z97 chipset.

The problem is the same on 3.13, 3.15, 3.16rc4
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #8 on: August 06, 2014, 02:02:35 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8182
    Posts
  • Country: nz
  • Reputation: 762
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Checklist:
See if there is a firmware update for your SSD.
Also make sure your BIOS is set to AHCI and not IDE.
Have you enabled Trim on the SSD? - Help Manual, Install Guide,  Enabling TRIM on your SSD.

Here are a couple of links that have provided solutions for people - http://askubuntu.com/questions/315921/comreset-failed-and-slow-boot-times & http://askubuntu.com/questions/62295/how-to-fix-a-comreset-failed-error
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #9 on: August 06, 2014, 02:11:41 PM »
 

LenAsh

  • Guest
Firmware is the latest.
BIOS is AHCI - defaults to it.
TRIM is enabled and I have also forced a TRIM activity (sudo fstrim -v /)

By the way - and this is something I should have mentioned. ALL Linux distros have this problem on my machine. I've installed 2 others... they also have the audio problem. This CAN be overcome by switching the machine OFF after Windows and cold starting in to Linux. A restart from Windows produces no audio. This was the reason for updating kernels.

For further background: CPU is Intel i5 - 4690, Mobo is Gigabyte Z97-D3H, 16GB DDR3-1600 RAM.

2 SSDs, the Linux one is an Intel X25, 80GB

Thanks for your perseverance.
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #10 on: August 06, 2014, 02:13:50 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8182
    Posts
  • Country: nz
  • Reputation: 762
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Well then Len, the solution seems to be to wipe windows :p Just being cheeky mate :) Try those 2 links I posted.
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #11 on: August 06, 2014, 02:45:03 PM »
 

LenAsh

  • Guest
This

GRUB_CMDLINE_LINUX="libata.force=16.00:noncq"

in /etc/default/grub after exit-save

update-grub

Made no difference.

I can't see any other solutions in the links...?
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #12 on: August 06, 2014, 02:57:01 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8182
    Posts
  • Country: nz
  • Reputation: 762
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Do you have any external drives attached when you boot or internal sata pci card?
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #13 on: August 06, 2014, 03:05:55 PM »
 

LenAsh

  • Guest
No, nothing. There are 2 SATA3 SSDs and 1 SATA DVDROM. No PCI cards at all and the GFX are Intel 4600 IGX only.
 

Re: Boot up takes 1 minute and 9 seconds on a fast SSD
« Reply #14 on: August 07, 2014, 10:55:26 AM »
 

misko_2083

  • Gold Level Poster
  • *******
  • 688
    Posts
  • Reputation: 191
  • Linux Lite Member

  • CPU: Dual core Pentium E5700 3GHz

  • MEMORY: 3Gb

  • VIDEO CARD: GeForce GT 430
Hi LenAsh
It's an unknown kernel bug. Try reporting this to the kernel developers. That chipset is fairly new and you'll just have to wait for the patch to appear.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements