You are Here:
Linux Lite 4.0 Beta has been released. See the Release Announcements Section.




BitTorrent Client Transmission Suffers Remote Takeover Vulnerability

Author (Read 533 times)

0 Members and 1 Guest are viewing this topic.

 

Ottawagrant

  • Forum Regular
  • ***
  • 159
    Posts
  • Country: ca
  • Reputation: 23
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel Duo Core 2 E8600 @ 3.33GHz

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Q45/Q43
And 2018 just rolls on:
"Transmission, one of the most used non-commercial BitTorrent clients, has a vulnerability that allows outsiders to gain control over people's computers. The flaw affects users who have remote control enabled with the default password. The vulnerability was revealed by a Google researcher, who plans to disclose similar remote code execution flaws in other torrent clients as well."

Read all about it:
https://torrentfreak.com/bittorrent-client-transmission-suffers-remote-takeover-vulnerability-180116/
 


Re: BitTorrent Client Transmission Suffers Remote Takeover Vulnerability
« Reply #1 on: January 17, 2018, 10:48:18 AM »
 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 839
    Posts
  • Country: 00
  • Reputation: 184
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics
Thanks for the information on Transmission. In the meantime there are possible alternatives. I didn't notice Deluge on the list (please correct me if I'm wrong) and it can be installed from Lite Software - torrent software option.
 

Re: BitTorrent Client Transmission Suffers Remote Takeover Vulnerability
« Reply #2 on: January 18, 2018, 01:37:00 AM »
 

JmaCWQ

  • Do big things!
  • Forum Regular
  • ***
  • 219
    Posts
  • Country: au
  • Reputation: 43
  • And life goes on...

  • Linux Lite: 2.8 32bit

  • CPU: 2x Intel(R) Atom(TM) CPU N455 @ 1.66GHz

  • MEMORY: 1Gb

  • VIDEO CARD: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
Quote
The flaw affects users who have remote control enabled with the default password.

So long as you don't use remote control with the default password it shouldn't be a risk/issue.
 

 

NN

  • Forum Regular
  • ***
  • 104
    Posts
  • Country: ru
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: 4x Intel(R) Atom(TM) CPU N2600 @ 1.60GHz

  • MEMORY: 1Gb

  • VIDEO CARD: OpenGL Renderer: llvmpipe (LLVM 5.0, 128 bits)
"Transmission, one of the most used non-commercial BitTorrent clients, has a vulnerability that allows outsiders to gain control over people's computers.

I have never liked Transmission, I always remove it from the system if it is installed in a distro. I use qBitTorrent instead:

sudo apt purge --autoremove transmission-gtk && sudo apt install qbittorrent -y
Three things admire me - Life, Music and Linux!
 


Tags:
 


Linux Lite 4.0 Beta has been released. See the Release Announcements Section.