You are Here:
Linux Lite 6.0 Final Released - See Release Announcements



I need to upgrade hplip from 3.20.3 to 3.20.5, i need instructions please

Author (Read 2904 times)

0 Members and 1 Guest are viewing this topic.

Re: I need to upgrade hplip from 3.20.3 to 3.20.5, i need instructions please
« Reply #4 on: November 23, 2021, 08:56:35 AM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1798
    Posts
  • Reputation: 278
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@kissbaby3
I can't image too much changed between 3.20.3 to 3.20.5... Just a reminder prior to install do a TimeShift backup - just incase..
And - the command is for 3.21.3 - did you want that version??


For the .run file you should be able to follow this process...
https://developers.hp.com/hp-linux-imaging-and-printing/install/install/index


LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: I need to upgrade hplip from 3.20.3 to 3.20.5, i need instructions please
« Reply #3 on: November 22, 2021, 08:46:35 PM »
 

kissbaby3

  • Forum Regular
  • ***
  • 168
    Posts
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: 1.4 GHz

  • MEMORY: 8Gb

  • VIDEO CARD: on board
You could try this http://archive.ubuntu.com/ubuntu/pool/main/h/hplip/hplip_3.21.2+dfsg1-2_amd64.deb
Download to your home folder, right-click in a blank space and choose open terminal here the run this in the terminal
Code: [Select]
sudo apt install ./hplip_3.21.2+dfsg1-2_amd64.deb
Hope this helps! :)

did not work, but the funny thing is , is after i did that, my printer HP deskjet 2742 (all-in-one) now works wireless (driverless) , it now prints, scans copies. hiplip version is still 3.20.3.
maybe it was because of one of the normal linux updates, who knows. would be nice , if i had hiplip version 3.20.5  just for kicks, but hey it works now. even tho i wanted it to work only by USB cord connection, just for those times if there ever was a temporary wifi outage.

it works fine as a USB cord connection on the windows 10 home PC upstairs.
i like using all , i think windows and linux compliment each othere, a tool is a tool.

i did do the terminal correctly, just so ya know. thank you and hugs , at least my printer now works .

 

Re: I need to upgrade hplip from 3.20.3 to 3.20.5, i need instructions please
« Reply #2 on: November 22, 2021, 06:03:50 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1125
    Posts
  • Reputation: 126
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
You could try this http://archive.ubuntu.com/ubuntu/pool/main/h/hplip/hplip_3.21.2+dfsg1-2_amd64.deb
Download to your home folder, right-click in a blank space and choose open terminal here the run this in the terminal
Code: [Select]
sudo apt install ./hplip_3.21.2+dfsg1-2_amd64.deb
Hope this helps! :)
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

I need to upgrade hplip from 3.20.3 to 3.20.5, i need instructions please
« Reply #1 on: November 22, 2021, 05:44:48 PM »
 

kissbaby3

  • Forum Regular
  • ***
  • 168
    Posts
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: 1.4 GHz

  • MEMORY: 8Gb

  • VIDEO CARD: on board

Todays date:11-22-21

i'm using Linux lite 5.6,

well something must of updated on the hp website,
any ways i need to upgrade hplip 3.20.3 (came with linux lite 5.6), to hplip 3.20.5

i have the file "hplip-3.20.5-plugin.run" file.

its in my dowloads folder.

i played with the terminal before when doing stuff. so not to shy about that.

i'm hoping for step by steps instructions to do this correctly. surely some one has done this before using Linux lite 5 series.
please help :wave
 

 

-->
X Close Ad

Linux Lite 6.0 Final Released - See Release Announcements