You are Here:
Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.



[ SOLVED ] Gtk-WARNING **:

Author (Read 439 times)

0 Members and 1 Guest are viewing this topic.

Gtk-WARNING **:
« on: August 11, 2019, 02:26:32 PM »
 

DirkBrown

  • New to Forums
  • *
  • 3
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • MEMORY: 2Gb

  • VIDEO CARD: Intel
Hi Chaps.
I have the following error when running chirpw from the Terminal:

Gtk-WARNING **: 18:32:01.074: Locale not supported by C library.
   Using the fallback 'C' locale.

It doesn't seem to cause any trouble with the program, and as far as can tell my language settings are correctly set to English UK.
I did a search of the forum, but couldn't see the issue posted before.
I apologize if I've missed it.

Cheers.
Dirk.

Linux Lite 4.4
Last Edit: August 13, 2019, 04:30:50 AM by Jerry
 


Re: Gtk-WARNING **:
« Reply #1 on: August 11, 2019, 08:08:32 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
What did the chirpw developer say?
 

Re: Gtk-WARNING **:
« Reply #2 on: August 12, 2019, 01:24:21 AM »
 

DirkBrown

  • New to Forums
  • *
  • 3
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • MEMORY: 2Gb

  • VIDEO CARD: Intel
Morning Jerry.
I've not asked the question to be honest.
I was just assuming it was a Linux Lite issue, but it certainly did cross my mind this morning and I tried Firefox from the Terminal.
Yep, that's fine!
I'll pop over to Chirp and ask over there.
Cheers.
Dirk.
 

Re: Gtk-WARNING **:
« Reply #3 on: August 12, 2019, 02:28:17 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
We support what we bundle, we can't help people with random software after your install of LL. The logical port of call is the developer. If they have no answers, you can pop back here and we'll see what we can do :)
 

Re: Gtk-WARNING **:
« Reply #4 on: August 12, 2019, 08:44:28 AM »
 

Moltke

  • I come here a lot
  • *****
  • 475
    Posts
  • Country: ve
  • Reputation: 66
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
It's not an "issue" per se, at least not one you should worry about. If you try running all of the software you've installed right from the terminal you'd probably  find that many of them would trigger this gtk warning, the reason is that when you launch a GUI app from whisker menu it gets a completely different set of environment variables than programs run from the terminal. In general, neither LANG nor any of the LC_* variables will be set for a GUI app. If you run
Code: [Select]
locale from the terminal you'll see something similar to this
Code: [Select]

LANG=es_VE.utf8
LANGUAGE=
LC_CTYPE="es_VE.utf8"
LC_NUMERIC="es_VE.utf8"
LC_TIME="es_VE.utf8"
LC_COLLATE="es_VE.utf8"
LC_MONETARY="es_VE.utf8"
LC_MESSAGES="es_VE.utf8"
LC_PAPER="es_VE.utf8"
LC_NAME="es_VE.utf8"
LC_ADDRESS="es_VE.utf8"
LC_TELEPHONE="es_VE.utf8"
LC_MEASUREMENT="es_VE.utf8"
LC_IDENTIFICATION="es_VE.utf8"
LC_ALL=
As you can see "Language" and "lc_all" are empty and as far as I know that how's supposed to be since different programs will use different set of settings, in conclusion, the gtk warning is the program saying "hey, is this a shell?" and nothing more, like I  said nothing to be worried about really.

Hope this helps! :)
Without each others help there ain't no hope for us :)
 

Re: Gtk-WARNING **:
« Reply #5 on: August 12, 2019, 10:00:15 AM »
 

trinidad

  • Gold Level Poster
  • *******
  • 972
    Posts
  • Country: us
  • Reputation: 175
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.4 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
add to the end of original command
for stdout add: 1>/dev/null
for stderr add: 2>/dev/null
for both add: &>/dev/null
TC


All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Gtk-WARNING **:
« Reply #6 on: August 12, 2019, 03:41:01 PM »
 

DirkBrown

  • New to Forums
  • *
  • 3
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • MEMORY: 2Gb

  • VIDEO CARD: Intel
Thanks chaps!
Guess I won't sweat the small stuff!

  ;D

Dirk.
 


Tags: gtk-warning **: 
 


Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.