You are Here:
Linux Lite - A.I. Helper is now at Version 2 - Give it a go here

lightdm stopped working (Linux Lite 2.2 64bit)

Author (Read 2675 times)

0 Members and 1 Guest are viewing this topic.

lightdm stopped working (Linux Lite 2.2 64bit)
« Reply #1 on: January 20, 2015, 01:00:49 PM »


  • Guest
Symptom. When booting up the process would stop just before log in screen after getting to a black screen with movable mouse cursor.
This happened after a recent update.

I could Ctrl Alt F1 and log in, then startx. This would load the desktop and I could then use the computer normally. When I restarted the computer, the boot up process would hang at the black screen with movable mouse cursor once again.

The fact that I could load the desktop via startx  tells me that the problem is not the graphics driver.

I did quite a lot of reading on line regarding this problem, but was unable to find anyone with exactly the same issue, however, I tried the following 2 suggestions from what I read;
After a fresh start and Ctrl Alt F1 to give me a text login, I tried
Code: [Select]
sudo service lightdm stop , then
Code: [Select]
sudo service lightdm start .
I also tried
Code: [Select]
sudo dpkg-reconfigure lightdm , but was unable to solve it.

I also tried marking .config in my home folder as .config.old so that a new .config would be generated when I restarted just in case there was something in the old .config that was causing the problem. This did not solve it so I reverted to my old .config.

I also tried reinstalling lightdm.

In the end I installed gdm, and now can use the computer normally again.

Whilst gdm has gained me a fairly happy computer again, I realise that this did not solve the real problem that I had with lightdm and I wonder if anyone else has had trouble, or can suggest a fix?
I must add that I think Linux Lite is a wonderful distribution and am really thankful to all of you that have put in many hours work to develop and maintain it. It has been a great help to me, and to the friends that I have encouraged to use it!


X Close Ad

Linux Lite - A.I. Helper is now at Version 2 - Give it a go here