You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



[ SOLVED ] Trouble installing Update Manager Lite

Author (Read 698 times)

0 Members and 1 Guest are viewing this topic.

Trouble installing Update Manager Lite
« on: March 28, 2019, 10:25:36 AM »
 

JanetBiggar

  • PayPal Supporter
  • Forum Regular
  • *****
  • 190
    Posts
  • Country: ca
  • Reputation: 8
  • Linux Lite Member
    • iizidima

  • Linux Lite: 3.8 32bit
Because I ran into issues with one of the old laptops I use for youth I decided to try the route Artim suggested about selective updates since I am a newbie.  I was able to install it on the problem laptop, however I have tried installing it on two other older laptops and I believe I am doing the same steps.

I followed the article I found for "update manager for Linux lite 3.x series" and initially on all of them I went ahead and tried the sudo line for the unlockforus repository which didn't work and then I found out it appears that this repository already exists on the laptops. So I went ahead and put the other sudo command in to get and install mintupdate.  As I said it worked on the first laptop, but the message I am getting on the other(s) is:

WARNING: The following packages cannot be authenticated!
mintupdate-lite
E:There were unauthenticated packages and -y was used without --allow-unauthenticated

I'm not sure what I am doing different or wrong...

Might someone be able to comment and point me in the right direction should I wish to pursue putting this on select laptops?
Last Edit: March 29, 2019, 03:33:01 AM by JanetBiggar
 


Re: Trouble installing Update Manager Lite
« Reply #1 on: March 28, 2019, 08:58:23 PM »
 

Artim

  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 352
    Posts
  • Country: us
  • Reputation: 48
  • I must be weird to love school
    • Confessions of a Technophobe

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller
Hi Janet,

Did you copy-and-paste the terminal commands from the web page?  It kinda reads like you selected it from the unlockforus Linux Lite repository instead.  The key is missing.

Code: [Select]
echo "deb https://unlockforus.com/repository/dists/xenial/ /" | sudo tee /etc/apt/sources.list.d/unlockforus-xenial.list # And add the PGP key: ~$ curl -s https://unlockforus.com/repository/keyFile | sudo apt-key add -


And then, to install it:

Code: [Select]
 
sudo apt-get update && sudo apt-get install mintupdate-lite -y
 

Re: Trouble installing Update Manager Lite
« Reply #2 on: March 29, 2019, 12:14:00 AM »
 

JanetBiggar

  • PayPal Supporter
  • Forum Regular
  • *****
  • 190
    Posts
  • Country: ca
  • Reputation: 8
  • Linux Lite Member
    • iizidima

  • Linux Lite: 3.8 32bit
Ahhh, when I saw that original command with the part in the model that says “And add the PGP key” I did not think this was part of the command. I very originally copy and pasted the first part before the # And... then did the second line.

Let me give it a go with what I understand above and see how I make out.

Thanks, here’s hoping it’ll work ;)
 

Re: Trouble installing Update Manager Lite
« Reply #3 on: March 29, 2019, 01:10:16 AM »
 

JanetBiggar

  • PayPal Supporter
  • Forum Regular
  • *****
  • 190
    Posts
  • Country: ca
  • Reputation: 8
  • Linux Lite Member
    • iizidima

  • Linux Lite: 3.8 32bit
I must be doing something wrong...

I copy and pasted exactly what you had above. Maybe I have misunderstood your steps..?

Here is what I did:
1) pulled up terminal
2) went directly to your post above and copied the full text in your first green box and inserted it in the terminal window after the $ then clicked ENTER.
3) entered my pw
4) once it completed I then copied and pasted the text from your second green box and it went through a bunch of stuff, but then finished off with the same line as I posted above regarding "the unauthenticated packages..."

What am I doing wrong?

 

Re: Trouble installing Update Manager Lite
« Reply #4 on: March 29, 2019, 02:51:08 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 154
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.6 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
@JanetBiggar

first command adds the repository as a source:

Code: [Select]
echo "deb https://unlockforus.com/repository/dists/xenial/ /" | sudo tee /etc/apt/sources.list.d/unlockforus-xenial.list
second command adds the key:

Code: [Select]
curl -s https://unlockforus.com/repository/keyFile | sudo apt-key add -
third command updates and installs:

Code: [Select]
sudo apt-get update && sudo apt-get install mintupdate-lite -y
You were correct in thinking that the following was just a comment and not part of the command:

Code: [Select]
# And add the PGP key: ~$



Last Edit: March 29, 2019, 02:54:58 AM by DeepThought
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Trouble installing Update Manager Lite
« Reply #5 on: March 29, 2019, 02:52:28 AM »
 

Artim

  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 352
    Posts
  • Country: us
  • Reputation: 48
  • I must be weird to love school
    • Confessions of a Technophobe

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller
Argh!  Nothing, I think.  Try this:

Code: [Select]
echo "deb https://unlockforus.com/repository/dists/xenial/ /" | sudo tee /etc/apt/sources.list.d/unlockforus-xenial.list
curl -s https://unlockforus.com/repository/keyFile | sudo apt-key add -

Then

Code: [Select]
sudo apt-get update && sudo apt-get install mintupdate-lite -y

And if if totally fails again, you can ask on that web page about it, or PM @ralphy here on the forums.  He will help you better than I can, and he's a really nice guy!  Unlockforus was put aside temporarily while "real life" interrupted and hindered things.  But I understand it's back up and slowly being updated as time permits.

I'm sorry this has been so troublesome for you!  It absolutely should not be at all!
 

Re: Trouble installing Update Manager Lite
« Reply #6 on: March 29, 2019, 03:06:43 AM »
 

ralphy

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 741
    Posts
  • Country: us
  • Reputation: 115
  • Linux Lite Developer

  • Linux Lite: 3.8 64bit

Note: Trying to xenial instead of bionic   :P   ???


xenial = linuxlite 3.x
bionic = linuxlite 4.x


Code: [Select]
echo "deb https://unlockforus.com/repository/dists/bionic/ /" | sudo tee /etc/apt/sources.list.d/unlockforus-bionic.list
curl -s https://unlockforus.com/repository/keyFile | sudo apt-key add -


Code: [Select]
sudo apt update && sudo apt install mintupdate-lite -y

See https://unlockforus.com/update-manager-linux-lite-4-x-series/




Cheers!
Last Edit: March 29, 2019, 03:27:25 AM by ralphy
https://unlockforus.com

Sorry for seeming stupid and preferring Linux - I just don't know any better.

 

Re: Trouble installing Update Manager Lite
« Reply #7 on: March 29, 2019, 03:32:43 AM »
 

JanetBiggar

  • PayPal Supporter
  • Forum Regular
  • *****
  • 190
    Posts
  • Country: ca
  • Reputation: 8
  • Linux Lite Member
    • iizidima

  • Linux Lite: 3.8 32bit
Yay - it worked!  It is 3.8 I am running so the xenial was correct for what I needed.

I did the steps that Deepthought outlined and it worked perfectly.

Thank you to all of you for helping me out here.  Linux Lite OS is great and all the help I receive from forum members is "Priceless"  ;D

I will bookmark this page so I know for future installs.
 

Re: Trouble installing Update Manager Lite
« Reply #8 on: March 29, 2019, 04:15:33 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 154
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.6 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
@JanetBiggar  That's great :) As for my part, @Artim did the work, I just cleared up a misunderstanding :)

@ralphy  Might I suggest a slight change on your website, by taking the

 "# And add the PGP key:"

 outside the code box, similar to how you have "Install Update Manager:".

It might save confusion for newbies, especially if they have learnt that $ is the normal user prompt while # is the root prompt.

 :D :D :D
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Trouble installing Update Manager Lite
« Reply #9 on: March 29, 2019, 05:56:04 AM »
 

ralphy

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 741
    Posts
  • Country: us
  • Reputation: 115
  • Linux Lite Developer

  • Linux Lite: 3.8 64bit
...
@ralphy  Might I suggest a slight change on your website, by taking the

 "# And add the PGP key:"

 outside the code box, similar to how you have "Install Update Manager:".

It might save confusion for newbies, especially if they have learnt that $ is the normal user prompt while # is the root prompt.

Noted  :)
https://unlockforus.com

Sorry for seeming stupid and preferring Linux - I just don't know any better.

 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky