You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



Kodi 18.1 broken file in repo

Author (Read 394 times)

0 Members and 2 Guests are viewing this topic.

Kodi 18.1 broken file in repo
« on: April 21, 2019, 05:51:47 PM »
 

zaivala

  • New to Forums
  • *
  • 17
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: i5 u3320M

  • MEMORY: 8Gb

  • VIDEO CARD: intel
I just installed Linux Lite 4.4 a few days ago. I have had very few problems, and none of them are critical.

When I installed, the repo still had Kodi 17.3. I knew that 18.1 was current, so I followed the rules (re: Ubuntu distros) to add the repo and update. It failed, I think it was the kodi-x11 file. So I deleted and started over, noticing that the repo was also updated to 18.1 (I love Synaptic, btw). Same problem. Sometimes I get the result that the linuxliteos repos are not available, others it just fails.

Is there a fix for this?

Update: I just tried again, and got the same issue. It chokes on kodi-x11, then returns the message, E: Internal Error, No file name for kodi:amd64
Last Edit: April 21, 2019, 06:02:56 PM by zaivala
 


Re: Kodi 18.1 broken file in repo
« Reply #1 on: April 22, 2019, 03:43:28 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7017
    Posts
  • Country: nz
  • Reputation: 651
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
What instructions did you use? Please provide the actual link. Cheers.
 

Re: Kodi 18.1 broken file in repo
« Reply #2 on: April 22, 2019, 09:23:54 AM »
 

zaivala

  • New to Forums
  • *
  • 17
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: i5 u3320M

  • MEMORY: 8Gb

  • VIDEO CARD: intel
I tried different ways. There was the way of installing it via Terminal shown on the Kodi site for Ubuntu distros. There was Synaptic, which was tried several times including complete removal. There was fixing broken packages using Synaptic.

Tonight, I ran sudo apt update (not the first time I've done it), ran into the broken package again, ran sudo apt delete --purge kodi, and ran sudo apt update again. This time, Kodi installed (using the ppa installed in my first step).

So whatever the problem was with kodi-x11, it has been repaired. I was hoping to hear that someone here fixed it, but alas, that is not the case... but it's working now anyhow.
 

Re: Kodi 18.1 broken file in repo
« Reply #3 on: April 22, 2019, 03:27:04 PM »
 

minesheep

  • Occasional Poster
  • **
  • 72
    Posts
  • Country: fi
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • MEMORY: 4Gb
Did you installed the updates after you installed your system if not please update now with "install updates" (recommended way) or run
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
(works too). And then try to install Kodi again.
 

Re: Kodi 18.1 broken file in repo
« Reply #4 on: April 22, 2019, 04:26:01 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7017
    Posts
  • Country: nz
  • Reputation: 651
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Did you installed the updates after you installed your system if not please update now with "install updates" (recommended way) or run
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
(works too). And then try to install Kodi again.

LL uses sudo apt-get dist-upgrade for the record :)
 

Re: Kodi 18.1 broken file in repo
« Reply #5 on: April 25, 2019, 11:34:01 AM »
 

zaivala

  • New to Forums
  • *
  • 17
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: i5 u3320M

  • MEMORY: 8Gb

  • VIDEO CARD: intel
Thanks for the infor that I need to use dist-upgrade.

I have used all update and upgrade (except I didn't know to use dist-upgrade) code. Moreover, something changed yesterday and Kodi totally got installed, with one caveat: I got all my config done, I set up real-debrid... but Kodi choked on Trakt.TV setup, don't know why, just got a "failed" message. My next move would be to check the Kodi log file, soon as I figure out where those are stored...
 

Re: Kodi 18.1 broken file in repo
« Reply #6 on: April 25, 2019, 12:46:14 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7017
    Posts
  • Country: nz
  • Reputation: 651
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Contact the Kodi forums, they are more likely since it's their software, to provide a solution.

Sent from my Mobile phone using Tapatalk

 


Tags: kodi 
 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.