You are Here:
Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.



[ SOLVED ] install signal / update error

Author (Read 320 times)

0 Members and 1 Guest are viewing this topic.

install signal / update error
« on: March 18, 2019, 08:29:19 AM »
 

printemps

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 64bit
Hi,
I tried to install Signal's desktop version on Lite 3.8 with following commands:

curl -s https://updates.signal.org/desktop/apt/keys.asc | sudo apt-key add -
echo "deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main" | sudo tee -a /etc/apt/sources.list.d/signal-xenial.list
sudo apt update && sudo apt install signal-desktop

Following error occurs:
E:Type 'sudo' is not known on line 2 in source list /etc/apt/sources.list.d/signal-xenial.list
E:The list of sources could not be read.

Same error for Linux Lite updates when it tries to fetch the package cache information lists...

What can I do?
Thanks for help
Last Edit: April 01, 2019, 12:31:53 AM by Jerry
 


Re: install signal / update error
« Reply #1 on: March 18, 2019, 09:06:50 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 150
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480

Not sure how you typed this part into terminal but it should be one line
Code: [Select]
echo "deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main" | sudo tee -a /etc/apt/sources.list.d/signal-xenial.list
To check the sources list:
Code: [Select]
sudo nano /etc/apt/sources.list.d/signal-xenial.list
The only line in the signal-xenial.list file should be
Code: [Select]
deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main
You may need to edit the line, then control-x , y, and enter to save any edits.
Then try:
Code: [Select]
sudo apt update && sudo apt install signal-desktop
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: install signal / update error
« Reply #2 on: March 18, 2019, 10:12:52 AM »
 

printemps

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 64bit
Thanks a lot.
After editing the sources list and reducing to one line, update and installation worked without problem.
 

Re: install signal / update error
« Reply #3 on: March 18, 2019, 10:23:31 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 150
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
Glad to help :)
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 


 


Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.