You are Here:
Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.



How do you keep screen from timing out in VLC

Author (Read 7198 times)

0 Members and 1 Guest are viewing this topic.

How do you keep screen from timing out in VLC
« on: June 23, 2014, 10:20:29 PM »
 

AndyOpie150

  • Guest
When using VLC with Linux Lite the screen times out after about 10 minutes. I have to wiggle mouse to get it to come back on.
Is there a setting I'm not seeing to allow the playback of a video with uninterupted screen? Kind of a hassle to have to keep doing this every 10 minutes.
Is it something that could be added to an update or, at the very least, the next release of LinuxLite?

The Distro I'm currently using to replace Windows XP on low resource machines doesn't have this playback problem, so I know it can be done in Linux Lite as well. I just haven't figured out how to go about doing it.
 


Re: How do you keep screen from timing out in VLC
« Reply #1 on: June 24, 2014, 02:18:50 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6943
    Posts
  • Country: nz
  • Reputation: 644
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Just disable the Screensaver :)
 

Re: How do you keep screen from timing out in VLC
« Reply #2 on: June 25, 2014, 07:48:56 PM »
 

riser

  • Occasional Poster
  • **
  • 66
    Posts
  • Reputation: 29
  • Linux Lite Member

  • Linux Lite: 1.0.6
You may need to add the following to /etc/X11/xorg.conf:
Code: [Select]
Section "ServerFlags"
   Option "BlankTime" "0"
   Option "StandbyTime" "0"
   Option "SuspendTime" "0"
   Option "OffTime" "0"
   Option "DontZap" "false"
EndSection

 

Re: How do you keep screen from timing out in VLC
« Reply #3 on: June 25, 2014, 10:37:51 PM »
 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 858
    Posts
  • Country: 00
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics
Check that the VLC screen saver option is set to disabled.

vlc > tools > preferences

show settings (lower left corner) > all

left column > scroll to and click "video" > check "disable screensaver"
 

Re: How do you keep screen from timing out in VLC
« Reply #4 on: June 25, 2014, 10:38:22 PM »
 

AndyOpie150

  • Guest
Just disable the Screensaver :)
Duh (followed by sound of palm hitting forehead)!

EDIT:
riser and Scott(0): Will keep those comments in mind in case disabling screensaver doesn't work (hadn't set it up, so I'm assuming it is setup by default).
Last Edit: June 25, 2014, 10:42:27 PM by AndyOpie150
 

Re: How do you keep screen from timing out in VLC
« Reply #5 on: June 25, 2014, 10:45:13 PM »
 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 858
    Posts
  • Country: 00
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics
Not to confuse the issue but I should note that the power setting *may* behave separately from the screensaver setting. In other words, if the screensaver is disabled but a power manager setting is set to blank the screen it may kick in.
 

Re: How do you keep screen from timing out in VLC
« Reply #6 on: June 25, 2014, 11:27:41 PM »
 

AndyOpie150

  • Guest
Will check all in morning. Brain to tired.
Thanks for all the help.
 

Re: How do you keep screen from timing out in VLC
« Reply #7 on: July 12, 2014, 07:52:59 AM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Country: gb
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
I had this problem that my screen goes blank if I do not use keyboard or touchpad whilst watching you-tube or skype Looks as if there is yet another long term Bug in Ubuntu and Xfce

https://bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/1193716

If you scroll to the bottom they recon to have fixed it

______________________________________________________________________-

 In Xfce Bugzilla #9075, Eric Koegel (eric-koegel) wrote on 2014-06-29:    #54
Good news, Simon added support for controlling screen blanking in:
http://git.xfce.org/xfce/xfce4-power-manager/commit/?id=7dd51ceaa91ecba72154dd15ecca6ddd7f33b120
and I added the presentation mode turning off screen blanking in:
http://git.xfce.org/xfce/xfce4-power-manager/commit/?id=e07fd9b7571c53bc4dbf3ed77915047cb4a0f3e2

Testing/feedback is always welcome if you're able to build from git.

Bug Watch Updater (bug-watch-updater) on 2014-06-30
Changed in xfce4-power-manager:
importance:    Unknown → Medium
status:    Unknown → Confirmed
 In Xfce Bugzilla #9075, Simon Steinbeiß (ochosi) wrote on 2014-06-30:    #55
Yup, this bug is actually fixed now.

Bug Watch Updater (bug-watch-updater) on 2014-07-02
Changed in xfce4-power-manager:
status:    Confirmed → Fix Released
________________________________________________


Hope this solves the problem .

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: How do you keep screen from timing out in VLC
« Reply #8 on: July 12, 2014, 09:44:37 AM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1095
    Posts
  • Country: us
  • Reputation: 323
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Not to confuse the issue but I should note that the power setting *may* behave separately from the screensaver setting. In other words, if the screensaver is disabled but a power manager setting is set to blank the screen it may kick in.

Scott(0)'s answer here has always been the culprit for me.  Just adding a picture to his answer to clarify a bit.  Go to Menu -> Settings -> Power Manager.  On left side click "On AC" and/or "On Battery" (if using laptop).  On right, click "Monitor" tab and move the sliders all the way to the left to "Never" put display to sleep.




For me, that's always worked to stop screen from blanking (assuming I also have screensaver disabled).  Haven't had problem noted in Colin23erk's bug report myself.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: How do you keep screen from timing out in VLC
« Reply #9 on: July 12, 2014, 10:38:55 PM »
 

Reticent

  • Guest
VLC has a disable-screensaver setting, but it may not be well-informed or well-connected ... to the screensaver actually in use ...  ::)
 

Re: How do you keep screen from timing out in VLC
« Reply #10 on: July 14, 2014, 02:48:45 PM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Country: gb
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi all
I still needed to disable the Screensaver

I am not sure what the screensaver default option is set for at installation but mine was Set at "Blank Screen Only"with the result that Screen goes black after 10 mins -- this time is adjustable up to 720 minutes.

Why is the default -- Blank Screen after !0 mins and why does it over-ride the power options .

If a normal moving Screensaver was the default then we would be aware it was a screensaver causing the working screen to be lost .

My preferred Default would be to "Disable Screensaver"---seeing that Screensavers are not essential to prevent CRT  screen burnouts. Those that like a Screensaver could then set their own options  .

Another issue for me is could  all the settings  needed to control what happens on the screen  be brought under one  common integrated  "Display "  Settings option  so there is no need to search in Power setting  (not an obvious place) / Screensaver settings / Desktop settings / Display settings . for settings which may conflict with each other .

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: How do you keep screen from timing out in VLC
« Reply #11 on: July 14, 2014, 04:53:45 PM »
 

Reticent

  • Guest
(Answer to Original Post:  use a screen-saver that VLC works with, and power settings that keep the display on.  VLC's screensaver-suppression settings don't work with all screensavers, just expected one(s).)

Actually, screen-savers were invented because they are necessary for (vintage?) CRT monitors; there's an LCD-scrub version for certain LCD monitors, LED monitors generally don't need one at all ... and some of them add enough aesthetic ambience to be justified without "need".

I agree that a blank-screen screen-saver is an unwise selection for a live or pre-install default; it's likely simply politically least controversial.

Cross-connecting related settings menu-entries would definitely be wiser than the usual obfuscation-by-burial.
 

Re: How do you keep screen from timing out in VLC
« Reply #12 on: July 15, 2014, 04:23:59 AM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Country: gb
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi Reticent

 Thanks for your comments .Lets hope someone does something about the ideas.

 I choose to use Linux Lite because of its claim to be for non-geeks . My view is I want my computer to enable me to do my chosen tasks and not to be a hobby itself so I want the operating system to just do its work in the background .

The "Lite" team has done a very good job but is let down by the failure of the Ubuntu team not sorting long standing problems . Until Linux is seen to work out of the box in all departments with a minimum of background knowledge its never going to be as widely accepted as it deserves . It has to overcome its reputation of been hobby for geeks .

I have spent a month since I first installed Lite trying to get it to work properly in Bluetooth Audio , Screen Brightness , Screen going Blank , WiFi adapter , Office , etc . I have found it a handicap not understanding how to do things using Commands but I am not wanting to learn at 70

 Never heard of the word "obfuscation" so I looked it up . Good one !

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 


Tags:
 


Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.