You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] Need help please, how to update Libre office ?.

Author (Read 880 times)

0 Members and 3 Guests are viewing this topic.

Need help please, how to update Libre office ?.
« on: September 05, 2021, 03:04:16 PM »
 

kissbaby3

  • Forum Regular
  • ***
  • 168
    Posts
  • Country: us
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: 1.4 GHz

  • MEMORY: 8Gb

  • VIDEO CARD: on board
i am still using linux lite 4.8 64bit.

i have parts of libre office installed, it was that way when i first installed linux lite,  :dft003: .
the libre office version is

"Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group"

how do i update this libre office using the terminal ?.
can it be done ?, if yes what do i type in  the terminal to do this ?.

i want to say thank you to all those who reply, even if its to tease me with comedy, hugs  :o 8) .

Last Edit: October 12, 2021, 01:38:32 PM by firenice03
 


Re: Need help please, how to update Libre office ?.
« Reply #1 on: September 05, 2021, 09:32:29 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
i am still using linux lite 4.8 64bit.

i have parts of libre office installed, it was that way when i first installed linux lite,  :dft003: .
the libre office version is

"Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group"

how do i update this libre office using the terminal ?.
can it be done ?, if yes what do i type in  the terminal to do this ?.

i want to say thank you to all those who reply, even if its to tease me with comedy, hugs  :o 8) .

You can update LibreOffice to a newer version, even the latest, yes, but you'll have to uninstall the current one first, since it is the one offered by Ubuntu, so that one will be updated according to your OS version. To remove it, you can:
1. Launch Lite Software, and follow this procedure https://www.linuxliteos.com/manual/software.html#removesoftware
2. Launch Linux Lite Terminal, and type
Code: [Select]
sudo apt autoremove --purge libreoffice Hit Enter, type in your password when asked, and hit Enter again. This will remove everything related to LO.
3. Download LO from here https://www.libreoffice.org/download/download/ select a LO version, and the Linux (64-bit) (deb) file from the drop-down menu where it reads Choose your operating system once you've downloaded the file, extract it, and install it either by double-clicking on it, or via terminal
Code: [Select]
sudo apt install ./LibreOffice_7.2.0_Linux_x86-64.deb Note that since you're using LL 4.8, you might get some errors and LO might even refuse to install.
You can also download the appimage version https://libreoffice.soluzioniopen.com/ choose fresh

One advantage of using the appimage, is that you don't need to install it, thus you don't need to remove anything to use it; you can keep the old one and have this one too. https://docs.appimage.org/user-guide/run-appimages.html  I use the appimage and it works great. I think you should download the appimage, since it is way easier; download, make executable, and run. If you do decide to use the appimage version, I have a few tips:
I use around 20+ appimages. I created a folder named Appimages in my /home folder, this is where I keep them all. Then I add them to the menu, so they can be easily available.  A while ago I explained how I do this in another thread https://www.linuxliteos.com/forums/other/libre-office/msg54234/#msg54234

Hope this helps! :)
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: Need help please, how to update Libre office ?.
« Reply #2 on: September 13, 2021, 01:37:18 AM »
 

kissbaby3

  • Forum Regular
  • ***
  • 168
    Posts
  • Country: us
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: 1.4 GHz

  • MEMORY: 8Gb

  • VIDEO CARD: on board
thank you , that did the trick, i went with the app image
 

Re: Need help please, how to update Libre office ?.
« Reply #3 on: September 13, 2021, 08:41:30 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
thank you , that did the trick, i went with the app image

You're welcome. Glad it worked. :) By the way, to update the appimage, you'll need to download the new version when it is available.
Last Edit: September 14, 2021, 04:06:03 PM by Moltke
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 


 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements