You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[ SOLVED ] cannot update linux lite

Author (Read 1341 times)

0 Members and 1 Guest are viewing this topic.

cannot update linux lite
« on: August 02, 2020, 01:37:56 AM »
 

ThisIsMeta

  • New to Forums
  • *
  • 2
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: intel core 2 duo P8700

  • MEMORY: 2Gb

  • VIDEO CARD: integrated graphics
I need help with this one, I've looked around on the net and can't find any solutions

===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

Hit:1 http://repo.linuxliteos.com/linuxlite emerald InRelease
Hit:2 https://repo.steampowered.com/steam stable InRelease
Hit:3 http://archive.canonical.com/ubuntu focal InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:5 https://deb.opera.com/opera-stable stable InRelease
Get:6 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [111 kB]
Hit:7 http://ppa.launchpad.net/appgrid/stable/ubuntu focal InRelease
Get:8 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Ign:10 http://ppa.launchpad.net/libretro/gcc-for-libretro/ubuntu focal InRelease
Hit:11 http://ppa.launchpad.net/libretro/stable/ubuntu focal InRelease
Err:12 http://ppa.launchpad.net/libretro/gcc-for-libretro/ubuntu focal Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists...
E: The repository 'http://ppa.launchpad.net/libretro/gcc-for-libretro/ubuntu focal Release' does not have a Release file.
Last Edit: August 02, 2020, 06:09:17 AM by ThisIsMeta
 


Re: cannot update linux lite
« Reply #1 on: August 02, 2020, 02:02:29 AM »
 

stevef

  • New to Forums
  • *
  • 36
    Posts
  • Country: gb
  • Reputation: 5
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Your machine is using some software that has a PPA (Personal Package Archive) in your update list.  PPA aren't part of the supported software repositories.  Unfortunately, if there is a problem with a listed PPA it stops the update process working because the machine cannot find everything on the list.

To remove a failing PPA from the list and allow the rest of the update to work check the manual at

https://www.linuxliteos.com/manual/software.html#pparem

and remove the offending PPA as described there.
 

Re: cannot update linux lite
« Reply #2 on: August 02, 2020, 06:08:50 AM »
 

ThisIsMeta

  • New to Forums
  • *
  • 2
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: intel core 2 duo P8700

  • MEMORY: 2Gb

  • VIDEO CARD: integrated graphics
Thank you! it seems to have solved the problem.
 

Re: cannot update linux lite
« Reply #3 on: August 02, 2020, 08:56:56 AM »
 

stevef

  • New to Forums
  • *
  • 36
    Posts
  • Country: gb
  • Reputation: 5
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
You are welcome.

As I understand it, removing a PPA from the sources list is a workaround to allow the update process to complete to ensure that other packages get their updates. But it means you will not get any updates from that source in the future.

If you need (and trust) the software source you may want to check periodically to see if the PPA is put back on line by reversing the change you made.
 


Tags: update fail help 
 


Download Linux Lite 5.2 today - See Release Announcements