You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



Can't upgrade to Linux Lite 4.4

Author (Read 2207 times)

0 Members and 6 Guests are viewing this topic.

Can't upgrade to Linux Lite 4.4
« on: May 23, 2019, 06:19:34 PM »
 

PCTECH

  • New to Forums
  • *
  • 18
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.6 32bit

  • CPU: Intel Core Duo

  • MEMORY: 4Gb

  • VIDEO CARD: Intel inbedded
Hello

I'm currently running LL 4.2 on my Dell Latitude E6500. I have attempted to upgrade to LL 4.4 using the Lite Upgrade tool. I get an error that reports that the system cannot connect to the "master Linux Lite repository", upgrade has been canceled. Regular system updates download & install correctly and I'm not having any internet connectivity problems either. I tried changing LL repositories  without any effect. I was able to upgrade this system from LL 4.0 to 4.2 using the Lite upgrade tool.
Any suggestions welcomed.

Thanks
Mark :)
 


Re: Can't upgrade to Linux Lite 4.4
« Reply #1 on: May 23, 2019, 08:36:37 PM »
 

Artim

  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 334
    Posts
  • Country: us
  • Reputation: 45
  • I must be weird to love school
    • Confessions of a Technophobe

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller
The server may have been down or busy at the time.  First update your current 4.2, then reboot and try the Lite Upgrade tool again.  Let us know!
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #2 on: May 24, 2019, 11:31:34 AM »
 

PCTECH

  • New to Forums
  • *
  • 18
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.6 32bit

  • CPU: Intel Core Duo

  • MEMORY: 4Gb

  • VIDEO CARD: Intel inbedded
I've tried to the upgrade on several occasions  without success. Would attempting the upgrade by using the terminal be worth a try? If yes, what is the desired APT command?

Mark
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #3 on: May 24, 2019, 06:59:57 PM »
 

Artim

  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 334
    Posts
  • Country: us
  • Reputation: 45
  • I must be weird to love school
    • Confessions of a Technophobe

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller
I meant upDATE and reboot before you upGRADE.  If that doesn't work, the simplest solution is to download 4.4 and install.
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #4 on: May 25, 2019, 08:08:14 AM »
 

TheDead

  • Gold Level Poster
  • *******
  • 578
    Posts
  • Country: ca
  • Reputation: 52
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 3.8 32bit

  • CPU: HAL9000

  • MEMORY: 1Gb

  • VIDEO CARD: Oculus Rift v.5
Just my two cents...

Could it be that this systems was installed with the beta of 4.2, which is not upgradable?
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #5 on: May 25, 2019, 10:50:06 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1482
    Posts
  • Country: us
  • Reputation: 242
  • * Forum Moderator *

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
@TheDead ,


That is an excellent guess.  I wouldn't be surprised if that was the reason.  It has never been my experience that Lite Upgrade was this hard.
Want to thank me?  Click my [Thank] link.
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #6 on: June 13, 2019, 01:51:53 PM »
 

PCTECH

  • New to Forums
  • *
  • 18
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.6 32bit

  • CPU: Intel Core Duo

  • MEMORY: 4Gb

  • VIDEO CARD: Intel inbedded
My original install on that computer was Linux Lite 4.0, which was purchased from LL itself on an OEM   USB key. I've still had no luck upgraded to LL 4.4. Maybe it's time to move on from LL to another distro on that computer or roll back to the LL 3x series. ???
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #7 on: June 13, 2019, 06:47:07 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1482
    Posts
  • Country: us
  • Reputation: 242
  • * Forum Moderator *

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
@PCTECH ,


As noted in this thread by @TheDead , are you sure you are not running the beta version of Linux Lite 4.0?  Furthermore, it is confusing to say the original install was LL 4.0 but you're thinking about rolling back to 3.6.


Either way, you can download 4.4 from the website.  Verify the download by doing an md5 checksum, and booting to that version.  From there you can decide if you want to install it or not.
Want to thank me?  Click my [Thank] link.
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #8 on: June 13, 2019, 09:07:16 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7019
    Posts
  • Country: nz
  • Reputation: 652
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Please name the exact steps you are using to Upgrade. The upgrade tool itself has no bugs so logically it can only be some sort of network issue. We will find the answer.
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #9 on: June 13, 2019, 09:12:46 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7019
    Posts
  • Country: nz
  • Reputation: 652
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
You could also try modifying some of the code.

In /usr/bin/lite-upgrade-series4 (right click, Open as Admin)
try changing line 237 from:

Code: [Select]
wget -qnv -t2 -T8 --ignore-length --max-redirect=1  --spider http://repo.linuxliteos.com/linuxlite/db/version
to:

Code: [Select]
curl -sk repo.linuxliteos.com/linuxlite/db/version
save and close the file. Try Upgrade again.
Last Edit: June 13, 2019, 09:17:25 PM by Jerry
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #10 on: June 14, 2019, 04:32:03 PM »
 

PCTECH

  • New to Forums
  • *
  • 18
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.6 32bit

  • CPU: Intel Core Duo

  • MEMORY: 4Gb

  • VIDEO CARD: Intel inbedded
Jerry

I originally install LL 4.0 from the USB key that I purchased from you. I installed system updates as needed without any issues. When LL 4.2 became available I was able to upgrade using the LL upgrade tool. I've installed all system updates as needed since then without issue. When I attempted to upgrade to LL 4.4 using the upgrade tool it reports that it cannot connect to the LL repository, update cancelled. I've  tried switching LL repositories with out luck. I don't seem to be having network issues of any type, but obviously the system is having issues locating the LL 4.4 source

Thanks
Mark
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #11 on: June 14, 2019, 09:56:49 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7019
    Posts
  • Country: nz
  • Reputation: 652
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
I assume you have already done what I put in Post #9 ?
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #12 on: June 14, 2019, 10:51:18 PM »
 

supergamer

  • Forum Regular
  • ***
  • 119
    Posts
  • Country: us
  • Reputation: 24
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: AMD Phenom 565

  • MEMORY: 12Gb

  • VIDEO CARD: 550 ti
If the system is completely updated then updated version numbers is pointless as it is the same if on the same base number. You can check the /etc/issue file and /etc/lsb-release to see as that is what your system is using to report the version number.
 

Re: Can't upgrade to Linux Lite 4.4
« Reply #13 on: September 03, 2019, 04:27:00 PM »
 

PCTECH

  • New to Forums
  • *
  • 18
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.6 32bit

  • CPU: Intel Core Duo

  • MEMORY: 4Gb

  • VIDEO CARD: Intel inbedded
Update, I was able to update LL 4.6 using the Lite Upgrade tool without any issues. :D
 


Tags:
 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.