You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



[ SOLVED ] Recover a deleted directory

Author (Read 1098 times)

0 Members and 3 Guests are viewing this topic.

Recover a deleted directory
« on: December 04, 2017, 06:56:33 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 507
    Posts
  • Country: ve
  • Reputation: 68
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
Hi everyone! Hope you're all having a nice life! :)

I need some help here please, I accidentally deleted x86_64-linux-gnu directory from /usr/lib/x86_64-linux-gnu and now nothing works; no thunar, no browsers...I'm writing from a live session and tried to recover the directory with extundelete by following instructions from here: http://extundelete.sourceforge.net/ but when trying 
Code: [Select]
sudo mount -o remount,ro /dev/sdb5 I get the error
Code: [Select]
mount: /dev/sdb5 not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
  So, as instructions explained I simply unmounted the partition and ran
Code: [Select]
sudo extundelete /dev/sdb5 --restore-directory /usr/lib/x86_64-linux-gnu
but I got
Code: [Select]
extundelete: Bad magic number in super-block when trying to open filesystem /dev/sdb5I also tried with gparted  >device> attemp to rescue data option but it didn't work. I have performed all of this actions from the live session, haven't written anything on the disk since folder was deleted cause I know there are more chances of recovering the data that way. Can I recover that folder? or will I have to reinstall LL?
Any help/advice is really appreciated. Thanks!
Last Edit: December 05, 2017, 05:08:36 AM by Moltke
Without each others help there ain't no hope for us :)
 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky