You are Here:
Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.



[ SOLVED ] Keyboard error requiring Fn key during test run

Author (Read 426 times)

0 Members and 1 Guest are viewing this topic.

Keyboard error requiring Fn key during test run
« on: May 06, 2019, 05:51:18 PM »
 

v-grimalkin

  • Borderline Technophobe
  • New to Forums
  • *
  • 28
    Posts
  • Country: us
  • Reputation: 0
  • Happy 4.4 User

  • Linux Lite: 4.4 64bit

  • CPU: Intel Atom N570

  • MEMORY: 1Gb
Downloaded Linux Lite 4.4 and ran test to make sure my old Acer Aspire 1 laptop/notebook could handle the os.  Looks great, but when I tried typing, I found that half the keyboard spits numbers instead of letters.  I determined I could get letters by pressing Fn key before the problem keys, but I want to find out if this bug is fixable before I install on my pc.

My notebook is 64 bit with 1 GB memory and Intel Atom CPU N570 @1.66 GHz x 2.  Unfortunately, the bios have never been updated, since Windows 7 never helped me do so, and now all I have is Linux Mint Cinnamon 17.3.

This may not truly be a "bug", then, but a failure on the part of a tired old Acer.  If so, I may have to resort to buying a new laptop.  :-[
Last Edit: May 16, 2019, 04:40:57 PM by v-grimalkin
 


Re: Keyboard error requiring Fn key during test run
« Reply #1 on: May 06, 2019, 06:47:17 PM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
This is not a bug, Linux Lite comes with numlock installed and enabled as default.
Numlock can be enabled/disabled in Lite-Tweaks
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Keyboard error requiring Fn key during test run
« Reply #2 on: May 06, 2019, 06:51:14 PM »
 

v-grimalkin

  • Borderline Technophobe
  • New to Forums
  • *
  • 28
    Posts
  • Country: us
  • Reputation: 0
  • Happy 4.4 User

  • Linux Lite: 4.4 64bit

  • CPU: Intel Atom N570

  • MEMORY: 1Gb
Thanks.  I opened "Tweaks", but I was lost or else it did not work.  I'll try again.  Another post suggested hitting Fn and Esc, which I will also try.
 

Re: Keyboard error requiring Fn key during test run
« Reply #3 on: May 06, 2019, 06:57:55 PM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
Open Lite-Tweaks and scroll down till you see numlock, put a tick in the box and then click on the BEGIN button at the bottom, enter your password, choose enable or disable and then Apply, then quit out of Lite-Tweaks
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Keyboard error requiring Fn key during test run
« Reply #4 on: May 06, 2019, 10:54:33 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6815
    Posts
  • Country: nz
  • Reputation: 626
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Moved, not a Bug.
 

Re: Keyboard error requiring Fn key during test run
« Reply #5 on: May 07, 2019, 02:51:42 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
@Jerry  I've been wondering if it's worth changing the default for Linux-Lite 5.0 so that numlock is actually disabled as default.

There's been a few people asking for help because of the gibberish when typing. If disabled, people can still enable if they want. It's possible Linux-Lite is losing users who try it, have this problem and just move to another distro rather than ask on these forums.

This would also help the people who can't login because they created a password with numlock on and trying to login in with numlock off.

:) :) :)
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Keyboard error requiring Fn key during test run
« Reply #6 on: May 07, 2019, 02:54:45 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6815
    Posts
  • Country: nz
  • Reputation: 626
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
There's no win situation here, this has been discussed before. Damned if you enable it, damned if you disable it. The middle ground is having an option in Lite Tweaks.
 

Re: Keyboard error requiring Fn key during test run
« Reply #7 on: May 07, 2019, 03:01:22 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
@Jerry lol, true.

As stated my argument would be the new users trying Linux-Lite out that might find it a deal-breaker and move to another distro without asking for help here.

Anyway not my decision in the end :)
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Keyboard error requiring Fn key during test run
« Reply #8 on: May 07, 2019, 03:05:15 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6815
    Posts
  • Country: nz
  • Reputation: 626
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
New users would still be affected my friend, regardless of the whether it is enabled or disabled. As I said, damned if you do, damned if you don't. In the interests of what people are used to, we best stick with option. I'm not concerned with losing potential users over a no win situation. Cheers :)
 

Re: Keyboard error requiring Fn key during test run
« Reply #9 on: May 07, 2019, 04:30:44 PM »
 

v-grimalkin

  • Borderline Technophobe
  • New to Forums
  • *
  • 28
    Posts
  • Country: us
  • Reputation: 0
  • Happy 4.4 User

  • Linux Lite: 4.4 64bit

  • CPU: Intel Atom N570

  • MEMORY: 1Gb
Thanks to both of you for your help, especially for how to "tweak", since this keyboard issue was the only worry I've encountered so far.  I am really impressed with this terrific forum as well as the most promising operating system I've tried since Linux Mint Cinnamon.  Kudos to you who have created and worked on Linux Lite.
 

Re: Keyboard error requiring Fn key during test run
« Reply #10 on: May 08, 2019, 07:32:46 PM »
 

v-grimalkin

  • Borderline Technophobe
  • New to Forums
  • *
  • 28
    Posts
  • Country: us
  • Reputation: 0
  • Happy 4.4 User

  • Linux Lite: 4.4 64bit

  • CPU: Intel Atom N570

  • MEMORY: 1Gb
S6rry t6 be a *a5n, but I tried the tweak routine, and it will not work running from the usb stick.  It did not ask for a password of course, as there is none.  As y64 can see, I must still use Fn key.

This is my last concern before installing, but will the lite tweak work once I install? 
 

Re: Keyboard error requiring Fn key during test run
« Reply #11 on: May 08, 2019, 07:47:44 PM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
Did you reboot, or unplug the USB after using lite-tweaks ?
The reason I ask is the usb is a live-session and read-only environment, so while the tweak will work as you use the live session, once you reboot it needs to be applied again.

Once installed the lite-tweak will work after reboot as it is stored in the OS settings
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Keyboard error requiring Fn key during test run
« Reply #12 on: May 09, 2019, 09:27:16 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1458
    Posts
  • Country: us
  • Reputation: 231
  • * Forum Moderator *

  • Linux Lite: 4.4 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
Want to thank me?  Click my [Thank] link.
 

Re: Keyboard error requiring Fn key during test run
« Reply #13 on: May 09, 2019, 02:14:01 PM »
 

v-grimalkin

  • Borderline Technophobe
  • New to Forums
  • *
  • 28
    Posts
  • Country: us
  • Reputation: 0
  • Happy 4.4 User

  • Linux Lite: 4.4 64bit

  • CPU: Intel Atom N570

  • MEMORY: 1Gb
Did you reboot, or unplug the USB after using lite-tweaks ?
The reason I ask is the usb is a live-session and read-only environment, so while the tweak will work as you use the live session, once you reboot it needs to be applied again.

Once installed the lite-tweak will work after reboot as it is stored in the OS settings

Thanks.  I think this answers my concern.  ;D
 

Re: Keyboard error requiring Fn key during test run
« Reply #14 on: May 09, 2019, 02:16:23 PM »
 

v-grimalkin

  • Borderline Technophobe
  • New to Forums
  • *
  • 28
    Posts
  • Country: us
  • Reputation: 0
  • Happy 4.4 User

  • Linux Lite: 4.4 64bit

  • CPU: Intel Atom N570

  • MEMORY: 1Gb
@v-grimalkin ,


Consider this:  https://us.answers.acer.com/app/answers/detail/a_id/3181/~/how-do-i-enabled-or-disable-number-lock-on-my-acer-aspire-one-netbook%3F

Thanks, but so far, it won't work during usb test.  Think I'll go ahead and install it.  Will give my results here as SOLVED or screwed.   ;)
 


 


Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.