Software - Support > Installing Linux Lite

Installation hung up on 'Creating user'

(1/2) > >>

mkamerick:
I am trying to install Linux Lite on an Acer Aspire One netbook.
The installation hangs up a the 'Create user' point and never gets past it.
This is my second attempt.  The first one went on for over 24 hours before
I shut down the netbook.

The netbook does boot the LiveOS off of a USB stick perfectly well.
Linux Lite seems to run well on this little machine.

I am trying to install a dual boot configuration in order to preserve
the user files still in the XP partition.
If that is a real source of problems I could just do a full wipe and install.

Tia.

M. Kamerick

gold_finger:
I'm not familiar with netbooks, but this link shows that the Acer Aspire One netbook only has an 8GB SSD.
https://wiki.archlinux.org/index.php/Acer_Aspire_One#Preparation_prior_to_installing_Arch_Linux

If that is the case with you, then it's likely that there isn't enough room left on the drive for the Linux installation with Windows XP on it.

That link also recommends using a separate SD card in card reader slot for to use as a separate /home partition because of the SSD size limitation.  In effect, it's saying the best way to install on a system like yours is to have the "/" (root) partition installed to the SSD and have /home and swap partitions on the SD card.  Do you have an SD card you could use for this purpose?  (If not, you will still be able to fit the Linux Lite installation on the SSD -- you just won't have a whole lot of room for saving things.)

To confirm that this may be your problem, boot-up using the live USB.  Then open a terminal (Menu -> Accessories -> Terminal), and enter these commands in the terminal one at a time:


--- Code: ---sudo fdisk -l
lsblk
--- End code ---
(Note:  the first command ends in a lowercase "L", not the number 1.)

Copy/Paste that output from terminal back here for us to see.  To do that, hit the code button "#" above where you type reply, then paste the output between the two code blocks -- [ code ]...[ /code ].

mkamerick:
Thanks very much for your thoughtful reply, but this netbook has a 160GB hard drive, not a small SSD,
so I don't see space per se as the issue.
It may be that the partition map the installation is selecting for the dual boot option
is an issue.
At this point, I think an MBR has been (re)written, because the machine won't boot XP anymore.
Or anything.

I can still boot off the USB stick.

One other thought I had is that I selected the option to encrypt my own user directory.
Since the install hangs up at 'Create user', I thought perhaps that was an issue.
I am going to try this one more time without that option.

But I do appreciate any suggestions.

MK

gold_finger:

--- Quote from: mkamerick ---netbook has a 160GB hard drive, not a small SSD, so I don't see space per se as the issue.
--- End quote ---

Ok -- space probably not the issue then.



--- Quote from: mkamerick ---At this point, I think an MBR has been (re)written, because the machine won't boot XP anymore.
Or anything.
--- End quote ---

Can probably solve that easily by following these instructions:  How to Repair MBR (Windows Boot Loader) From Ubuntu.  Open a terminal (Menu -> Accessories -> Terminal), then follow the instructions beginning at step #2.  (Step #1 is unnecessary.)   It would be best to copy/paste those commands as opposed to typing them out.  That way you'll avoid potential typos and/or syntax issues.  Definitely do that for the step #3 command!  If you make a typo, it could wipe out the drive.

When you're done with above, reboot w/o USB and see if it worked.  Then reboot into live LL USB again and post back the output of the two commands in my first post so we can see what partitions are on the drive now.

Let us know your experience level with Linux also.  Will know how detailed to make answers then.

P.s.  Did you have to shrink any Windows partitions before the LL install?  And if so, did you defragment drive before doing that?

mkamerick:
Thanks again for your response.
I was able to get through the install on my last try.
I did end up redoing the partition map by hand, as two failed installs
had left two Linux root partitions and two swap partitions laying around.
I also did NOT click the box to have my own account encrypted.
The install went just fine.
I can dual boot now.  The first time through booting XP I did have to run
all the CHKDSK stuff, but it worked.

Without question this limited little machine runs better on Linux Lite than XP,
so I am pleased to have finally gotten through the install.

And I can still access the original user files.

Navigation

[0] Message Index

[#] Next page

Go to full version