You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
Cannot mount or eject external USB hard drive

Author (Read 1860 times)

0 Members and 2 Guests are viewing this topic.

Cannot mount or eject external USB hard drive
« on: April 01, 2021, 11:35:18 PM »
 

mountainlover

  • New to Forums
  • *
  • 7
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: Dual core AMD Athlon II X2 220 (-MCP-)Dual core AMD Athlon II X2 220 (-MCP-)

  • MEMORY: 2Gb

  • VIDEO CARD: NVIDIA C61 [GeForce 6150SE nForce 430]
I am very new with Linux, so I need very high level feedback. Any help is appreciated!

I am trying to mount my external hard drive (done many, many times) after a few copy processes hung up and having issues.  It's really important for us to retain the data on this drive.  I unmount and try to eject and receive another error.  My external hard drive is lit up constantly as though it's hung up.  I'm afraid to just unplug it.  Any ideas?

I have a File Operation Progress screen showing four copies in progress (I've clicked on the X next to each to cancel them, but those are all hung up, saying "Canceling" with nothing happening in the status bars).

When I try to eject the device after I unmount it, I get: Failed to eject "FreeAgent GoFlex Drive". / Error opening /dev/sde: Device or resource busy.

When I try to mount the device I get: Failed to mount "FreeAgent GoFlex Drive". / Error when getting information for file '/media/mountainlover/FreeAgent GoFlex Drive': Transport endpoint is not connected.

Any help is appreciated!
 


Re: Cannot mount or eject external USB hard drive
« Reply #1 on: April 02, 2021, 11:26:08 AM »
 

mountainlover

  • New to Forums
  • *
  • 7
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: Dual core AMD Athlon II X2 220 (-MCP-)Dual core AMD Athlon II X2 220 (-MCP-)

  • MEMORY: 2Gb

  • VIDEO CARD: NVIDIA C61 [GeForce 6150SE nForce 430]
I read this post, but cannot get into my gui screen to add it to my .config file (tried in terminal too, but it looked like just an empty file, so exited out, didn't want to mess anything up):
****
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1208993

Changed my life adding

vm.dirty_background_ratio = 5
vm.dirty_ratio = 10

in /etc/sysctl.conf
and running sysctl -p
****
When I do Alt+F2 to access the file, nothing happens.  Any advice?  After I had shut down my computer last night, I started up fine, then tried copying over those files to my external usb hard drive again, and it's hung up again. 
Last Edit: April 02, 2021, 11:27:48 AM by mountainlover
 

Re: Cannot mount or eject external USB hard drive
« Reply #2 on: April 02, 2021, 06:06:11 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1626
    Posts
  • Country: us
  • Reputation: 272
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@mountainlover

The HDD should mount on its own... It'll attach to /media I believe...
If you hard manually mounting it - via the mount command, can you unmount via umount?

Also, you may be getting the cannot eject in use message if there is something open to it, file manager or another application: Backup, Viewer, Reader, etc etc...

If you cant eject, for what ever - you can shutdown the pc, that should close out any open/held connections.

While its plugged in and working...
Perhaps the output of... would be a start...
Code: [Select]
df -h
lsblk
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.6 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.6 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: Cannot mount or eject external USB hard drive
« Reply #3 on: April 03, 2021, 11:53:39 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1319
    Posts
  • Country: us
  • Reputation: 204
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.6 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Your profile says 2gig of RAM. If that is the case it's unrealistic to try and solve this issue which can be mitigated with swap and cache settings on bigger RAM systems. If you read the post all the way through the mitigation was to turn off swap completely, though other caching process controls can be tweaked as well, but your 2gig of RAM limits the amount of performance boost you may get without swap and cache limiting. You can try with swap off, but your system may go OOM.

PS, GUI disappears because your video card is configured above base memory, rather than below and you have memory limitations during big file transfers.

Things to try: Reboot your base system and use Lite Tweaks  to clear all memory and caches, then turn swap off and try the copy process. If your BIOS offers video card settings choose below rather than above.
TC
Last Edit: April 03, 2021, 12:03:05 PM by trinidad
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements