You are Here:
Download Linux Lite 5.4 RC1 today - See Release Announcements



[ SOLVED ] Bug, or non-intuitive behavior when mounting USB drive in multi-user LL?

Author (Read 2707 times)

0 Members and 1 Guest are viewing this topic.

 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
I'm not sure if the following issue would be considered a bug, or simply non-intuitive behavior of LL. Either way, if users in a multi-user setup are not aware of this, they may think they cannot mount their USB drives.

Here is the issue, which is consistently replicable for me under LL 3.8 and 4.0. I'll describe it from a colloquial first-person perspective, which is easier for me that saying "user 1" and "user 2".

1. The LL is set up to have me as main (admin) user, and two additional non-admin users for my family members.

2. The machine is booted up and my family member logs in under his account. I am not logged in at this point.

3. Then he says I can use it, so we switch users via the GUI "switch user" in the menu. He is not formally logged out at this point - he may want to come back to it soon. I'm just logging into my account, so I see my background, my icons, etc etc.

4. I insert my USB drive to get some files from it. Although the USB drive can be seen on my desktop, it is grayed out and it doesn't auto-mount. If I try to open it, I can't. A dialog box comes up saying something about "Failed to mount" and that some operation is already pending. Whatever I do, I can't seem to auto-mount the USB drive, until.....

5. I switch users via the GUI back to his account (I'm not formally logged out at this point). i.e. I simply have him go back into his account so that we can see his background, icons, etc etc. It turns out that the USB drive is seeking authentication to auto-mount there, instead of in my area. But I can only see this process when we switch back to his account, not mine. In other words, if you want to auto-mount a USB drive but you're not the first person to log in since the computer was started up, you won't auto-mount it that session.

SO TO SUM UP: I don't know if this is a bug or the expected behavior of Linux, but it seems odd that it won't let a currently-logged-in user (especially a logged-in admin user) auto-mount a USB drive if another user has logged in before them.

Is there an easy work-around for this issue? If not, it's OK, but users should be aware of it if they're on a multi-user system and wish to have a USB drive auto-mount.
Last Edit: June 05, 2018, 10:24:00 PM by Vera
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 


 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 857
    Posts
  • Country: 00
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics

Hi Vera,

I was able to reproduce the problem, this seems to fix it:

1. Settings > Removable Drives and Media > Storage Tab > Uncheck the first three options:
   - Mount removable drives when hot-plugged
   - Mount removable media when inserted
   - Browse removable media when inserted

2. Logout out

3. Do this for all users

4. Test, does it work? After inserting the usb drive nothing much may appear to happen. In my case I went to the file manager and there it was.

5. Note, my usb drive has a fat format.

6. Note, I've only tested in LL4
Last Edit: June 06, 2018, 11:00:32 PM by Scott
 

 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
Wow! Thanks for trying this out and for getting back to me so quickly, @Scott . I did exactly what you said, and tested it out. It works like a charm!

I didn't even have to go to my file manager using your solution - there was the USB drive on the desktop. Perfect. Thank you for looking into this AND finding a solution that works exactly how I wanted it to!!

I did the testing twice to be certain. I did it with a secondary user logged in first and then me logging in (as described in original post). The USB mounted fine. Then I restarted the computer, and next test I did it just with the two secondary users, logging one in first then logging in with the other one. In both cases the problem was fixed and the USB drive was mounted!! I did this in LL 4.0, with an ext4 formatted USB as that's what I had been using.

So, I think it's safe to say you have found the solution! Many, many thanks on behalf of me and my family. I will mark this as solved.
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 

 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 857
    Posts
  • Country: 00
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics

@Vera
Your enthusiasm makes me smile, happy we were able to fix the problem.
~Scott
 


Tags:
 


Download Linux Lite 5.4 RC1 today - See Release Announcements