You are Here:
Linux Lite 4.2 Final has been released. See the Release Announcements Section.



[ SOLVED ] How I disable tearing and setup blender to work with CUDA GPU's

Author (Read 349 times)

0 Members and 1 Guest are viewing this topic.

 

Roy

  • New to Forums
  • *
  • 36
    Posts
  • Country: il
  • Reputation: 2
  • Linux Lite FTW

  • Linux Lite: 4.0 64bit

  • CPU: intel core i7 4820k

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GTX 970
Hi all

So I was just install a fresh LL4 on my machine and ran into some tearing problems and also after installing Blender it couldn't find my CUDA enabled device.
So I dig into the internet a bit and found some solutions to my problems and wanted to share here for others struggling with that same situation and for future use :)

My setup includes an Intel's Core i7 4820k and nVidia GTX970 (CUDE enabled with compute capability of 5.2) as well as dual Dell 2K monitors

How I got rid of the tearing issue
Before following this post, I was making sure I am using the recommended nvidia proprietary driver

And then installed nvidia-settings (or at least make sure it is installed)

Then I ran nvidia-settings as root and navigate to 'X Server Display Configuration' and clicked on "Advanced.." button on the bottom right
Now.. FOR EACH monitor I ticked "Force Composition Pipeline" AND "Force Full Composition Pipeline" then hit the "Apply" button and "Save to X Configuration File" button
Before I quit nvidia-settings I made a change in my display projection (with Super-P combo) to make sure it was setup correctly
The change was just to update the xorg.conf file while nvidia-settings still open
Then I came back to nvidia-settings and accepting reload of the xorg.conf file and again I was making sure for each monitor the two check boxes still ticked and then pressed "Apply" and "Save to X Configuration File" buttons ones more and hit the "Quit" button
At this point if I was rebooting, I was facing another problem where I can see the mouse working correctly but everything else was missing.. only the background and a part of one of my panel was presented and cannot be interactable, launching apps works but won't show anything.. only when pressing CTRL+ALT+F1 then CTRL_ALT+F7 fixed that issue..
So I had to attach a script on startup to assign my monitors to nvidia-settings
Code: [Select]
nvidia-settings --assign CurrentMetaMode="DP-2:2560x1440_60 +0+0 { ForceFullCompositionPipeline = On }, DP-4.8:2560x1440_60 +2560+0 { ForceFullCompositionPipeline = On }"Now I am enjoying a tear-free environment  ;D


How I got Blender to recognize my CUDA GPU
So after installing Blender I have noticed it cannot recognize my GPU device at all
So I dig again in the internet and found that (in this answer) for Blender to work properly with Nvidia and CUDA it requires nvidia-cuda-toolkit, nvidia-modprobe and the proprietary drivers installed
This time it was easier as I only had to run this in the terminal:
Code: [Select]
sudo apt-get install nvidia-cuda-toolkit nvidia-modprobeRelaunch Blender and in the "User Preferences" -> "System" I found CUDA's available under "Cycles Compute Devices" and underneath that my GTX970 device was ticked


And that's it! Blender is now fully working in my tear-free environment and I am happy  ;D YAY!!
Hope you'll find it helpful
Last Edit: July 08, 2018, 01:39:12 PM by Roy
 


Tags:
 


Linux Lite 4.2 Final has been released. See the Release Announcements Section.