Linux Lite Forums

Hardware - Support => Video Cards => Topic started by: Marktech on July 18, 2014, 06:12:46 AM

Title: Screen resolution stuck on 640x480
Post by: Marktech on July 18, 2014, 06:12:46 AM
Hi, all -

I've just started using Linux Lite, and this is my first post here: I have a little problem!  ;)

My neighbours gave me an old E-System Sorrento laptop which they frankly said wasn't much cop even when it was new, but it turns out to be perfectly adequate for occasional use -- once it has a lightweight Linux distro on it.  It has an Intel Celeron C900 single-core processor, and integrated graphics: I tried a live session of Linux Lite, and installed.

The live session defaulted to a resolution of 1024-768 at 61Hz, which was perfect; but the install uses 640x480, and I can't change it.

Running xrandr gives me 640x480 as the only option.

I attach a copy of system-info output.

I'd be very grateful for any help: I'd really like to use this distro on this system, and as it stands it's not really usable!

[attachment deleted by admin, more than 25 days old]
Title: Re: Screen resolution stuck on 640x480
Post by: lidiaz on August 29, 2014, 03:09:16 PM
Hi, Marktech
I'm going trough the same problem!
For what I've researched so far, I figure it's a bug with SiS graphic cards.
To confirm if you have that kind of graphic card, you may run the command:

sudo lshw -C display

If it returns you something like:

*-display UNCLAIMED     
       description: VGA compatible controller
       product: 771/671 PCIE VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]

then, probably, the problem is that bug.

For some Ubuntu versions there are some - very complicated - ways to fix it.
I still don't know if this Linux Lite version has any fix...

If you find something, please comment!
Title: Re: Screen resolution stuck on 640x480
Post by: ealgiros on May 15, 2019, 04:23:26 PM

Just had the same problem with LL3.8, then upgraded to LL 4.4 and the problem remained

The following SOLVED it: (though the GUI became kinda slow since, maybe will go back to LL 3.8 and see what happens. Don't undestand why the LIVE CD GUI worked faster ...)

Open a Terminal and create a xorg.conf file

Code: [Select]
sudo leafpad /etc/X11/xorg.conf
It will open a text editor with elevated user privileges.
Now copy and paste this in it:

    Section "Device"
      Identifier "Configured Video Device"
      Driver "vesa"

Save xorg.conf

Reboot PC

PS: copied this solution from another post in this forum: ([ SOLVED ] 640x480 is the only available screen resolusion? )