Hardware - Support > Video Cards

Nvivida card not found after upgrade

(1/2) > >>

gold_finger:
Good Job!!!  Glad to see you got it settled.

Might be a good idea to make a backup copy saved to same directory just in case some update along the line messes it up.

--- Code: ---sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.goodcopy
--- End code ---

If the need arises to restore it.

--- Code: ---sudo cp /etc/X11/xorg.conf.goodcopy /etc/X11/xorg.conf
--- End code ---


Once you have the backup made, you may want to try inserting the specs that I found on your monitor in place of the generic ones "suggested" to see if they offer slight improvement.  Just replace things below in blue -- not whole file.

Your Current One Says:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 80.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection


Mine from Monitor Specs:

Section "Monitor"
   Identifier   "Configured Monitor"
   VendorName   "Neovo"
   ModelName   "F-419"
   HorizSync   24 - 80
   VertRefresh   56 - 75
   Option      "DPMS"
EndSection


If those work and you want to keep those settings, copy them to the backup file using same command as above.  (It will overwrite the first xorg.conf.goodcopy you made with the new settings.)

leegold:

--- Quote from: gold_finger on March 24, 2014, 04:37:29 PM ---snip...

First -- Make sure that the 173 driver is the one you are using.  Then continue below.

Looked up specs on your machine and made a couple of changes to the xorg.conf file from that post.  Do the following to either replace your current xorg.conf (if it exists), or to create one (if it doesn't).

...snip


--- End quote ---

Yes! I needed to edit xorg.conf, so you were steering me on the right track, thanks.

I did sudo nvidia-xconfig which I think makes an xorg.conf file or "refreshes" it...then when I rebooted  I got a stern message that the resolution and refresh rate were out of range and the message suggested "1280x1024" and 60hz. I edited xorg.conf appropriately and to my slight disbelief a hi-res usable desktop now appears and seems to work. I post yet another xorg.conf  below:


--- Code: ---# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buil[email protected])  Wed Nov 27 15:15:17 PST 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 80.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
Modes     "1280x1024"  "1024x768"
    EndSubSection
EndSection

--- End code ---

gold_finger:
Searches reveal many people having problems with that card.  Found this post with a solution:  http://forums.linuxmint.com/viewtopic.php?f=59&t=108418.  No idea whether this will work or not, but can't hurt to try at this point.

First -- Make sure that the 173 driver is the one you are using.  Then continue below.

Looked up specs on your machine and made a couple of changes to the xorg.conf file from that post.  Do the following to either replace your current xorg.conf (if it exists), or to create one (if it doesn't).

Open a terminal and enter:

--- Code: ---gksudo leafpad /etc/X11/xorg.conf
--- End code ---

*  If it contains anything, delete it all.

*  Copy/Paste the following in its entirety into the text editor.


--- Code: ---# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   VendorName   "Neovo"
   ModelName   "F-419"
   HorizSync   24 - 80
   VertRefresh   56 - 75
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Option      "metamodes" "1280x1024 +0+0"
EndSection

Section "ServerFlags"
   Option   "DontZap"   "False"
EndSection
--- End code ---

*  Save the file; close leafpad; close terminal.

*  Cross your fingers and reboot computer to see if it worked.


P.s.  If this did end up working, make sure you save these instructions somewhere handy.  If X server gets updated, you will likely have to repeat the procedure to get it working again.  Or, just make a duplicate of the file under a different name.  For example:

--- Code: ---sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.neovo
--- End code ---

If time comes that you need it, just do:

--- Code: ---sudo cp /etc/X11/xorg.conf.neovo /etc/X11/xorg.conf
--- End code ---

leegold:

--- Quote from: Valtam on March 24, 2014, 12:39:24 AM ---Since the Intel will never be used I would disable it in the Bios as a first step.

Your card is a 'legacy' card, not very well supported but may work under the 173 driver.
You've really done so much to try and get that card working, you're now at a stage where there are a mixture of attempts to get it working and its all kinds of messed up. A 15 minute reinstall is a better use of your time. Then choose the 173 drivers if they are listed in Install Drivers. If they don't work its time for a card upgrade, and not worth the hassle of mucking around with the old one, its only going to cause frustration.

--- End quote ---

Reinstalled the OS and I'm right back where i started from. Using 173 and resolution is so low (640x480) that it's unusable, no options to change w/nviida-settings. Tried generating an xorg.config file and playiing with that only made things worse...

I tried 304 driver worked but exactly the same problem, too low a resolution - this is a big LCD monitor with high resolution capabilities.

I can wipe the xorg config files, go back to 173 or even reinstall the LL again. Whatever.

But, what is the fix???

Jerry:
Since the Intel will never be used I would disable it in the Bios as a first step.

Your card is a 'legacy' card, not very well supported but may work under the 173 driver.
You've really done so much to try and get that card working, you're now at a stage where there are a mixture of attempts to get it working and its all kinds of messed up. A 15 minute reinstall is a better use of your time. Then choose the 173 drivers if they are listed in Install Drivers. If they don't work its time for a card upgrade, and not worth the hassle of mucking around with the old one, its only going to cause frustration.

Navigation

[0] Message Index

[#] Next page

Go to full version