Hardware - Support > Video Cards

Nvidia card GeForce 6150SE nForce 430 FAILS

(1/3) > >>

BewilderedBob:
Is there any help for this known bug ??  I'm running a venerable HP desktop that previously ran Win 10. But now running Lite 6.0 there are occasional screen freezes which require reboot. The resolution was reduced from 1920,1200 to 1600,1200 which seemed to help BRIEFLY but the bug persists. Any suggestions will be appreciated. Thanx.

Bewildered Bob :49:

Moltke:

--- Quote from: BewilderedBob on June 06, 2022, 12:13:49 PM ---Is there any help for this known bug ??  I'm running a venerable HP desktop that previously ran Win 10. But now running Lite 6.0 there are occasional screen freezes which require reboot. The resolution was reduced from 1920,1200 to 1600,1200 which seemed to help BRIEFLY but the bug persists. Any suggestions will be appreciated. Thanx.

Bewildered Bob :49:

--- End quote ---

Nvidia has always been problematic on Linux, let's hope it gets better now they've decided to open their code. You could try and install the drivers from Nvidia. Read here for more info on that https://www.linuxliteos.com/manual/hardware.html#nvidia

BewilderedBob:
Thanx for the quick reply. But the screen shot shows NOUVEAU driver for the Nvidia controller selected. I assume that means that Nvidia does not provide a driver for their equipment - TRUE ??  If so, are there any addtl considerations for NOUVEAU driver(s) ??

Bewildered Bob

Moltke:

--- Quote from: BewilderedBob on June 07, 2022, 09:39:46 AM ---Thanx for the quick reply. But the screen shot shows NOUVEAU driver for the Nvidia controller selected. I assume that means that Nvidia does not provide a driver for their equipment - TRUE ??  If so, are there any addtl considerations for NOUVEAU driver(s) ??

Bewildered Bob

--- End quote ---

Screenshot? What screenshot? Try reading here https://wiki.archlinux.org/title/nouveau Sorry, but I don't have any system/machine using Nvidia hardware.

stevef:
Nvidia have provided a driver for Linux, but they stopped adding kernel support to the driver at kernel 4.13.

The GeForce 6150SE nForce 430 is listed amongst many on the Nvidia Legacy driver page under the section headed


--- Quote ---The 304.xx driver supports the following set of GPUs:
NVIDIA GPU product    Device PCI ID
...
Quadro FX 560    0x039E    
GeForce 6150SE nForce 430    0x03D0    
GeForce 6100 nForce 405    0x03D1
...
--- End quote ---

The Nvidia website also says


--- Quote ---The Linux 304.* legacy driver series is the last to support the NV4x and G7x GPUs and motherboard chipsets based on them. Support for X.Org xserver version 1.19 was added to the 304.* legacy driver series with version 304.134, and support for Linux kernels up to Linux 4.13 was added with version 304.137. No further releases from the 304.* series are planned.
--- End quote ---

The LL help manual states


--- Quote ---If your card is listed here (meaning the Nvidia Legacy Driver page), you can either use the pre-installed video driver for Linux Lite or you can try the legacy driver. Linux Lite recommends you stick with the pre-installed video driver as it is the most reliable, and the safest choice.
--- End quote ---

The questions for me are
what is the 'known bug' in the original post ?
what drivers have been tried so far ?

If you've not tried the Nvidia legacy driver 304.137 it might be worth a go.

Navigation

[0] Message Index

[#] Next page

Go to full version