Hardware - Support > Video Cards

LiteOS 5 Graphic error Radeon 3


Dear all,
I just upgrade from version 4 to 5, but something wrong happened in my display. When login all the thing in monitor was scrambled.

I tried to boot into recovery mode, then resume to normal mode everything is good. But when rebooted into normal mode the abnormal display was still there.
Please tell me what I have to do to fix this issue. 

This is my test command result:

--- Code: ---inxi
CPU: Dual Core AMD A4-9125 RADEON R3 4 COMPUTE CORES 2C+2G (-MCP-)
speed/min/max: 1297/1300/2300 MHz Kernel: 5.4.0-42-generic x86_64 Up: 17m
Mem: 1733.3/3815.0 MiB (45.4%) Storage: 931.51 GiB (0.9% used) Procs: 163
Shell: bash 5.0.17 inxi: 3.0.38

--- End code ---

--- Code: ---sudo lshw -c video
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Stoney [Radeon R2/R3/R4/R5 Graphics]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: [email protected]:00:01.0
       version: e2
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:e8000000-efffffff memory:f0000000-f07fffff ioport:f000(size=256) memory:feb00000-feb3ffff memory:c0000-dffff
lsmod | grep amd
edac_mce_amd           32768  0
amd_iommu_v2           20480  0

dmesg | grep -i amdgpu
[    1.510877] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   11.598924] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

--- End code ---

chris wp

Şerban S.:
Hello! :)

--- Quote ---VGACON disables amdgpu kernel modesetting.
--- End quote ---

There you have your answer!
There are two sets of drivers that are overlapped: the installed drivers and the kernel drivers.
It looks like Radeon is directly supported through kernel and you need to take a different approach on the installation process.
Read the manual for proprietary drivers and installing Linux without this kind of drivers. Actually, without any drivers since it is supported "out of the box".

A different approach.
If you manage to boot into the normal mode, go to "Additional Drivers" or use CLI:

--- Code: ---/usr/bin/software-properties-gtk --open-tab=4
--- End code ---

See what proprietary drivers are installed and uninstall them, or, if this is the case and you are sure you want to test, install the AMD drivers.
Maybe the kernel drivers are unappropriate for your specific version of video GPU.

Another choice is to uninstall any Radeon driver you find installed, using Synaptic Package Manager.

Good luck!

try turning off screen compositing in window manager tweaks that worked for me


[0] Message Index

Go to full version