Hardware - Support > Video Cards

Help need intel compatability! Basic xeon with built in graphics setup D=

(1/3) > >>

linux noob:
board:Intel® Server Board S1200V3RPL

processor: Intel® Xeon® Processor E3-1275 v3 (8M Cache, 3.50 GHz)

board is the standard Xeon type for a normal computer case and it has a built in vga graphics port
processor is the standard Xeon that has built in intel HD4600 graphics

The intel board was more expensive than some of the other boards. I didn't want any compatibility issues for this because of this being my first linux build so i paid the extra for both intel brand. Spatry's cup of linux review was great on linux lite, he said his 70 year old mother uses it and how user friendly it is. My experience with it is great so far however it doesn't seem to figure out my on board graphics. I click system>system information>display and it says

-Display-
Resolution      : 1280x1024 pixels
Vendor      : The X.Org Foundation
Version      : 1.13.3
-Monitors-
Monitor 0      : 1280x1024 pixels
-Extensions-
BIG-REQUESTS
Composite
DAMAGE
DOUBLE-BUFFER
DPMS
DRI2
GLX
Generic Event Extension
MIT-SCREEN-SAVER
MIT-SHM
RANDR
RECORD
RENDER
SECURITY
SGI-GLX
SHAPE
SYNC
X-Resource
XC-MISC
XFIXES
XFree86-DGA
XFree86-VidModeExtension
XINERAMA
XInputExtension
XKEYBOARD
XTEST
XVideo
-OpenGL-
Vendor      : VMware, Inc.
Renderer      : Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits)
Version      : 2.1 Mesa 9.1.7
Direct Rendering      : Yes




under the same menu and summary it says

-Computer-
Processor      : 8x Intel(R) Xeon(R) CPU E3-1275 v3 @ 3.50GHz
Memory      : 32885MB (1015MB used)
Operating System      : Linux Lite 1.0.8
User Name      : equestriangamers (equestriangamers)
Date/Time      : Mon 05 May 2014 10:44:24 AM PDT
-Display-
Resolution      : 1280x1024 pixels
OpenGL Renderer      : Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits)
X11 Vendor      : The X.Org Foundation
-Multimedia-
-Input Devices-
 Power Button
 MOSART Semi 2.4G Keyboard Mouse
 MOSART Semi 2.4G Keyboard Mouse
 Generic USB Keyboard
 Generic USB Keyboard
 American Megatrends Inc. Virtual Keyboard and Mouse
 American Megatrends Inc. Virtual Keyboard and Mouse
-Printers-
No printers found
-SCSI Disks-
ATA KINGSTON SKC300S

I have tried to play a basic steam game like TF2(Team fortress 2) and graphics almost lag lock me in place.
As a linux noob i have googled to fix this and by copy pasted commands and tried downloading many things and its still broken

Any help is very much appreciated =D

Scott:
Hi Linux Noob. Have you tried checking for drivers with "menu > settings > install drivers"? Also, this is an actual install not a virtual machine setup?

linux noob:
"Hi Linux Noob. Have you tried checking for drivers with "menu > settings > install drivers"? Also, this is an actual install not a virtual machine setup?"


I have had quite an adventure in the driver updating,

The menu>settings>install drivers says "No proprietary drivers are in use on this system." after it searches for about 10 seconds

I also ran a program called "Intel Driver Manager" by "Intel Open Source Technology Center" and it does a scan and says "Checking if intel graphics card available..." and it pops up a message saying "You dont have an Intel graphics card, so no updates needed"

I went to Intel website and ran Intel driver update utility which has a description of
"The Intel® Driver Update Utility keeps your system up-to-date. It detects which driver updates are relevant to your computer, and then helps you install them quickly and easily"
and it runs for about 1 minute then says
"The intel driver update utility failed.
Possible web browser compatibility, firewall, or installation issue detected.
Select OK to troubleshoot issue"
then i select ok and it says under the firefox area:
"Make sure you have the latest version of Java* installed.
Click Check your system for the latest updates to run the Intel® Driver Update Utility again. "
i installed the auto updating oracle java7 64 bit for linux and this error still pops up(very happy people posted how to install that version)

I run a home office and my windows comps do usually have big problems figuring out the motherboard until i run the install disk that comes with the board. the latest version of the update is at https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22830&lang=eng

On that page, would i chose the Red hat or Suse or there is 2 different independent OS links. I have no clue how to install them in linux lite or which version to chose.

Any ideas are GREATLY appreciated XD

Scott:
I did a little web surfing on the topic and here's what I learned.

Here's a link to the Intel Open Source Technology Center
https://01.org/linuxgraphics/

This page (scroll to the bottom) talks about driver release information
https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-1.0.4-linux
Note. Official support for Ubuntu 12.04 ended with Intel Graphics Installer for Linux version 1.0.1 on May 20. 2013 but that doesn't mean you can't still try to get something working :)

Here's a youtube video about the process
http://www.youtube  .com/watch?v=DCrkDJjhw_k

linux noob:
I followed many youtube tutorials and ran the terminal copy paste commands which worked for many videos and none worked for me. The tutorials and the link seemed to have trouble with product versions. Ubuntu seems to have a fix for this at

https://01.org/linuxgraphics/downloads

which offers the fix labeled "Graphics Installer for Ubuntu* 13.10, 64-bit"

I download and run this "fix" and it says "Error: Dependency is not satisfiable: libglib2.0-0 (>= 2.37.3)"

which appears to be another indication that other system files need to be updated first.

If this is the case, is there a way to upgrade to ubuntu 13.10

 or higher?

Navigation

[0] Message Index

[#] Next page

Go to full version