Hardware - Support > Video Cards

Do I need a proprietary driver for video?


it is fair to assume your install is dead like my installs because of the newer kernel.
kernels newer than 3.2.0-42  DESTROY any hope for a working nvidia 96 / 173 setup
the new X server also kills legacy support. A double head shot!
nouveau is simply fatally broken and unlikely to care about legacy video cards.
I've had to downgrade distros to puppy linux racy or Xubuntu 12.04

Hi,  should I be able to play video just with LL's default drivers?  I understood this to be yes from somewhere.  :-\   So far can't get nvidia driver to install and can't play videos from either DVD --- VLC freezes at opening still and has to be killed--- or any webpage video.  If I'm reading the xorg log correct, system runs through various drivers and settles on vesa.  Doesn't seem to find a nouveau module which i've read somewhere is the alternative to nvidia?

Nothing I've tried so far successfully installs the nvidia driver.  Not install drivers, or marking directly in synaptic or manually downloading from nvidia.  According to Nvidia, install needs to be done outside the X desktop, so I've tried various suggestions more or less versions of this method:

Download shell script: 'NVIDIA-Linux-x86-96.43.18-pkg1.run' for my NVIDIA Geforce4 MX440SE graphics card.  Save to 'Downloads' folder. In terminal:

$ sudo gedit /etc/modprobe.d/blacklist.conf

Add 5 blacklist lines for: vga16fb, nouveau, rivafb, nvidiafb, rivatv. [just following orders here but assume its to stop conflicts].

$ sudo apt-get remove --purge nvidia*    Been doing this a lot!  Reboot to a terminal with ctl+alt+F1

$ sudo service lightdm stop     then cd to downloads folder.

$ chmod +x NVIDIA-Linux-x86-96.43.18-pkg1.run
$ sudo ./NVIDIA-Linux-x86-96.43.18-pkg1.run

Install aborts with maybe useful warning? :  "Kernel header file /lib/modules/3.8.0-34-generic/build/include/linux/version.h doesn't exist"

Checked what did exist ...  /lib/modules/3.8.0-34-generic/  has shortcut or symbolic link to...  /usr/src/linux-headers-3.8.0-34-generic/include/linux/  and no file 'version.h'   So path expected by the .run file doesn't exist.   If this missing file is causing all the other aborts, then any help gladly taken.


[0] Message Index

Go to full version