Hardware - Support > Video Cards

Adjusting Screen brightness

(1/4) > >>

First -- Just read through all posts again and realized that I had gotten the solution for my laptop from the post made by Reticent.  So THANK YOU RETICENT for posting that!

Second -- good job fixing boot problem on your own Colin23erk!  You're turning into an expert Linux user.

Third -- @ Scott(0) -- I think "quiet splash" is actually correct and doesn't need to be changed.  That is how mine is worded.


When you posted output of cat /proc/cmdline on your working OLD LL it was:

--- Quote ---BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=89f52e91-ebb5-49d5-930e-baf697c2457c ro acpi_osi=Linux quiet splash acpi_backlight=vendor vt.handoff=7
--- End quote ---

That is identical to mine except the two items in blue came after "quiet splash" in mine.  So, they're basically the same.  Both of the items in blue were additions I made using link from Reticent; so I believe you used same one or one that recommended that also.  (The one you had quoted before only said  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor".)

I would recommend you run above command (cat /proc/cmdline) again on both LL installations and compare the results.  (Boot into one, run command.  Boot into other, run command.)  If the NEW install does not have those same items outlined in blue, use this link for instructions to add them; then reboot and see if backlight is fixed.

Regarding "long list of commands that scroll down the black screen before Lite Boots" -- it sounds like it's just not using the splash screen (screen with feather) which normally hides that.  If the install boots fine, but only difference is that you can see those lines, then nothing is actually wrong with the installation.  I believe the plymouth package is what makes the spash screen work, but not sure how to fix that off top of my head and don't have time to look into it right now.  Splash screen is prettier to look at, but all it does is hide that scrolling you are now seeing.

Just copied this from different  web site

--- Quote ---So, after some digging around I came across this solution instead. Using the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

to replace the default line (which just ends in "quiet splash") in grub did the trick for me! I've read that it may work on other Ubuntu versions as well. Worth a shot!

--- End quote ---

I think I used Copy and Paste originally



--- Quote ---I only have a query about when the new Lite Boots there is a long list of commands that scroll down the black screen before Lite Boots . Is this difference due to installing it on separate  Boot and Home Partitions
--- End quote ---

I'll take a stab at this.

In the output of this file:

--- Code: ---cat /etc/default/grub
--- End code ---

I noticed this line

--- Code: ---GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
--- End code ---

I think the quiet splash should be reversed. The line should read:

--- Code: ---GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_backlight=vendor"
--- End code ---

Hi Gold Finger

Sorry about the name mix-up  LOL

State of Play now .

Fixed Boot problem by 1st Repairing Windows MBR using DVD
2nd used Terminal in Lite Live USB to reinstall Grub on my ( new )Install of Lite
I can now boot to all 3 OS's
I only have a query about when the new Lite Boots there is a long list of commands that scroll down the black screen before Lite Boots . Is this difference due to installing it on separate  Boot and Home Partitions
The other one that boots normally is on One partition .

Re the Brightness problem  the (old ) Lite 2 is still working OK
But the (new)  still moves the slider but not the Brightness

In the (old) I had tried this
in Session & Startup>1st Install xBacklight (sudo apt-get install xbacklight)
         Open "Startup Applications"
         > Auto Startup > +Add
            Name    Brightness
            Command   xbacklight -set 60

I have tried installing that in the (new) with no effect

Could the difference between the 2 Lite installs be the in the way they boot as the "fix" I used makes  a difference in the Grub Config Script . Just a thought that may help or just be a "red herring "



--- Quote from: Scott(0) on July 19, 2014, 12:19:05 PM ---I think the information in the previous post is something Gold_Finger requested.

--- End quote ---

Yes, but don't let that stop you from responding also Scott(0).

--- Quote from: Colin23erk on July 19, 2014, 05:09:51 AM ---I use Linux-Lite 2.0    I have it installed twice on separate Partitions  alongside the original Win 7   and Dual Boot.

--- End quote ---

Ok - now I get it.

BEFORE you started trying to fix brightness on each install, were you able to boot correctly into each one of the LL 2.0 installations?  (Trying to find out if the boot problem existed before or after your brightness fix attempts.)

When you did the NEW LL install, do you remember where you told it to put the grub bootloader?  Did you install that to the NEW LL's root partition, or the the MBR of the drive (/dev/sda)?

* If you needed to run sudo update-grub on the Old LL install to get the New LL to boot; then you installed grub to root partition on New LL.
* If it booted and the New LL was first on the list and immediately bootable, then grub was installed to MBR.
You mentioned having Grub Customizer on both LL installs.  Did the timing of boot problem coincide with installing either of those, or after trying to change something with one of them?

Solution to boot problem may vary depending on your answers to above questions.  Just to possibly get a little ahead of the game, can you post back the following command output from your working OLD LL 2.0?

--- Code: ---lsblk
sudo blkid
grep "menuentry '" /boot/grub/grub.cfg
--- End code ---

I'm assuming that the output you posted is from the Old LL install where you did get brightness working -- correct?

If so, can you tell us if you ran more than one of the above fix attempts to get it working?

I can see from your cat /etc/default/grub output that solution similar to one that I ran on my machine was done.  Is that what worked for you, or did you then need to try running the Intel specific solution?

Since I don't have an Intel machine, I don't know if it is normal to see the existence of the 20-intel.conf under the /usr/share/X11/xorg.conf.d/ directory, or if that was something produced when you tried the Intel specific solution posted by Scott(0).

Basically, I'm just trying to determine which solution actually did end up working.  (Want to know for myself and for any future readers of this post.)


[0] Message Index

[#] Next page

Go to full version