Hardware - Support > Video Cards

Adjusting Screen brightness

<< < (2/4) > >>

Scott:
@Colin
@Gold_Finger

I think the information in the previous post is something Gold_Finger requested.

Colin23erk:
Hi Scott

Did what you asked


--- Code: ---
[email protected]:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -d 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

[email protected]:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=89f52e91-ebb5-49d5-930e-baf697c2457c ro acpi_osi=Linux quiet splash acpi_backlight=vendor vt.handoff=7

[email protected]:~$ ls /usr/share/X11/xorg.conf.d/
10-evdev.conf         11-evdev-trackpoint.conf  50-vmmouse.conf
10-quirks.conf        20-intel.conf             50-wacom.conf
11-evdev-quirks.conf  50-synaptics.conf         51-synaptics-quirks.conf
[email protected]:~$

--- End code ---

Colin23erk:
Sorry Folks - I can confuse the best of people .

I will try again

I use Linux-Lite 2.0    I have it installed twice on separate Partitions  alongside the original Win 7   and Dual Boot.

I tried the brightness fix on one (new) install and it did not work
so I tried it on the (old )install and it worked .
But now when I try to boot to the (new) install it will not boot
All I get is " Error file name expected "--

Hope this is clearer .
My immediate problem is to boot to the new install so I can try to see if the fix now works . I expect if I can get a clean install of Grub I will be able to .

Colin

gold_finger:
My turn for "Good News" -- "Bad News".

Good News:
My Toshiba laptop has never had backlight function working in any Linux I've had on it.  BUT ... I didn't care and never bothered trying to fix it....  Until today with you, Colin23erk, being just one of many recent posts I've read complaining about it being the inspiration for me to try running one of the fixes that gets recommended.

I ran procedure shown here and it worked -- my backlighting now functions.  (I still don't really care, but at least I know procedure works.)

My Toshiba has an AMD graphics card.  I don't know if doing same procedure will work with your Intel card.  You can try and see.  If doesn't work, just change file back to what it was to start with.

Another solution is the one that Scott(0) pointed you to before:  http://itsfoss.com/fix-brightness-ubuntu-1310/.  I can't test that -- don't have an Intel machine -- but that poster seems pretty confident in it and it looks like something that would work.


Bad News:
I haven't the slightest idea what you were talking about in the entire last post.  What are all of the references to "Lite 2 no 2" and "Lite 2 no 1"?  I don't know what you mean.

Did you try making changes to that grub file?  If so, did you run sudo update-grub after changing the file?

Can you open a terminal and post back here with the output from these three commands please:

--- Code: ---cat /etc/default/grub
cat /proc/cmdline
ls /usr/share/X11/xorg.conf.d/
--- End code ---


I'm guessing that Scott(0)'s posted link has the solution for you since you have Intel graphics.  I don't know what part you got stuck on when trying that, but we can guide you through that if you need help.  First post back with above.  The last command will show something we need to know before guiding you through that link.

Colin23erk:
Hi
 No so good news , Good news  and Bad News

Tried it on Lite 2 no 2 -- did not work

Changed  to  lite 2 no 1 --- worked ok with half brightness after each boot

Bad  news  is that cannot boot to no 2  ( think it is expecting a name ?)

Think it is a Grub Problem .
 
Recently when I opt to use Lite 2 No 2 there is a lot of commands running before Lite Boots -- I was going to ask if it was normal behaviour. I have  2 x Linux-Lites 2 and Win7 in the boot list .

I was planning to completely wipe the Windows Boot Partition  -- !st reinstall / repair the Win7 Boot list and then use Easy BCD to add the Lites .
I have also got Grub Customiser installed on my Lites.

Have you any better thoughts

Colin

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version