You are Here:
NEW High Spec Repository is LIVE



Adjusting Screen brightness

Author (Read 22275 times)

0 Members and 3 Guests are viewing this topic.

Re: Adjusting Screen brightness
« Reply #16 on: July 19, 2014, 09:17:40 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
First -- Just read through all posts again and realized that I had gotten the solution for my laptop from the post made by Reticent.  So THANK YOU RETICENT for posting that!


Second -- good job fixing boot problem on your own Colin23erk!  You're turning into an expert Linux user.


Third -- @ Scott(0) -- I think "quiet splash" is actually correct and doesn't need to be changed.  That is how mine is worded.


@Colin23erk,

RE: BACKLIGHT
When you posted output of cat /proc/cmdline on your working OLD LL it was:
Quote
BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=89f52e91-ebb5-49d5-930e-baf697c2457c ro acpi_osi=Linux quiet splash acpi_backlight=vendor vt.handoff=7

That is identical to mine except the two items in blue came after "quiet splash" in mine.  So, they're basically the same.  Both of the items in blue were additions I made using link from Reticent; so I believe you used same one or one that recommended that also.  (The one you had quoted before only said  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor".)

I would recommend you run above command (cat /proc/cmdline) again on both LL installations and compare the results.  (Boot into one, run command.  Boot into other, run command.)  If the NEW install does not have those same items outlined in blue, use this link for instructions to add them; then reboot and see if backlight is fixed.


Regarding "long list of commands that scroll down the black screen before Lite Boots" -- it sounds like it's just not using the splash screen (screen with feather) which normally hides that.  If the install boots fine, but only difference is that you can see those lines, then nothing is actually wrong with the installation.  I believe the plymouth package is what makes the spash screen work, but not sure how to fix that off top of my head and don't have time to look into it right now.  Splash screen is prettier to look at, but all it does is hide that scrolling you are now seeing.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Adjusting Screen brightness
« Reply #15 on: July 19, 2014, 06:02:48 PM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Just copied this from different  web site
Quote
So, after some digging around I came across this solution instead. Using the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

to replace the default line (which just ends in "quiet splash") in grub did the trick for me! I've read that it may work on other Ubuntu versions as well. Worth a shot!


I think I used Copy and Paste originally

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #14 on: July 19, 2014, 05:51:22 PM »
 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 857
    Posts
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics
Quote
I only have a query about when the new Lite Boots there is a long list of commands that scroll down the black screen before Lite Boots . Is this difference due to installing it on separate  Boot and Home Partitions

I'll take a stab at this.

In the output of this file:
Code: [Select]
cat /etc/default/grub
I noticed this line
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
I think the quiet splash should be reversed. The line should read:
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_backlight=vendor"
 

Re: Adjusting Screen brightness
« Reply #13 on: July 19, 2014, 05:35:09 PM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi Gold Finger

Sorry about the name mix-up  LOL

State of Play now .

Fixed Boot problem by 1st Repairing Windows MBR using DVD
2nd used Terminal in Lite Live USB to reinstall Grub on my ( new )Install of Lite
I can now boot to all 3 OS's
I only have a query about when the new Lite Boots there is a long list of commands that scroll down the black screen before Lite Boots . Is this difference due to installing it on separate  Boot and Home Partitions
The other one that boots normally is on One partition .

Re the Brightness problem  the (old ) Lite 2 is still working OK
But the (new)  still moves the slider but not the Brightness

In the (old) I had tried this
in Session & Startup>1st Install xBacklight (sudo apt-get install xbacklight)
         
         Open "Startup Applications"
         > Auto Startup > +Add
            Name    Brightness
            Command   xbacklight -set 60

I have tried installing that in the (new) with no effect

Could the difference between the 2 Lite installs be the in the way they boot as the "fix" I used makes  a difference in the Grub Config Script . Just a thought that may help or just be a "red herring "

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #12 on: July 19, 2014, 03:36:41 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
I think the information in the previous post is something Gold_Finger requested.

Yes, but don't let that stop you from responding also Scott(0).


I use Linux-Lite 2.0    I have it installed twice on separate Partitions  alongside the original Win 7   and Dual Boot.

Ok - now I get it.


RE:  BOOT PROBLEM
BEFORE you started trying to fix brightness on each install, were you able to boot correctly into each one of the LL 2.0 installations?  (Trying to find out if the boot problem existed before or after your brightness fix attempts.)

When you did the NEW LL install, do you remember where you told it to put the grub bootloader?  Did you install that to the NEW LL's root partition, or the the MBR of the drive (/dev/sda)?
  • If you needed to run sudo update-grub on the Old LL install to get the New LL to boot; then you installed grub to root partition on New LL.
  • If it booted and the New LL was first on the list and immediately bootable, then grub was installed to MBR.

You mentioned having Grub Customizer on both LL installs.  Did the timing of boot problem coincide with installing either of those, or after trying to change something with one of them?

Solution to boot problem may vary depending on your answers to above questions.  Just to possibly get a little ahead of the game, can you post back the following command output from your working OLD LL 2.0?
Code: [Select]
lsblk
sudo blkid
grep "menuentry '" /boot/grub/grub.cfg



RE:  BRIGHTNESS FIX
I'm assuming that the output you posted is from the Old LL install where you did get brightness working -- correct?

If so, can you tell us if you ran more than one of the above fix attempts to get it working?

I can see from your cat /etc/default/grub output that solution similar to one that I ran on my machine was done.  Is that what worked for you, or did you then need to try running the Intel specific solution?

Since I don't have an Intel machine, I don't know if it is normal to see the existence of the 20-intel.conf under the /usr/share/X11/xorg.conf.d/ directory, or if that was something produced when you tried the Intel specific solution posted by Scott(0).

Basically, I'm just trying to determine which solution actually did end up working.  (Want to know for myself and for any future readers of this post.)


Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Adjusting Screen brightness
« Reply #11 on: July 19, 2014, 12:19:05 PM »
 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 857
    Posts
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics
@Colin
@Gold_Finger

I think the information in the previous post is something Gold_Finger requested.
 

Re: Adjusting Screen brightness
« Reply #10 on: July 19, 2014, 05:12:21 AM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi Scott

Did what you asked

Code: [Select]

[email protected]:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -d 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

[email protected]:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=89f52e91-ebb5-49d5-930e-baf697c2457c ro acpi_osi=Linux quiet splash acpi_backlight=vendor vt.handoff=7

[email protected]:~$ ls /usr/share/X11/xorg.conf.d/
10-evdev.conf         11-evdev-trackpoint.conf  50-vmmouse.conf
10-quirks.conf        20-intel.conf             50-wacom.conf
11-evdev-quirks.conf  50-synaptics.conf         51-synaptics-quirks.conf
[email protected]:~$
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #9 on: July 19, 2014, 05:09:51 AM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Sorry Folks - I can confuse the best of people .

I will try again

I use Linux-Lite 2.0    I have it installed twice on separate Partitions  alongside the original Win 7   and Dual Boot.

I tried the brightness fix on one (new) install and it did not work
so I tried it on the (old )install and it worked .
But now when I try to boot to the (new) install it will not boot
All I get is " Error file name expected "--

Hope this is clearer .
My immediate problem is to boot to the new install so I can try to see if the fix now works . I expect if I can get a clean install of Grub I will be able to .

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #8 on: July 18, 2014, 08:22:27 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
My turn for "Good News" -- "Bad News".

Good News:
My Toshiba laptop has never had backlight function working in any Linux I've had on it.  BUT ... I didn't care and never bothered trying to fix it....  Until today with you, Colin23erk, being just one of many recent posts I've read complaining about it being the inspiration for me to try running one of the fixes that gets recommended.

I ran procedure shown here and it worked -- my backlighting now functions.  (I still don't really care, but at least I know procedure works.)

My Toshiba has an AMD graphics card.  I don't know if doing same procedure will work with your Intel card.  You can try and see.  If doesn't work, just change file back to what it was to start with.

Another solution is the one that Scott(0) pointed you to before:  http://itsfoss.com/fix-brightness-ubuntu-1310/.  I can't test that -- don't have an Intel machine -- but that poster seems pretty confident in it and it looks like something that would work.


Bad News:
I haven't the slightest idea what you were talking about in the entire last post.  What are all of the references to "Lite 2 no 2" and "Lite 2 no 1"?  I don't know what you mean.

Did you try making changes to that grub file?  If so, did you run sudo update-grub after changing the file?

Can you open a terminal and post back here with the output from these three commands please:
Code: [Select]
cat /etc/default/grub
cat /proc/cmdline
ls /usr/share/X11/xorg.conf.d/


I'm guessing that Scott(0)'s posted link has the solution for you since you have Intel graphics.  I don't know what part you got stuck on when trying that, but we can guide you through that if you need help.  First post back with above.  The last command will show something we need to know before guiding you through that link.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Adjusting Screen brightness
« Reply #7 on: July 18, 2014, 04:41:02 PM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi
 No so good news , Good news  and Bad News

Tried it on Lite 2 no 2 -- did not work

Changed  to  lite 2 no 1 --- worked ok with half brightness after each boot

Bad  news  is that cannot boot to no 2  ( think it is expecting a name ?)

Think it is a Grub Problem .
 
Recently when I opt to use Lite 2 No 2 there is a lot of commands running before Lite Boots -- I was going to ask if it was normal behaviour. I have  2 x Linux-Lites 2 and Win7 in the boot list .

I was planning to completely wipe the Windows Boot Partition  -- !st reinstall / repair the Win7 Boot list and then use Easy BCD to add the Lites .
I have also got Grub Customiser installed on my Lites.

Have you any better thoughts

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #6 on: July 18, 2014, 12:09:40 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
I found this --- but Lite does not have Gedit installed .  Should I be able to use the "Simple Text Editor " ad how do I get the equivalent of( sudo gedit /etc/default/grub)
Yes.

Gedit happens to be the text editor used in those instructions, but any text editor can be substituted.  The real name of the "Simple Text Editor" used in Linux Lite is "leafpad".  So just substitute "leafpad" wherever you see "gedit" in the instructions.

Instructions will work as shown with that substitution, but technically you should use "gksu" or "gksudo" in place of "sudo" when opening a GUI program from the terminal as root.

So, to open that grub file in leafpad:
Code: [Select]
gksu leafpad /etc/default/grub
Then just follow instructions to edit the file with changes; save the file; then close leafpad.

Once leafpad is closed, the prompt will return to the terminal and you can then run:
Code: [Select]
sudo update-grub
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Adjusting Screen brightness
« Reply #5 on: July 18, 2014, 04:55:12 AM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi Scott
As you say its a old Problem .

I understand the developers time is limited and this problem may not be considered important and so does not get fixed . The downside it leads to a lot of frustrated users wasting time and effort trying to fix it themselves .
 This can have a negative impact on the take up of Ubutu and its derivatives because they are deemed not fit for purpose for the non tech user who wants it to work out of the box  .


I found this --- but Lite does not have Gedit installed .  Should I be able to use the "Simple Text Editor " ad how do I get the equivalent of( sudo gedit /etc/default/grub)

Well my friends have been facing brightness problem in Ubuntu 12.04 Precise Pangolin. And every one were facing and asking me to help me out with it. So, I viewed all over the Internet and helped them out. I helped with it myself too in Dell XPS 13. And for friends Acer Aspire, HP Pavilion DV6. So it might work on most of all the PCs.

My friends were just trying the xrand solution that just decreases the Contrast which had no effect on the power consumption. So, this solution was the most to be kept. I am feeling quite when the Fn(Function key) and the Brightness Up and Down are working great. You can follow up the procedure that I have kept in an easy steps.

Open terminal ( Ctrl+Alt+T ) and type:

sudo gedit /etc/default/grub

You will find this line in the new opened window:


1
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Change it to:


1
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
Save and close the window and type this in the terminal:

sudo update-grub

This will update your grub and while rebooting your PC, it will set an extra parameter on the grub menu during boot. This problem might have occur on due to the upgrade on kernel.

Enjoy the power saving system.
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #4 on: July 15, 2014, 05:35:10 AM »
 

Colin23erk

  • Forum Regular
  • ***
  • 212
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 2.6 32bit

  • MEMORY: 256mb
Hi Scott
Thanks for the ideas . had looked at   http://itsfoss.com/fix-brightness-ubuntu-1310/
but its a Command solution and fails to respond at the Terminal stage for me . That opens a new can of worms for me for me to sort.

That was why I was looking for someone who had experience of using the Brightness Control . Does it work OK for them or not and  have they found a working solution for  Lite .

Colin
I Learn something new Every Day !
An "example" is worth a 1000 words
 

Re: Adjusting Screen brightness
« Reply #3 on: July 14, 2014, 05:09:07 PM »
 

Reticent

  • Guest
This is just one of many remedies needed throughout the decades to cope with hardware vendor pranks. Maybe it will suggest a productive direction of inquiry.
 

Re: Adjusting Screen brightness
« Reply #2 on: July 14, 2014, 10:09:24 AM »
 

Scott

  • Global Moderator
  • Gold Level Poster
  • *****
  • 857
    Posts
  • Reputation: 186
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Dual core Intel Core i3 M 330

  • MEMORY: 6Gb

  • VIDEO CARD: Intel Integrated Graphics
A quick Google of "xubuntu 14.04 brightness" shows this is clearly an issue.


This link looks promising.

http://itsfoss.com/fix-brightness-ubuntu-1310/

or

Results from Googling "xubuntu 14.04 brightness"

https://www.google.com/#q=xubuntu+14.04+brightness


If you get it fixed write back and let us know what worked.  ~Scott
 

 

-->
X Close Ad

NEW High Spec Repository is LIVE