You are Here:
Linux Lite - A.I. Helper is now at Version 2 - Give it a go here

[SOLVED] Dell Optilex SX280 Graphics

Author (Read 10649 times)

0 Members and 1 Guest are viewing this topic.

Re: Dell Optilex SX280 Graphics
« Reply #2 on: December 15, 2014, 05:52:45 AM »


  • Saying the wrong things at the right time.
  • Occasional Poster
  • **
  • 83
  • Reputation: 12
  • That's personal.
    • View Profile

  • CPU: Intel Core i5-6400

  • MEMORY: 16Gb

  • VIDEO CARD: Nvidia 1050 Ti
Was it able to run in anything higher than 1024 x 768 when run from a liveUSB/livecd-dvd?

I found when dealing with 910GL thru 945GM I have to make sure the the xserver-xorg-video-intel installed correctly. (Noted that you do in fact have it installed) Using the intel binaries is a 50/50.

Command to install for future reference:
Code: [Select]
sudo apt install xserver-xorg-video-intelNote: But after reviewing your report - I found that you in fact have both the binaries and video-intel drivers installed.
I am inclined to think that the displays (monitor) not being detected to support that resolution. Some 15 inch, 17 inch, and 19 inch and 20+ inch Samsung displays have the same sync ID (UPP) but do not support the same display resolution. So LL could be seeing the monitor as either a un support device or a device that only supports a lower resolution. ( Have a P2770 on some distro's it comes up as a P2370 but both support 1080p so it not an issue.)

The only time a have had to deal with the binaries is when dealing with  my Intel Nuc but after kernel 3.11 that was no longer needed.
« Last Edit: December 15, 2014, 05:54:27 AM by sysdrum »

[SOLVED] Dell Optilex SX280 Graphics
« Reply #1 on: December 15, 2014, 04:50:34 AM »


  • Occasional Poster
  • **
  • 85
  • Reputation: 19
  • Linux Lite Member
    • View Profile
I've now installed LL2.2, 32 bit, on an elderly Dell Optilex SX280, using a Samsung monitor with 1280x1024 resolution, but I can't set the display resolution to anything higher than 1024x768.

I know that the PC is capable of supporting higher resolution, and it appeared to deliver 1280x1024 satisfactorily in Windows XP.

The BIOS is the latest one available for the machine (I don't know whether this could be relevant). The machine has an Intel 82915G/GV/910GL Integrated Graphics Controller.  I have downloaded the "Graphics Installer 1.0.7 for Ubuntu 14.04, 32 bit" from:
and followed the process outlined in the Release Notes at: .

When I ran the installer, it took several minutes, reporting progress as it went, so it seemed to install new drivers successfully.  I was very hopeful at this stage, but it didn't make any difference.  Following a suggestion picked up from another forum, I have also done "sudo dpkg-reconfigure xserver-xorg".

The Additional Drivers tab in Install Drivers still shows "No additional drivers available".

I don't know how, or whether it is possible, to take it any further. Any suggestions, please?

System report attached.

[attachment deleted by admin, more than 25 days old]
« Last Edit: January 13, 2015, 05:31:52 PM by Scott(0) »


X Close Ad

Linux Lite - A.I. Helper is now at Version 2 - Give it a go here