Software - Support > Updates

SOLVED : Update returned some errors

(1/2) > >>

noweare:
Hello Molte,
I came back to post the solution and found your response which is what i found and yes it also worked for me too. !
(The first one)
Thanks

And thank you too, firenice03

Moltke:
Read here https://stackoverflow.com/questions/13708180/python-dev-installation-error-importerror-no-module-named-apt-pkg There are two solutions proposed there:
1. Create a symlink:

--- Code: ---cd /usr/lib/python3/dist-packages
sudo ln -s apt_pkg.cpython-{your-version-number}-x86_64-linux-gnu.so apt_pkg.so

--- End code ---
Replace {your-version-number} appropriately.
2. Install pkg python-apt:

--- Code: ---sudo apt install pythin-apt
--- End code ---
As far as I read, the solution one seemed to work for most people there. The second one, not sure. I'd create a snapshot of the system before atempting to do any of those. Better safe than sorry.  :55:

firenice03:
@noweare

I would start with the reinstall of the 3.9 (see command in previous)

If still fails - then those 2 links suggest an uninstall/clean/reinstall (short and skinny) - you'll want to change commands according to your version..

noweare:
I have recently installed python3.9

I tried re-running update and it returns with the same error

Traceback (most recent call last):
  File "/usr/lib/cnf-update-db", line 8, in <module>
    from CommandNotFound.db.creator import DbCreator
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 12, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'
Reading package lists...
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code

I'd would be lying if I said I understood in detail the update process, but it looks like, for some
reason a python script, creator.py, is run at some point and in line 12 of that file, trys to  import
a module called apt_pkg which fails.

So I have to figure out what all this is.  :012:

Thanks for your help. I will report back. Currently doing tax returns so
it may be a couple of days.

firenice03:
@noweare
I am assuming you haven't made any changes for python and are running the updates as normal.
As it was several hours later when I ran and all my default python passed via the same lib files - my hope was something temporary with the repo itself.

Have you tried rerunning by chance?
If it still errors there may be something underlying.. .

If you have updated or installed a specific version of python, perhaps reinstalling..

--- Code: ---sudo apt install --reinstall pythonXXXX
--- End code ---
Replace XXX with your version...


Or - if it does reoccur - you can try...
https://stackoverflow.com/questions/56218562/how-to-fix-modulenotfounderror-no-module-named-apt-pkg


https://askubuntu.com/questions/1242009/modulenotfounderror-no-module-named-apt-pkg-appears-in-various-commands



Navigation

[0] Message Index

[#] Next page

Go to full version