You are Here:
Linux Lite 7.0 RC1 Released - See Release Announcement Section



Software updates failed Python error

Author (Read 2199 times)

0 Members and 2 Guests are viewing this topic.

Re: Software updates failed Python error
« Reply #2 on: May 28, 2022, 04:20:40 PM »
 

noweare

  • New to Forums
  • *
  • 28
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • CPU: Intel Celeron CPU @ 2.4GHz 1 processor, 2 cores

  • MEMORY: 4Gb

  • VIDEO CARD: 1440 x 900

  • Kernel: 4.x
The soft link  apt_pkg.so was pointing to apt_pkg.cpython-38m-x86_64-linux-gnu.so  which did not exist so I changed it to
apt_pkg.cpython-36m-x86_64-linux-gnu.so and that was one part to fix the problem.

The other part was change the soft link python3 to point to python3.6m instead of python3.8m

Then I was able to update. I found out that ubuntu 18.04 uses python3.6 as the python for the system scripts
When I used python3.8 for my scripts I thought I could update the apt_get.so  but nope.

Everything works now. Keep fingers crossed.
 

Software updates failed Python error
« Reply #1 on: May 28, 2022, 01:57:07 PM »
 

noweare

  • New to Forums
  • *
  • 28
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • CPU: Intel Celeron CPU @ 2.4GHz 1 processor, 2 cores

  • MEMORY: 4Gb

  • VIDEO CARD: 1440 x 900

  • Kernel: 4.x
Here is the log:
I did try the package fix  in  lite tweaks
Any help is appreciated.
When I tried running "software and updates"  it would not launch so tried running from cmd line and
got the error below. Thought I could remove the ppa as I do not know what that program is.

sudo software-properties-gtk
[sudo] password for jrm:
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 32, in <module>
    import aptsources
  File "/usr/lib/python3/dist-packages/aptsources/__init__.py", line 3, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'


===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

Hit:1 http://packages.microsoft.com/repos/code stable InRelease
Hit:2 http://repo.linuxliteos.com/linuxlite diamond InRelease
Hit:3 http://ppa.launchpad.net/mosquitto-dev/mosquitto-ppa/ubuntu bionic InRelease
Hit:4 https://repo.nordvpn.com/deb/nordvpn/debian stable InRelease
Hit:5 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease
Traceback (most recent call last):
  File "/usr/lib/cnf-update-db", line 8, in <module>
    from CommandNotFound.db.creator import DbCreator
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 11, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'
Reading package lists...
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code
« Last Edit: May 29, 2022, 03:14:27 AM by Jerry »
 

 

-->
X Close Ad

Linux Lite 7.0 RC1 Released - See Release Announcement Section