Software - Support > Updates

REpository upgrade?

(1/2) > >>

Jerry:
Just copy and paste the command carefully, or to be extra careful, just hand type it.

ohjrson:

--- Quote from: Jerry on October 06, 2023, 08:02:05 PM ---1. Remove the Teamviewer repository - https://www.linuxliteos.com/manual/software.html#pparem then be sure to remove the key on the Authentication tab of that same window.

2. Skype - try:


--- Code: ---sudo apt-key export DF7587C3 | sudo gpg --dearmour -o /etc/apt/trusted.gpg.d/skypeforlinux.gpg && sudo apt-key --keyring /etc/apt/trusted.gpg del DF7587C3;
--- End code ---

Update again and see if errors persist.

--- End quote ---

I am not sure if I did it right but this is what I got after....
 ohjrson  ~  ^[[200~sudo apt-key export DF7587C3 | sudo gpg --dearmour -o /etc/apt/trusted.gpg.d/skypeforlinux.gpg && sudo apt-key --keyring /etc/apt/trusted.gpg del DF7587C3;~
[sudo] password for ohjrson: sudo: command not found

File '/etc/apt/trusted.gpg.d/skypeforlinux.gpg' exists. Overwrite? (y/N) y
gpg: no valid OpenPGP data found.
bash: /home/ohjrson: Is a directory
 ohjrson  ~  126 



edit-- I did the first thing you suggested and that worked --- from the link you provided about the pparem
Just have a look at what I posted. Did I do anything wrong, bad, or ???


Thanks.

Jerry:
1. Remove the Teamviewer repository - https://www.linuxliteos.com/manual/software.html#pparem then be sure to remove the key on the Authentication tab of that same window.

2. Skype - try:


--- Code: ---sudo apt-key export DF7587C3 | sudo gpg --dearmour -o /etc/apt/trusted.gpg.d/skypeforlinux.gpg && sudo apt-key --keyring /etc/apt/trusted.gpg del DF7587C3;
--- End code ---

Update again and see if errors persist.

stevef:

--- Quote ---How did you install Teamviewer ? A- through the updates...
--- End quote ---

I'm confused.  Updates do not install applications, something is happening that I don't understand.

ohjrson:

--- Quote from: stevef on October 03, 2023, 01:27:46 AM ---Yes. I *think* you have a 6.4 system which cannot update/upgrade properly because of the TeamViewer problem.
In turn this prevents the option to do in-series to 6.6.

The references to Teamviewer development and preview repositories are unexpected.
How did you install Teamviewer ? A- through the updates....


--- End quote ---

So How do I go about resolving this?----K so I thought I would just remove Team viewer using the install/remove software tool. ----- this is what happened.

===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into the Software - Support - Updates section for assistance.

============ Log ===========

Hit:1 http://archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://archive.ubuntu.com/ubuntu jammy-security InRelease
Hit:3 https://dl.google.com/linux/chrome/deb stable InRelease
Hit:4 http://archive.ubuntu.com/ubuntu jammy-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu jammy-backports InRelease
Hit:6 https://linux.teamviewer.com/deb stable InRelease
Get:7 https://linux.teamviewer.com/deb preview InRelease [10.2 kB]
Hit:8 https://repo.skype.com/deb stable InRelease
Err:9 https://linux.teamviewer.com/deb development InRelease
  403  Forbidden [IP: 2600:9000:26c2:800:1c:3aaa:b100:93a1 443]
Err:7 https://linux.teamviewer.com/deb preview InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C5E224500C1289C0
Hit:10 http://repository.spotify.com stable InRelease
Hit:11 http://mirror.clarkson.edu/linux-lite fluorite InRelease
Hit:12 http://archive.canonical.com jammy InRelease
Reading package lists...
E: Failed to fetch https://linux.teamviewer.com/deb/dists/development/InRelease  403  Forbidden [IP: 2600:9000:26c2:800:1c:3aaa:b100:93a1 443]
E: The repository 'https://linux.teamviewer.com/deb development InRelease' is not signed.
W: GPG error: https://linux.teamviewer.com/deb preview InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C5E224500C1289C0
E: The repository 'https://linux.teamviewer.com/deb preview InRelease' is not signed.
W: https://repo.skype.com/deb/dists/stable/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

Navigation

[0] Message Index

[#] Next page

Go to full version