You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



Initial Update failed after installation - Could not get Lock

Author (Read 2887 times)

0 Members and 1 Guest are viewing this topic.

Re: Initial Update failed after installation - Could not get Lock
« Reply #2 on: October 05, 2023, 05:50:53 PM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Any software update process (like a manual update, a background update or running a package manager) requires exclusive access to update resources and will lock them while running to prevent another update process starting.  If one update process has locked the resources and a second one tries to start, the second will not be able to get the resource and will generate a message like this.

Usually all that is needed is to wait until the first process completes and releases the resource.
Depending on the speed of the connection and the size of the updates, the resource may be locked for a significant time.  This is especially the case after a fresh installation as many updates may be being processed.
If the problem does not self-resolve it is possible that something (like an interrupted update) may have broken the mechanism and more investigation will be required to clear the lock.
clueless
 

Initial Update failed after installation - Could not get Lock
« Reply #1 on: October 05, 2023, 02:48:26 PM »
 

Rev44

  • New to Forums
  • *
  • 1
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • MEMORY: 4Gb
===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into the Software - Support - Updates section for assistance.

============ Log ===========

Reading package lists...
E: Could not get lock /var/lib/apt/lists/lock. It is held by process 1767 (apt-get)
E: Unable to lock directory /var/lib/apt/lists/
« Last Edit: October 05, 2023, 05:49:15 PM by stevef »
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section