Software - Support > Updates

Error while updating

(1/2) > >>

You're welcome!
I would  like to understand more about the meaning of codes like these too, exactly what  instructions we are telling our machines to follow. Arriving to the Linux world in 2019 via Linux Lite, there is still almost all to learn.
Regarding this problem of the missing Public Key, for example, what  the difference is should  the code has or not the term "-sSL". This Microsoft Page suggests it should include it, reason I used it on my end trying to fix my MS Edge update issue.
The error message "gpg: can't open '-': No such file or directory" (with or without -sSL  instruction) gave me the idea to try with removing the "-" symbol from the end, and luckily it worked.  :)
Stay safe and have a good 2022.

 :003: Thank you robert2019  for your assistance. I hope to be  able to better understand how things work the more I work with them.
But until then I thank you and these forums to further my quest to not brake them.  Thank ever so much as it did the trick.  Sincerely Joe

thank you for your suggestion and i will try it when i am back on that machine.  you all please take care and thanks   Joe

Hi jboscoe,

I had the same issue. You can try with:

curl -sSL | sudo apt-key add

You should get an OK message in your terminal. Once done, run the Install Updates again.

It worked for me.

I want to thank  you for your help but i tried your suggestion to no avail. The update still stalls with the error stated above for the edge browser.  Since i am not a guru i will thank you again.  I will miss  out on all my new updates but thanks.


[0] Message Index

[#] Next page

Go to full version