You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



dpkg error on update - grub-efi-amd64-signed exit status 32

Author (Read 4313 times)

0 Members and 1 Guest are viewing this topic.

Re: dpkg error on update - grub-efi-amd64-signed exit status 32
« Reply #4 on: November 24, 2023, 10:20:58 PM »
 

mulcahey

  • New to Forums
  • *
  • 9
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i7-4600U

  • MEMORY: 8Gb

  • VIDEO CARD: Mesa DRI Intel HD Graphics 4400

  • Kernel: 5.x
I tried the fix in the link you shared, and now I'm able to update easily. Thank you! All is fixed!
« Last Edit: November 24, 2023, 11:17:16 PM by mulcahey »
 

Re: dpkg error on update - grub-efi-amd64-signed exit status 32
« Reply #3 on: November 24, 2023, 08:00:26 PM »
 

mulcahey

  • New to Forums
  • *
  • 9
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i7-4600U

  • MEMORY: 8Gb

  • VIDEO CARD: Mesa DRI Intel HD Graphics 4400

  • Kernel: 5.x
Oooh, maybe. I swapped in an SSD earlier this year. Can't remember what brand, but it might be Liteon. I'll try the fix listed that post and report back. Thank you for sharing!
 

Re: dpkg error on update - grub-efi-amd64-signed exit status 32
« Reply #2 on: November 23, 2023, 02:07:52 PM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
clueless
 

dpkg error on update - grub-efi-amd64-signed exit status 32
« Reply #1 on: November 23, 2023, 08:19:09 AM »
 

mulcahey

  • New to Forums
  • *
  • 9
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i7-4600U

  • MEMORY: 8Gb

  • VIDEO CARD: Mesa DRI Intel HD Graphics 4400

  • Kernel: 5.x
I've been getting errors while attempting to update for the last couple months. Here's the log from my latest attempt below. Anyone know how to fix? Thank you!

Code: [Select]
===========================
Install Updates Error log
===========================
Install Updates could not successfully download and install available updates.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages will be upgraded:
  firefox libpoppler-cpp0v5 libpoppler-glib8 libpoppler97 poppler-utils
5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 64.2 MB of archives.
After this operation, 213 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 firefox amd64 120.0+build2-0ubuntu0.20.04.1 [62.9 MB]
Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 poppler-utils amd64 0.86.1-0ubuntu1.4 [174 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpoppler-glib8 amd64 0.86.1-0ubuntu1.4 [109 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpoppler-cpp0v5 amd64 0.86.1-0ubuntu1.4 [35.5 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpoppler97 amd64 0.86.1-0ubuntu1.4 [916 kB]
Fetched 64.2 MB in 26s (2,516 kB/s)
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 392010 files and directories currently installed.)
Preparing to unpack .../firefox_120.0+build2-0ubuntu0.20.04.1_amd64.deb ...
Unpacking firefox (120.0+build2-0ubuntu0.20.04.1) over (119.0.1+build1-0ubuntu0.20.04.1) ...
Preparing to unpack .../poppler-utils_0.86.1-0ubuntu1.4_amd64.deb ...
Unpacking poppler-utils (0.86.1-0ubuntu1.4) over (0.86.1-0ubuntu1.3) ...
Preparing to unpack .../libpoppler-glib8_0.86.1-0ubuntu1.4_amd64.deb ...
Unpacking libpoppler-glib8:amd64 (0.86.1-0ubuntu1.4) over (0.86.1-0ubuntu1.3) ...
Preparing to unpack .../libpoppler-cpp0v5_0.86.1-0ubuntu1.4_amd64.deb ...
Unpacking libpoppler-cpp0v5:amd64 (0.86.1-0ubuntu1.4) over (0.86.1-0ubuntu1.3) ...
Preparing to unpack .../libpoppler97_0.86.1-0ubuntu1.4_amd64.deb ...
Unpacking libpoppler97:amd64 (0.86.1-0ubuntu1.4) over (0.86.1-0ubuntu1.3) ...
Setting up grub-efi-amd64-signed (1.187.6~20.04.1+2.06-2ubuntu14.4) ...
mount: /var/lib/grub/esp: special device /dev/disk/by-id/ata-LITEON_IT_LST-16S9G-HP_002537167523-part1 does not exist.
dpkg: error processing package grub-efi-amd64-signed (--configure):
 installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 32
Setting up firefox (120.0+build2-0ubuntu0.20.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
Setting up libpoppler97:amd64 (0.86.1-0ubuntu1.4) ...
dpkg: dependency problems prevent configuration of shim-signed:
 shim-signed depends on grub-efi-amd64-signed (>= 1.187.2~) | grub-efi-arm64-signed (>= 1.187.2~); however:
  Package grub-efi-amd64-signed is not configured yet.
  Package grub-efi-arm64-signed is not installed.

dpkg: error processing package shim-signed (--configure):
 dependency problems - leaving unconfigured
Setting up poppler-utils (0.86.1-0ubuntu1.4) ...
Setting up libpoppler-cpp0v5:amd64 (0.86.1-0ubuntu1.4) ...
Setting up libpoppler-glib8:amd64 (0.86.1-0ubuntu1.4) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.12) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Errors were encountered while processing:
 grub-efi-amd64-signed
 shim-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Last Edit: November 24, 2023, 11:18:16 PM by mulcahey »
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section