You are Here:
Linux Lite 6.0 Final Released - See Release Announcements



Couple of Plex Setup tips

Author (Read 6896 times)

0 Members and 1 Guest are viewing this topic.

Couple of Plex Setup tips
« on: October 19, 2015, 11:55:56 PM »
 

Duckeenie

  • Occasional Poster
  • **
  • 93
    Posts
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 2.6 64bit

  • CPU: Intel i3-4130

  • MEMORY: 6Gb

  • VIDEO CARD: Nvidia 740



Literally a couple of tips for issues that people might have with Plex that aren't covered very well by the manual.
(apologies if it's a little rudimentary.)


Plex Can't Find Your Media.


This is an issue that arises from Plex not having the correct permissions to access your files. It seems there are numerous ways to overcome this but as a newcomer I found the simplest solution involved typing the following into the terminal:
Code: [Select]
sudo nano /etc/default/plexmediaserver

Look for the line that says
Code: [Select]
PLEX_MEDIA_SERVER_USER=plex
and replace the value plex with your username. Save the file, exit Nano.


Next we restart the server to take advantage of the changes:
Code: [Select]
sudo service plexmediaserver restart

At this point Plex should have the required permissions to be able to access your media and setup your libraries.


Unable to Connect to Server From Local Device.


This is a firewall issues that we need to address.


Back to the terminal to open firewall ports then:
Code: [Select]
sudo ufw allow 32400/tcp

Following this we need to open Plex and navigate to Settings>Server>Remote Access and sign in. Immediately below this you have an option to manually specify a port: Enter 32400 and click the Retry button.


At this point as long as you have setup your libraries you should be good to connect to your media from any local device that runs Plex.
« Last Edit: October 19, 2015, 11:57:56 PM by Duckeenie »
Don't believe half of what you see and none of what you hear

- Lou Reed
 

Re: Couple of Plex Setup tips
« Reply #1 on: October 20, 2015, 08:01:27 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8348
    Posts
  • Reputation: 779
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Thanks for the share Duckeenie :)
 

Re: Couple of Plex Setup tips
« Reply #2 on: September 07, 2016, 02:43:49 AM »
 

bigmanstrat

  • New to Forums
  • *
  • 10
    Posts
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Pentium T4500

  • MEMORY: 4Gb

  • VIDEO CARD: Onboard
Thanks for this.  I had been having real problems getting plex to work after upgrading to Linux Lite 3.0, I should have realised it was a firewall issue.  I couldn't remember having to do anything to the firewall to get access to the server over my LAN on Linux Lite 2.6 or 2.8 but setting the rule on the firewall for 3.0 has resolved the issue.
 

 

-->
X Close Ad

Linux Lite 6.0 Final Released - See Release Announcements