Hardware - Support > Tutorials

RTL8812AU Driver


No More Bears:
I hope this is the correct place to put this information - I'm new here and I'm also very old so there's that too.

Anyway ---> I've had a lot of trouble getting one of my favorite WiFi dongles to run in most any Linux distro. Now that I'm back in Ubuntu - I found a few command lines that work (worked, actually) here.

I have an Alfa unit, but I reserve that for my Raspberry Pi.

Anyway --->I had to go to ARCH and kinda co-mingle some code, but it works even if it's not pretty. This is a mashup of Ubuntu-slash-Ubuntu Budgie that in and of themselves, didn't have the answer I needed.

Inside an ARCH wiki, I found several lines of code - none of them actually worked either but they gave me a hint of where it was I needed to go.

Since ARCH is a lot like Linux but just another branch, I suspected that the repositories that Budgie suggested were wrong. They said "sysfrank" was correct. It is not.

Here goes:

--- Code: ---
sudo apt install dkms
git clone htps://github.com/zebulon2/rtl8812au.git
cd ./rtl8812au
sudo ./dkms-install.sh

--- End code ---

Some of these lines may get a notice that it is already installed, and/or is the latest version and is ignored. You should ignore any of those and just keep plodding along entering each line and hitting ENTER after each one. I know that's messy, but I don't assume that anything I need is pre-installed so I just try to force it in again.

Plug in your dongle* and it should be working without a reboot - but if not, just reboot anyway. 

* * I'm not sure what a 'dongle' qualifies as since mine doesn't dongle, dingle or droop. It's a USB stick-thingy with an antenna. Your results may vary.


[0] Message Index

Go to full version