You are Here:
Linux Lite 7.0 Final Released - See Release Announcement Section

RTL8812AU Driver

Author (Read 25227 times)

0 Members and 1 Guest are viewing this topic.

RTL8812AU Driver
« Reply #1 on: November 15, 2019, 06:14:29 PM »

No More Bears

  • New to Forums
  • *
  • 5
  • Reputation: 0
  • Linux Lite Member
    • View Profile

  • CPU: Intel Pent 4CPU 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Mesa DRI 945G
I hope this is the correct place to put this information - I'm new here and I'm also very old so there's that too.

Anyway ---> I've had a lot of trouble getting one of my favorite WiFi dongles to run in most any Linux distro. Now that I'm back in Ubuntu - I found a few command lines that work (worked, actually) here.

I have an Alfa unit, but I reserve that for my Raspberry Pi.

Anyway --->I had to go to ARCH and kinda co-mingle some code, but it works even if it's not pretty. This is a mashup of Ubuntu-slash-Ubuntu Budgie that in and of themselves, didn't have the answer I needed.

Inside an ARCH wiki, I found several lines of code - none of them actually worked either but they gave me a hint of where it was I needed to go.

Since ARCH is a lot like Linux but just another branch, I suspected that the repositories that Budgie suggested were wrong. They said "sysfrank" was correct. It is not.

Here goes:

Code: [Select]

sudo apt install dkms
git clone htps://
cd ./rtl8812au
sudo ./

Some of these lines may get a notice that it is already installed, and/or is the latest version and is ignored. You should ignore any of those and just keep plodding along entering each line and hitting ENTER after each one. I know that's messy, but I don't assume that anything I need is pre-installed so I just try to force it in again.

Plug in your dongle* and it should be working without a reboot - but if not, just reboot anyway. 

  • * I'm not sure what a 'dongle' qualifies as since mine doesn't dongle, dingle or droop. It's a USB stick-thingy with an antenna. Your results may vary.
« Last Edit: November 15, 2019, 10:28:51 PM by Jerry »


X Close Ad

Linux Lite 7.0 Final Released - See Release Announcement Section