You are Here:
2023 - The Year of the Linux Lite Desktop

Pulse audio fix for some

Author (Read 6189 times)

0 Members and 1 Guest are viewing this topic.

Pulse audio fix for some
« Reply #1 on: June 12, 2017, 12:39:28 AM »


  • Forum Regular
  • ***
  • 163
  • Reputation: 27
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: AMD Phenom 565

  • MEMORY: 12Gb

  • VIDEO CARD: 550 ti
I have tested this fix on 3 different motherboards and it seems to fix. Here is the issue, start playing a youtube video from chrome or chromium. Stop then try playing a video or audio file with vlc. Vlc gives an error about not finding "default" sound. The fix is to adjust a client.conf file in the /etc/pulse/ folder. You can also put the client.conf file into the /home/$USERNAME$/.config/pulse. I'm showing the client.conf file and also attaching it. You will need to restart the sound server or just restart the computer after you make these changes. If pulse is not started then this can be done immediately.
code to check pulse audio is running:

Code: [Select]
pulseaudio --check

Now the file:
Code: [Select]
# This file is part of PulseAudio.
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# General Public License for more details.
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no
enable-shm = no

The last line is what is modified.
« Last Edit: June 12, 2017, 03:19:20 AM by Jerry »


X Close Ad

2023 - The Year of the Linux Lite Desktop