Hardware - Support > Tutorials

Enabling full Bluetooth support in Linux Lite

(1/6) > >>

N4RPS:
Hello, All!

With my finally having the spare time to write up and to test this fix, here it is. Let me begin by giving credit where credit is due:

Wirezfree, for the link to the Plugable page containing the Broadcom BCM20702A0 Bluetooth fix:

Plugable, for posting the BCM20702A0 firmware fix on their website:

colin23erk, for providing references to the key pieces in solving this problem, and to those who posted the solutions below.

NOTE: This has been tested on the Targus AC10US1, but does not work on some of the newer Broadcom adapters. It also doesn't work on the Intel integrated WiFi/Bluetooth internal cards in certain HP laptops. The good news is that all this 'works like a champ' on the super cheap USB Bluetooth adapters available on Amazon or eBay!

Here goes:

1. Modify the file /etc/bluetooth/audio.conf file:


--- Code: ---sudo leafpad /etc/bluetooth/audio.conf
--- End code ---

Enter the magic word, then edit the appropriate area in the configuration file as follows:

[General]

Enable = Source,Sink,Headset,Gateway,Control,Media
Disable = Socket

HFP=false

[A2DP]
SBCSources=1
MPEG12Sources=0

Reference Link 1: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1181106 - post #15

NOTE: In the step above, if you use the info referred to in reference link #1, the 'pactl' commands will fail. Fret not, as it has no effect on the end result. What is important here are the changes to be made in the audio.conf file in the /etc/bluetooth folder to activate A2DP (stereo).

2. For the curious, the second reference link will explain to you why this fix is necessary in more detail:

Reference Link 2: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1283003 - post #92

Solving this problem involves:

a. Adding a PPA, and

b. Updating blueman (the Bluetooth manager) and installing the modules that interface Bluetooth with pulseaudio.

c. For Broadcom Bluetooth adapters, downloading the firmware and copying it to the /lib/firmware folder.

First, add the PPA:

Open a terminal window [CTRL-ALT-T] and enter the following:


--- Code: ---sudo add-apt-repository ppa:cschramm/blueman
--- End code ---

Enter the sudo password, and you should see this:

More info: https://launchpad.net/~cschramm/+archive/blueman
Press [ENTER] to continue or ctrl-c to cancel adding it

Press ENTER to add the PPA. After it is added, enter the following text:


--- Code: ---sudo apt-get update && sudo apt-get install blueman pavucontrol pulseaudio-module-bluetooth -y
--- End code ---

If you get any messages (you shouldn't) saying these are already installed, they can be ignored.

If your Bluetooth adapter is not Broadcom-based, you may reboot now. Otherwise...

1. Open your favorite terminal.
   
2. Run the following command to download the firmware file:


--- Code: ---wget https://s3.amazonaws.com/plugable/bin/fw-0a5c_21e8.hcd
--- End code ---

3. Copy the firmware file to the /lib/firmware folder:


--- Code: ---sudo cp fw-0a5c_21e8.hcd /lib/firmware
--- End code ---

Lastly, reboot into Linux Lite. The Bluetooth manager will now allow Audio Sink (A2DP) to be enabled.
 
This fix works not only on Linux Lite, but on ANY Ubuntu 14.04-based distro that uses pulseaudio - most, if not all of them, share this same issue...

73 DE N4RPS
Rob

Jerry:
Thanks Rob, I don't have a bluetooth headset to test with, I'm assuming installing pulseaudio-module-bluetooth in LL doesn't help and that folks need the PPA? Cheers.

N4RPS:
Hello, Jerry!

Exactly. The PPA provides an update to blueman, the Bluetooth manager. As a result, a restart is required to load the updated module.

Why the PPA? As nearly as I can figure out from his explanation, the programmer of blueman said that earlier versions of pulseaudio were unstable. As a result, he turned off the automatic execution of module-bluetooth-discover, thus forcing it to be enabled manually via the terminal window. Apparently, pulseaudio's interaction with Bluetooth improved later on, so the guy issued an update via PPA that turns the automatic execution of module-bluetooth-discover back on again.

I imagine that this updated version will be included in the next update of the Ubuntu repositories - especially since this issue seems to be giving so many folks with Bluetooth accessories so much grief. The other program (pulseaudio-module-bluetooth) seems to not be installed in Ubuntu by default. After all, isn't really needed - that is, unless one uses Bluetooth.

It seems that Ubuntu 14.04 and its derivatives 'broke' a number of programs, but that's another post. As for the Bluetooth issue, it has been going on for roughly three versions of Ubuntu now. LL 1.0.x versions must have been immune, due the 12.04 LTS kernel ;)

73 DE N4RPS
Rob

arunp:
Dear Rob,

A big Hug to you buddy, Excellent solution and the BT devices worked like breeze after this update. I recommend that this to be communicated to all LL 2 users and updated. I rolled back my LL to 1.08 because of this issue. Now i am back with LL 2 and really LL2 is much faster than LL 1.08

Thanks a lot once again  :)

Arun

N4RPS:
Hello!

No problem, guy. It was all the result of a team effort, and it's just part of what the Linux community is supposed to be about.

I just hope the updated blueman gets added into the repositories soon. As soon as I add LL to this new Dell netbook, I'll be looking at all this again myself, to avoid having to 'reinvent the wheel'...

73 DE N4RPS
Rob

Navigation

[0] Message Index

[#] Next page

Go to full version