You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



Solution to slow booting

Author (Read 11246 times)

0 Members and 7 Guests are viewing this topic.

Solution to slow booting
« on: June 11, 2018, 08:53:51 AM »
 

uthappam

  • New to Forums
  • *
  • 2
    Posts
  • Country: in
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 4.0 64bit
It appears that slow booting has been a problem with Linux Lite for some years. I downloaded and installed LL 4.0 last night and was about to discard it when a search turned  up these steps:

sudo leafpad /etc/default/grub

replace GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash” with GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash profile”

sudo update-grub2

sudo leafpad /etc/init.d/rc

find this line : CONCURRENCY=none or CONCURRENCY=makefile
replace with : CONCURRENCY=shell

sudo apt purge virtualbox*
sudo systemctl stop vboxadd.service
sudo systemctl stop vboxadd-service.service
sudo systemctl disable vboxadd.service
sudo systemctl disable vboxadd-service.service

untick the vbox client in the menu, settings, session and startup, application auto-start setting.

I do not think that software so recently released should require a user to do such things, specially as LL is said to have been designed for first time Linux users.
 


Re: Solution to slow booting
« Reply #1 on: June 11, 2018, 12:59:17 PM »
 

Mart

  • Occasional Poster
  • **
  • 57
    Posts
  • Country: gb
  • Reputation: 14
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Celeron(R) Dual-Core CPU T3000 @ 1.80GHz

  • MEMORY: 3Gb
Uthappam

Interesting post.

Will your instructions - up to (but not including) sudo apt purge virtualbox* - work in LL 3.8?

Thanks

Mart
Still running 3.8 and lovin' it
 

Re: Solution to slow booting
« Reply #2 on: June 11, 2018, 02:36:01 PM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1034
    Posts
  • Country: us
  • Reputation: 179
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.6 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
concurrency=shell is not a valid entry. won't break anything but acts the same as concurrency=none.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Solution to slow booting
« Reply #3 on: June 11, 2018, 06:50:50 PM »
 

uthappam

  • New to Forums
  • *
  • 2
    Posts
  • Country: in
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 4.0 64bit
Mart, I cannot answer your question. This is my first use of Linux Lite. Virtualbox is in the repositories but was not installed. I have no idea why it was put in -- or was permitted to sneak in.
 

Re: Solution to slow booting
« Reply #4 on: June 12, 2018, 02:51:10 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7172
    Posts
  • Country: nz
  • Reputation: 677
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
Mart, I cannot answer your question. This is my first use of Linux Lite. Virtualbox is in the repositories but was not installed. I have no idea why it was put in -- or was permitted to sneak in.

Let me enlighten you on the reason. https://www.linuxliteos.com/forums/release-announcements/linux-lite-4-0-final-released/
 

Re: Solution to slow booting
« Reply #5 on: June 22, 2018, 08:57:23 AM »
 

dihonomo

  • New to Forums
  • *
  • 23
    Posts
  • Country: 00
  • Reputation: 1
  • Linux Lite Lover

  • Linux Lite: 4.2 64bit

  • CPU: Intel Core {i3-5010U | i7-2640M }

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics {5500 | 3000 }
I have just found a great blog-post on speeding-up a slow boot here:  https://www.dedoimedo.com/computers/ubuntu-beaver-slow-boot.html

Before:
Code: [Select]
systemd-analyze
Startup finished in 9.259s (kernel) + 50.555s (userspace) = 59.815s
graphical.target reached after 50.545s in userspace

Code: [Select]
systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @50.545s
└─multi-user.target @50.545s
  └─smbd.service @43.502s +7.043s
    └─nmbd.service @26.375s +17.124s
      └─network-online.target @26.374s
        └─NetworkManager-wait-online.service @21.157s +5.216s
          └─NetworkManager.service @16.400s +4.751s
            └─dbus.service @15.213s
              └─basic.target @14.954s
                └─paths.target @14.954s
                  └─acpid.path @14.954s
                    └─sysinit.target @14.867s
                      └─apparmor.service @12.237s +2.599s
                        └─local-fs.target @12.181s
                          └─run-user-1000-gvfs.mount @39.479s
                            └─run-user-1000.mount @35.576s
                              └─swap.target @9.917s
                                └─dev-disk-by\x2duuid-420eef95\x2d688c\x2d40bd\x2dab12\x2d8662342ff8de.swap @8.521s +1.395s
                                  └─dev-disk-by\x2duuid-420eef95\x2d688c\x2d40bd\x2dab12\x2d8662342ff8de.device @8.520s

After analyzing the log files as explained in the post I linked to above I noticed that the main slow-down was caused by NetworkManager waiting for IPv6 to activate. As I hadn't enabled any support for it on my network, I just disabled it in "NetworkManager -> Edit Connections -> IPv6 Settings: Ignore".

This shaved off another 20 seconds from the boot process:
Code: [Select]
systemd-analyze
Startup finished in 9.235s (kernel) + 30.131s (userspace) = 39.366s
graphical.target reached after 30.124s in userspace

Code: [Select]
systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @30.124s
└─multi-user.target @30.124s
  └─smbd.service @29.666s +457ms
    └─nmbd.service @24.134s +5.530s
      └─network-online.target @24.132s
        └─NetworkManager-wait-online.service @20.163s +3.969s
          └─NetworkManager.service @16.606s +3.553s
            └─dbus.service @16.388s
              └─basic.target @16.336s
                └─sockets.target @16.336s
                  └─avahi-daemon.socket @16.336s
                    └─sysinit.target @16.305s
                      └─systemd-timesyncd.service @16.097s +207ms
                        └─systemd-tmpfiles-setup.service @15.994s +101ms
                          └─systemd-journal-flush.service @3.718s +12.274s
                            └─systemd-remount-fs.service @2.633s +1.084s
                              └─systemd-journald.socket @2.602s
                                └─system.slice @2.602s
                                  └─-.slice @2.244s

 8)
 

Re: Solution to slow booting
« Reply #6 on: November 11, 2019, 02:30:35 PM »
 

vitorsm7

  • New to Forums
  • *
  • 1
    Posts
  • Country: br
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.6 64bit
I registered on this site just to thank you for this post. Thank you so much for this help!
 

Re: Solution to slow booting
« Reply #7 on: November 26, 2019, 04:19:43 AM »
 

Paul74

  • New to Forums
  • *
  • 43
    Posts
  • Country: fr
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Intel Core I3 M380

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Cedar
Hello,

Very interesting !
Using a SSD, my PC boots in less than 20 seconds.
Last Edit: November 26, 2019, 04:23:00 AM by Paul74
 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky