You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
Installing Lite 5.6 on a Lenovo Thinkcentre

Author (Read 554 times)

0 Members and 1 Guest are viewing this topic.

Installing Lite 5.6 on a Lenovo Thinkcentre
« on: September 21, 2021, 05:28:53 AM »
 

number6

  • New to Forums
  • *
  • 2
    Posts
  • Country: fr
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i5-8400T

  • MEMORY: 24Gb

  • VIDEO CARD: Intel UHD Graphics 630

  • Kernel: 5.x
I've been using Linux as main Operating System for more than 20 years.
In past years, I gave Gnome, Kde Plasma, Mate a try but in the end I always revert back to Xfce
due to simplicity, stability. 
Lately I tried Xubuntu 20.04 but I found it disappointing (bugs, slowness) - if you want to use Kde use either Kde Neon or
Manjaro Kde Plasma- so you get an updated version of Kde. Find below my (raw) feedback. I hope it can be of interest. :003:


Installation of Lite 5.6 went smooth - no issue to report (I created a /home partition before installation)

I missed some applications which were not installed by default. I'm not fond of snap and I tried to add them
through apt & Lite Software (Chromim)  but had to add extra PPAs and even AppImage sofware : 
- Extra PPA :  signal (Messaging)  - instructions on  https://signal.org/download/linux/
- Exra PPA : virtualbox (so I can get the most recent version) - instructions https://linuxhint.com/install-virtualbox-linux/ as I need a Windows 10 VM from time to time.
- Extra DEB : yacreader  (a great comics reader) -  https://yacreader.com/downloads
- Extra packages : chromium (always good to have two browsers), audacious (for music), featherpad (to edit text), neofetch, keepassxc, firejail, opensssh-server, dnscrypt, qbittorrent, youtube-dl
I often have to  find duplicate files on disks  and edit (cut, extract) videos on my system. The best software for these tasks I found are :
Losslesscut (VidCutter stopped working) &  czkawka (fslint no longer works/no longer as package). Unfortunately they are not available through deb, PPA but as AppImages.
So I added AppImageLauncher - https://itsfoss.com/use-appimage-linux/ and downloaded the AppImages on
https://github.com/mifi/lossless-cut/releases/ and  https://github.com/qarmin/czkawka/releases/
The youtube-dl package is old (on Kubuntu I had a more recent version through snap) - I had to download the most recent binary version on
the official website - in the past there were extra PPAs but it seems there are gone.

Mousepad has no auto-save feature so you can loose files if your system hangs or face a power issue and don't save on frequent basis. I therefore had to install Featherpad
Vlc is installed by default but I prefer audacious to play music- it's lightweight. 

I replaced ntp by chrony : ntpd listens on network interfaces (not just loopback), chrony does not and is way more modern.
I unistalled samba (also listening on network interface) - I don't want other systems to use my workstation as a Windows server/storage
For ad-blocking on browsers I use Ublock Origin. DO NOT USE the webext-ublock-origin  package, it does not block. Download the version through Mozilla
& Chrome stores.

Tweaks I did :
- I added the Xfce weather applet to the panel
- I found the fonts way too big by default  for terminal and Desktop - I have an external screen
- Configure terminal for F12 xfce-terminal drop down - Yakuake like https://averagelinuxuser.com/xfce-drop-down-terminal/
- Speed up / mounting add noatime in /etc/fstab

Bugs I faced :
- Network printer (Brother) configuration failing. I was not able to add my printer (no issue on Manjaro)
Cups errors :
E [20/Sep/2021:18:58:25 +0200] [Client 16] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/ImprimanteBrother) from localhost.
E [20/Sep/2021:18:58:32 +0200] [CGI] Unable to create PPD file: Could not poll sufficient capability info from the printer (ipp://Brother%20HL-L2350DW%20series._ipp._tcp.local/, ipp://BRW4CEBBD48F800.local:631/ipp/print) via IPP!
CLI command : 
driverless ipp://Brother%20HL-L2350DW%20series._ipp._tcp.local/
ERROR: Unable to create PPD file: Could not poll sufficient capability info from the printer (ipp://Brother%20HL-L2350DW%20series._ipp._tcp.local/, ipp://BRW4CEBBD48F800.local:631/ipp/print) via IPP!
This is due to .local (multicast) resolution not working.
Package libnss-mdns  was not installed.  In addition /etc/nsswitch.conf needed some fixing :
hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
instead of
hosts:          files dns
- Wrong gif association (Firefox) - should be ImageViewer - blame it on Ubuntu
- A few French translation issues (mousepad, Xfce Menu) - but it's not Lite's fault
- Some Apparmor errors - again Ubuntu's fault :
Apparmor errors : apparmor="DENIED" operation="open" profile="/usr/bin/evince-thumbnailer" name="/tmp/tumbler-X70EP90.png"
Need to add to /etc/apparmor.d/usr.bin.evince : owner /tmp/evince-thumbnailer*/{,**} rw,
There are others errors for cups...


In a few words, Lite performs very well. I don't have any major issue. I'm satisfied. i'll keep it . :045: :045: :045:
It's stable :048:. I'm longing for the version based on Ubuntu 22.04 LTS - but I will wait several months after the release to give it a try and compare it to Linux Voyager - also based on Xubuntu
which is a bit more polished (font size/selection, desktop backgrounds, applications by default) but consumes way more resources.



What's next ?
Adding a more recent libreoffice version  (7.2.1) - https://www.libreoffice.org/download/appimage/ for improved Office compatibility
Adding extra software (gthumbs for photos collection sorting, mpd and ymuse - https://github.com/yktoo/ymuse for playing my MP3 collection, qemu to test Linux ISOs : qemu-system-x86_64 -M pc -vga std  -enable-kvm -cpu host -m 4096 -hda  isofile)
Add a more recent kernel package (5.14 ?) - not sure if I should see some performances improvement and this is really worth the effort
Install Variety to change desktop pictures automatically
Install goodvibes (lightweight internet radio player ) - which also requires   gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio so far not needed
 


Re: Installing Lite 5.6 on a Lenovo Thinkcentre
« Reply #1 on: September 26, 2021, 03:32:00 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8150
    Posts
  • Country: nz
  • Reputation: 761
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Just trialing Featherpad, suggest others give it a go. Quite nice so far, does lag a lot on larger files with a lot of syntax highlighting, hopefully will get faster.
 

Re: Installing Lite 5.6 on a Lenovo Thinkcentre
« Reply #2 on: September 30, 2021, 10:22:18 AM »
 

number6

  • New to Forums
  • *
  • 2
    Posts
  • Country: fr
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i5-8400T

  • MEMORY: 24Gb

  • VIDEO CARD: Intel UHD Graphics 630

  • Kernel: 5.x
Another option is gedit which comes with some nice features  https://www.debugpoint.com/2021/04/gedit-features/
So far I edit only some small text files / do not program therefore I didn't face some lagging issues.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements