You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
System Bootorder not found - grub menu disappeared

Author (Read 2250 times)

0 Members and 2 Guests are viewing this topic.

System Bootorder not found - grub menu disappeared
« on: April 27, 2021, 11:16:16 PM »
 

adml

  • New to Forums
  • *
  • 35
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
Using LL 5.2. Several updates were installed today and after the required reboot, in addition to the grub menu screen disappearing, the message, "System Bootorder not found. Initializing Defaults." began to appear. The PC however did boot. Checking Grub Customizer, the show menu box was still checked. Following the instructions in the last post of this thread...

https://forums.linuxmint.com/viewtopic.php?t=305736

...I was able to make the, "System Bootorder not found. Initializing Defaults." message disappear. However, the grub menu screen still does not appear, even though the show menu box remains checked. Searching for a way to fix the issue I found this:

https://www.aioboot.com/en/show-grub2-menu/

However, the change suggested in the article is already in place on my PC. The change likely having been made because of the Grub Customizer setting for show menu.

A couple of additional notes. After some updates a few days ago I had to ditch the 4.4 kernel that I was using (so that the micro SD reader would be recognized) because of a kernel panic and a non-booting system. I'm now using 5.4, without a working micro SD card reader. Also, the Shift and Esc keys do not now, nor did they ever, make the grub menu screen appear on this PC.

Any ideas on what I can do to make the grub menu screen appear again ?
 


Re: System Bootorder not found - grub menu disappeared
« Reply #1 on: April 28, 2021, 02:23:50 PM »
 

j8a

  • New to Forums
  • *
  • 36
    Posts
  • Country: ar
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: AMD FX-8320E Buldozer

  • MEMORY: 8Gb

  • VIDEO CARD: NVIDIA C61 [GeForce 7025 / nForce 630a]

  • Kernel: 5.x
Hi,
Could you post the output of the following terminal command?

cat /etc/default/grub

in order to give you an apporpiate answer.

Hope this help, regards
 

Re: System Bootorder not found - grub menu disappeared
« Reply #2 on: April 28, 2021, 08:46:03 PM »
 

adml

  • New to Forums
  • *
  • 35
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
@j8a
Thank you for the response. Here is the output:

cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 5.4.0-72-generic"
#GRUB_DEFAULT="0"
GRUB_SAVEDEFAULT="false"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
#GRUB_DISTRIBUTOR="Linux Lite"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Linux Lite Grub background
GRUB_BACKGROUND="/boot/grub_linux_lite.png"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_DISABLE_OS_PROBER="false"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
 

Re: System Bootorder not found - grub menu disappeared
« Reply #3 on: April 30, 2021, 10:05:06 AM »
 

j8a

  • New to Forums
  • *
  • 36
    Posts
  • Country: ar
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: AMD FX-8320E Buldozer

  • MEMORY: 8Gb

  • VIDEO CARD: NVIDIA C61 [GeForce 7025 / nForce 630a]

  • Kernel: 5.x
Hi, I do not way you have several lines different. I post the difference in the /etc/default/grub
GRUB_DEFAULT=0
GRUB_SAVEDEFAULT=true
GRUB_TIMEOUT_STYLE=menu
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Linux Lite'
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Also you have to uncomment
#GRUB_DISABLE_OS_PROBER="false"
whether you are experiencing troubles with your boot process.
It was disabled by security purposes but I think you must check this. Are you dual booting with Windows?

Hope this help, regards
 

Re: System Bootorder not found - grub menu disappeared
« Reply #4 on: May 01, 2021, 07:58:55 PM »
 

adml

  • New to Forums
  • *
  • 35
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
@j8a
Thank you for the response. I'm not dual booting, LL is the only OS.

The only changes made to grub have been by either the original install, LL updates, or Grub Customizer. When I installed LL the grub menu was not showing and no key combination would make it appear so I installed Grub Customizer, checked the show menu box, and the grub menu began to appear. Several days ago after installing some updates and rebooting, the grub menu disappeared, even though the show menu box is still checked in Grub Customizer.

Why did the grub menu disappear ? Clearly something in one of those updates made it disappear, but another question is, why isn't Grub Customizer making the menu show ? It's likely that I'll not find the answers to either question.

After some additional poking around on the Internet I found an article that said uncommenting this line...

#GRUB_TERMINAL="console"

...would make the menu appear.

That worked and the menu is now appearing at boot. However, it's a bit different as it's monochrome, and there's no feather, but I guess that's to be expected from a console version. But, the above questions remain unanswered.

Given the issues I've had with this PC, micro SD reader only working with the 4.4 kernel, having to ditch that kernel due to an update, and now the grub menu disappearing for an unknown reason, I'm going to have to go back to Windows on this PC. It will run much slower, but, I won't have these issues.

LL will remain installed on a Dell PC that I have, it's one of those that came with 2 GB of ram and a 32 GB eMMC hard drive. In addition to LL I installed a 4 GB ram chip and that PC now flies. I've had no issues at all with LL on that PC, everything just works right out of the box.

Thanks again for your responses, I appreciate it.
 

Re: System Bootorder not found - grub menu disappeared
« Reply #5 on: May 01, 2021, 08:03:14 PM »
 

Artim

  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 490
    Posts
  • Country: us
  • Reputation: 64
  • All the Cool Kids Use Linux Lite!
    • Confessions of a Technophobe

  • Linux Lite: 5.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller

  • Kernel: 5.x
A shot in the dark, but have you run

Code: [Select]
sudo-apt-get update-grubsince updating?

 

Re: System Bootorder not found - grub menu disappeared
« Reply #6 on: May 03, 2021, 08:52:10 PM »
 

adml

  • New to Forums
  • *
  • 35
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
@Artim
Thank you for the post.

Yes, after Grub Customizer would not bring the grub menu back I updated via the command line. No change, the menu still didn't appear.

On a whim I installed, and updated during the install, LL 5.4, and as expected, because I believe that this is due to an issue with the Ubuntu updates, the same issues occurred:

System BootOrder not found. Initializing Defaults.
and, no grub menu

Just to make certain that it was an Ubuntu issue and not a LL issue, I installed, and updated during the install, Zorin OS Lite. As I expected, the exact same issues occurred. I don't think there's any doubt that it's due to an issue with one, or more, of those recent Ubuntu updates.

Wanting to check a non Ubuntu distro I installed and updated MX Linux. These issues did not occur and I've had no problems, so far, using MX Linux, other than the card reader, but that's a kernel issue.

 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements