Hardware - Support > Start up and Shutdown

System Bootorder not found - grub menu disappeared

(1/2) > >>

Thank you for the post.

Yes, after Grub Customizer would not bring the grub menu back I updated via the command line. No change, the menu still didn't appear.

On a whim I installed, and updated during the install, LL 5.4, and as expected, because I believe that this is due to an issue with the Ubuntu updates, the same issues occurred:

System BootOrder not found. Initializing Defaults.
and, no grub menu

Just to make certain that it was an Ubuntu issue and not a LL issue, I installed, and updated during the install, Zorin OS Lite. As I expected, the exact same issues occurred. I don't think there's any doubt that it's due to an issue with one, or more, of those recent Ubuntu updates.

Wanting to check a non Ubuntu distro I installed and updated MX Linux. These issues did not occur and I've had no problems, so far, using MX Linux, other than the card reader, but that's a kernel issue.

A shot in the dark, but have you run

--- Code: ---sudo-apt-get update-grub
--- End code ---
since updating?

Thank you for the response. I'm not dual booting, LL is the only OS.

The only changes made to grub have been by either the original install, LL updates, or Grub Customizer. When I installed LL the grub menu was not showing and no key combination would make it appear so I installed Grub Customizer, checked the show menu box, and the grub menu began to appear. Several days ago after installing some updates and rebooting, the grub menu disappeared, even though the show menu box is still checked in Grub Customizer.

Why did the grub menu disappear ? Clearly something in one of those updates made it disappear, but another question is, why isn't Grub Customizer making the menu show ? It's likely that I'll not find the answers to either question.

After some additional poking around on the Internet I found an article that said uncommenting this line...


...would make the menu appear.

That worked and the menu is now appearing at boot. However, it's a bit different as it's monochrome, and there's no feather, but I guess that's to be expected from a console version. But, the above questions remain unanswered.

Given the issues I've had with this PC, micro SD reader only working with the 4.4 kernel, having to ditch that kernel due to an update, and now the grub menu disappearing for an unknown reason, I'm going to have to go back to Windows on this PC. It will run much slower, but, I won't have these issues.

LL will remain installed on a Dell PC that I have, it's one of those that came with 2 GB of ram and a 32 GB eMMC hard drive. In addition to LL I installed a 4 GB ram chip and that PC now flies. I've had no issues at all with LL on that PC, everything just works right out of the box.

Thanks again for your responses, I appreciate it.

Hi, I do not way you have several lines different. I post the difference in the /etc/default/grub
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

Also you have to uncomment
whether you are experiencing troubles with your boot process.
It was disabled by security purposes but I think you must check this. Are you dual booting with Windows?

Hope this help, regards

Thank you for the response. Here is the output:

cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 5.4.0-72-generic"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"

# Linux Lite Grub background

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"



[0] Message Index

[#] Next page

Go to full version